update-manager: E:Error, pkgProblemResolver::Resolve generated breaks

Bug #980502 reported by Tuomas Heino on 2012-04-13
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Seen while attempting to upgrade couple weeks outdated installation of Precise:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.10
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Fri Apr 13 08:04:19 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120112)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IE:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Tuomas Heino (iheino+ub) wrote :

I have seen many issues on this thing . but what you got aftre doing this
sudo -i
apt-get autoclean
apt-get autoremove
apt-get upgrade
apt-get dist-upgrade

Changed in update-manager (Ubuntu):
status: New → Confirmed
Tuomas Heino (iheino+ub) on 2012-04-13
tags: added: dist-upgrade
Tuomas Heino (iheino+ub) wrote :

The following packages have unmet dependencies:
 gwibber : Depends: gwibber-service (= 3.4.0-0ubuntu2) but 3.4.0-0ubuntu3 is to be installed
 gwibber-service : Breaks: gwibber (< 3.4.0-0ubuntu3) but 3.4.0-0ubuntu2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Might mean just that the mirrors are not yet up to date...

Tuomas Heino (iheino+ub) wrote :

Seems related to bug #932581

yeah its similar to that

Kosmic Jok (kosmicjok) wrote :

I get similar error when trying to upgrade to 13.04 from 12.10. (amd64)

xpdf is understandable since xpdf,rep-gtk is marked as hold to an older version, but there should not be any problem in openssh,xemacs
Here is the output of sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 libbamf3-0 : Depends: bamfdaemon (= 0.3.4-0ubuntu1)
 libsm6:i386 : Depends: libuuid1:i386 (>= 2.16) but it is not going to be installed
 openssh-client : Depends: adduser (>= 3.10) but it is not going to be installed
                  Depends: passwd
 openssh-server : Depends: upstart-job
                  Depends: adduser (>= 3.9) but it is not going to be installed
                  Depends: procps
 xemacs21 : Depends: xemacs21-mule (>= 21.4.22-3.2ubuntu2) but it is not going to be installed or
                     xemacs21-mule-canna-wnn (>= 21.4.22-3.2ubuntu2) but it is not going to be installed or
                     xemacs21-nomule (>= 21.4.22-3.2ubuntu2) but it is not going to be installed
 xpdf : Depends: lesstif2 (>= 1:0.94.4) but it is not going to be installed
        Depends: libxt6 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Kosmic Jok (kosmicjok) on 2013-04-21
tags: added: quantal

Ok held packages can get back with dist-upgrade

open your terminal and type as

sudo apt-get update
sudo apt-get dist-upgrade

Kosmic Jok (kosmicjok) wrote :

dist-updgrade doesn't work.
But I was able to upgrade to raring with do-release-upgrade.
The errors have dispappeared in raring.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers