update-manager unable to compute update (3rd party nvidia)

Bug #96673 reported by tjacobs on 2007-03-26
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

This may be the same as bug 63723 but since I'm not sure, I'm submitting.
update-manager tells me not all upgrades can be installed and asks that I perform a distribution upgrade.
When I attempt, I get a message "Could not calculate the upgrade"
I'm running Ubuntu 6.10.

From the page I'm submitting this bug I don't see a way to attach files.
If it becomes obvious to me after clicking the "Submit Bug Report", I'm upload
apt.log and term.log ;-)

tjacobs (twjacobs) wrote :

apt.log is attached, term.log is empty.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please attach your /etc/apt/sources.list? Did you install the nvidia driver manually?

Thanks,
 Michael

Changed in update-manager:
status: Unconfirmed → Needs Info

Hi Mike,
Actually, my son installed the graphics driver...
Attached is the sources.list

Thanks,
Tim

On Tue, 2007-03-27 at 12:01 +0000, Michael Vogt wrote:
> Thanks for your bugreport.
>
> Could you please attach your /etc/apt/sources.list? Did you install the
> nvidia driver manually?
>
> Thanks,
> Michael
>
> ** Changed in: update-manager (Ubuntu)
> Status: Unconfirmed => Needs Info
>

HI,

it looks like the attachment did not make it to here. If you send it by mail you may have to go to launchpad.net and attach it manually.

Sorry for the trouble,
 Michael

tjacobs (twjacobs) wrote :

2nd attempt to get you sources.list. This time through launchpad.net

Mike,
I uploaded the file from launchpad.net. It appears to be there now.
Thanks again for looking into this.

On Thu, 2007-03-29 at 12:46 +0000, Michael Vogt wrote:
> HI,
>
> it looks like the attachment did not make it to here. If you send it by
> mail you may have to go to launchpad.net and attach it manually.
>
> Sorry for the trouble,
> Michael
>

tjacobs (twjacobs) wrote :

Hi Michael,
Any progress on this?

Thanks,
Tim

On Tue, 2007-03-27 at 12:01 +0000, Michael Vogt wrote:
> Thanks for your bugreport.
>
> Could you please attach your /etc/apt/sources.list? Did you install the
> nvidia driver manually?
>
> Thanks,
> Michael
>
> ** Changed in: update-manager (Ubuntu)
> Status: Unconfirmed => Needs Info
>

There's evidence of automatrix in the log files.

tjacobs:
What is the output of:
dpkg -l nvidia-\* | grep ii
dpkg -l \*envy\* | grep ii
dpkg -l \*autom\* | grep ii

tjacobs (twjacobs) wrote :

Hi Sitsofe, here is the output requested:
tjacobs@tjacobs-desktop:~$ dpkg -l nvidia-\* | grep ii
ii nvidia-glx 1.0.9629+2.6.17.6-2~amaranth NVIDIA binary XFree86 4.x/X.Org driver
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files
tjacobs@tjacobs-desktop:~$ dpkg -l \*envy\* | grep ii
No packages found matching *envy*.
tjacobs@tjacobs-desktop:~$ dpkg -l \*autom\* | grep ii
ii automake1.9 1.9.6-4 A tool for generating GNU Standards-complian
ii automatix2 1.1-3.3-6.10edgy_i386 Automatix is a graphical interface for autom
tjacobs@tjacobs-desktop:~$

Sitsofe Wheeler (sitsofe) wrote :

Setting back to unconfirmed. The nvidia-glx 1.0.9629+2.6.17.6-2~amaranth package looks like it came from a 3rd party repository. It would be interesting to know where it came from...

Changed in update-manager:
status: Needs Info → Unconfirmed
tjacobs (twjacobs) wrote :

According to my sources.list file, the driver came from here:

##Nvidia proprietary driver repository
deb http://seerofsouls.com/ edgy contrib

Also, googling the package, I see it only shows up in that repo as well. So I'm pretty confident that's it.

Adam Niedling (krychek) wrote :

Is this still an issue? Edgy is not supported anymore.

Changed in update-manager:
status: New → Incomplete

Adam Niedling wrote:
> Is this still an issue? Edgy is not supported anymore.
>
> ** Changed in: update-manager (Ubuntu)
> Status: New => Incomplete
>
>
No,
I have upgraded several times by now.

Thanks for following up. I'm closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Incomplete → Invalid
Adam Niedling (krychek) on 2008-11-15
Changed in update-manager:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers