package libcryptsetup4 2:1.4.1-2ubuntu2 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

Bug #964115 reported by Bluppie on 2012-03-24
68
This bug affects 6 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

Just updating from 11.10 to 12.04

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libcryptsetup4 2:1.4.1-2ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Sat Mar 24 15:54:44 2012
ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: cryptsetup
Title: package libcryptsetup4 2:1.4.1-2ubuntu2 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured
UpgradeStatus: No upgrade log present (probably fresh install)

Bluppie (benhyper) wrote :
Steve Langasek (vorlon) wrote :

The root error in your log is:

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-20-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.2.0-20-generic with 1.
dpkg: error processing initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of dmsetup:
 dmsetup depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.

This is not a bug in cryptsetup, but a cascading failure caused by running out of disk space on your /boot partition.

update-manager should have been able to predict that you would run out of space on /boot, and advised you to free more space before the upgrade.

Can you please show the output of the following commands?

  df -h /boot
  ls -l /boot

affects: cryptsetup (Ubuntu) → update-manager (Ubuntu)
Changed in update-manager (Ubuntu):
status: New → Incomplete
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: Undecided → High
tags: added: rls-mgr-p-tracking
  • boot2.txt Edit (105 bytes, text/plain; charset=US-ASCII; name="boot2.txt")
  • boot.txt Edit (543 bytes, text/plain; charset=US-ASCII; name="boot.txt")

Hereby the output.

Greeting, Ben

May the force be with you

© BenHyper

2012/3/25 Steve Langasek <email address hidden>

> The root error in your log is:
>
> Processing triggers for initramfs-tools ...
> update-initramfs: Generating /boot/initrd.img-3.2.0-20-generic
>
> gzip: stdout: No space left on device
> E: mkinitramfs failure cpio 141 gzip 1
> update-initramfs: failed for /boot/initrd.img-3.2.0-20-generic with 1.
> dpkg: error processing initramfs-tools (--configure):
> subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of dmsetup:
> dmsetup depends on initramfs-tools; however:
> Package initramfs-tools is not configured yet.
>
> This is not a bug in cryptsetup, but a cascading failure caused by
> running out of disk space on your /boot partition.
>
> update-manager should have been able to predict that you would run out
> of space on /boot, and advised you to free more space before the
> upgrade.
>
> Can you please show the output of the following commands?
>
> df -h /boot
> ls -l /boot
>
> ** Package changed: cryptsetup (Ubuntu) => update-manager (Ubuntu)
>
> ** Changed in: update-manager (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: update-manager (Ubuntu)
> Assignee: (unassigned) => Canonical Foundations Team
> (canonical-foundations)
>
> ** Changed in: update-manager (Ubuntu)
> Importance: Undecided => High
>
> ** Tags added: rls-mgr-p-tracking
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/964115
>
> Title:
> package libcryptsetup4 2:1.4.1-2ubuntu2 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
>
> Status in “update-manager” package in Ubuntu:
> Incomplete
>
> Bug description:
> Just updating from 11.10 to 12.04
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libcryptsetup4 2:1.4.1-2ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic i686
> ApportVersion: 1.95-0ubuntu1
> Architecture: i386
> Date: Sat Mar 24 15:54:44 2012
> ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
> SourcePackage: cryptsetup
> Title: package libcryptsetup4 2:1.4.1-2ubuntu2 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/964115/+subscriptions
>

Steve Langasek (vorlon) wrote :

well, this shows only a single kernel in /boot. Did you clean up the directory after hitting the error?

Bluppie (benhyper) wrote :

Jes and with Beathbit I dit some cleaning to.

swap device /dev/sda1 is larger than expected (Bleathbit)

Chromium kan niet opgeschoond worden omdat het nog in gebruik is. Sluit het
af en probeer het opnieuw.
Chromium is in use? I am using Firefox.

E: Kon het vergrendelingsbestand '/var/cache/apt/archives/lock' niet openen
- open (13: Toegang geweigerd)
E: Kon het vergrendelingsbestand '/var/lib/dpkg/lock' niet openen - open
(13: Toegang geweigerd)
Is this an Bleachbit error?

[Errno 39] Map is niet leeg: '/home/ben/.cache/wallpaper'

[Errno 39] Map is niet leeg:
'/home/ben/.thunderbird/ewjeo8mh.default/Cache/3'
[Errno 39] Map is niet leeg:
'/home/ben/.thunderbird/ewjeo8mh.default/Cache/5'
[Errno 39] Map is niet leeg:
'/home/ben/.thunderbird/ewjeo8mh.default/Cache/9'

I was updating from 11.10 to 12.04 so no fresh install.

May the force be with you

© BenHyper

2012/3/27 Steve Langasek <email address hidden>

> well, this shows only a single kernel in /boot. Did you clean up the
> directory after hitting the error?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/964115
>
> Title:
> package libcryptsetup4 2:1.4.1-2ubuntu2 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
>
> Status in “update-manager” package in Ubuntu:
> Incomplete
>
> Bug description:
> Just updating from 11.10 to 12.04
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libcryptsetup4 2:1.4.1-2ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic i686
> ApportVersion: 1.95-0ubuntu1
> Architecture: i386
> Date: Sat Mar 24 15:54:44 2012
> ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
> SourcePackage: cryptsetup
> Title: package libcryptsetup4 2:1.4.1-2ubuntu2 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/964115/+subscriptions
>

Steve Langasek (vorlon) wrote :

ok, since you've already cleaned up the disk I think it will be difficult for us to make a useful analysis of this bug. Leaving the bug report open for now however in case more information becomes available.

Steve Langasek (vorlon) on 2012-04-19
tags: added: rls-p-nottracking
removed: rls-mgr-p-tracking
Brian Murray (brian-murray) wrote :

The log file main.log contains information about the state of the user's partitions at the time of the upgrade:

2012-03-24 09:37:43,158 DEBUG Free space on /: 2598268928
2012-03-24 09:37:43,158 DEBUG Dir /usr mounted on /
2012-03-24 09:37:43,158 DEBUG Dir /var mounted on /
2012-03-24 09:37:43,159 DEBUG Dir /boot mounted on /
2012-03-24 09:37:43,159 DEBUG Dir /var/cache/apt/archives mounted on /
2012-03-24 09:37:43,159 DEBUG Dir /tmp mounted on /
2012-03-24 09:37:43,159 DEBUG Free space on /home: 16584757248
2012-03-24 09:37:43,159 DEBUG Dir /tmp mounted on /
2012-03-24 09:37:43,160 DEBUG fs_free contains: '{'/var': <DistUpgradeCache.FreeSpace object at 0xb02ffcc>, '/tmp': <DistUpgradeCache.FreeSpace object at 0xb02ffcc>, '/usr': <DistUpgradeCache.FreeSpace object at 0xb02ffcc>, '/boot': <DistUpgradeCache.FreeSpace object at 0xb02ffcc>, '/home': <DistUpgradeCache. FreeSpace object at 0xb02526c>, '/': <DistUpgradeCache.FreeSpace object at 0xb02ffcc>, '/var/cache/apt/archives': <DistUpgradeCache.FreeSpace object at 0xb02ffcc>}'
2012-03-24 09:37:44,061 DEBUG linux-image-3.2.0-20-generic (new-install) added with 22344507 to boot space
2012-03-24 09:37:45,345 DEBUG dir '/var/cache/apt/archives' needs '1658759950' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (2598268928.000000)
2012-03-24 09:37:45,346 DEBUG dir '/usr' needs '441409536' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (939508978.000000)
2012-03-24 09:37:45,346 DEBUG dir '/usr' needs '52428800' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (498099442.000000)
2012-03-24 09:37:45,346 DEBUG dir '/boot' needs '22344507' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (445670642.000000)
2012-03-24 09:37:45,346 DEBUG dir '/tmp' needs '5242880' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (423326135.000000)
2012-03-24 09:37:45,346 DEBUG dir '/' needs '10485760' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (418083255.000000)
2012-03-24 09:37:45,347 DEBUG dir '/tmp' needs '0.0' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (407597495.000000)
2012-03-24 09:37:45,347 DEBUG dir '/usr' needs '0.0' of '<DistUpgradeCache.FreeSpace object at 0xb02ffcc>' (407597495.000000)

jo (jonstro) wrote :

I had nearly such an problem with Linux-image-generic-3.5.45 when i update from Lubuntu 12.4 to 12.10

peterstan (stasnel) on 2015-08-22
Changed in update-manager (Ubuntu):
status: Incomplete → Fix Committed
status: Fix Committed → Fix Released
Changed in update-manager (Ubuntu):
status: Fix Released → Confirmed
assignee: Canonical Foundations Team (canonical-foundations) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers