Can not update packages - nothing happens after package download

Bug #960914 reported by Thomas Bechtold on 2012-03-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
APT
New
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I started update-manager and after the package download, nothing happens. the terminal is empty.

i tried to use "apt-get upgrade" (and also apt-get dist-upgrade) but this has the same effect. after the package download, nothing happens.

$ sudo apt-get dist-upgrade
[sudo] password for tom:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
...
...
...
295 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/430 MB of archives.
After this operation, 9,139 kB of additional disk space will be used.
Do you want to continue [Y/n]?

That's all.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.8
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic-pae 3.2.11
Uname: Linux 3.2.0-19-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Aptdaemon:

Architecture: i386
Date: Wed Mar 21 08:12:06 2012
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1332284984
 com.ubuntu.update-manager show-details true
 com.ubuntu.update-manager window-height 847
 com.ubuntu.update-manager window-width 1041
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: Upgraded to precise on 2012-03-13 (7 days ago)

Thomas Bechtold (toabctl) wrote :
Thomas Bechtold (toabctl) wrote :

i'm able to install the updates with "dpkg -i --force-yes /var/cache/apt/archives/*.deb".

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What is the output of:
$ sudo apt-get install -f
$ apt-get dist-upgrade --simulate -y
?
This might be a Dpkg::Pre-Invoke hook going berserk so the output of:
$ apt-config dump|grep Pre-In
would also be helpful.

Thomas Bechtold (toabctl) wrote :

after i did "dpkg -i --force-yes /var/cache/apt/archives/*.deb", "apt-get upgrade" works again. i think the output of the command is useless, then? there are no packages left for installation.

Michael Vogt (mvo) wrote :

Yes, please add the info if you encounter the bug again.

Changed in update-manager (Ubuntu):
status: New → Invalid
Thomas Bechtold (toabctl) wrote :

The problem is back. see attachment for requested command output.

Changed in update-manager (Ubuntu):
status: Invalid → New
Thomas Bechtold (toabctl) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers