update-manager crashed with ValueError in /usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py: bad marshal data (unknown type code)

Bug #954344 reported by GuyR on 2012-03-13
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu 12.04 Beta1

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.8
Uname: Linux 3.2.11-030211-generic i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CheckboxSubmission: 592d2a6e0d18bcb44c8ff4a0517b9d98
CheckboxSystem: 4029317434a5f787a60302f0f64e8786
Date: Tue Mar 13 20:12:45 2012
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1331661466
 com.ubuntu.update-manager show-details true
 com.ubuntu.update-manager window-height 600
 com.ubuntu.update-manager window-width 600
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/update-manager
ProcEnviron:
 LANGUAGE=fr_FR:fr:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with ValueError in /usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py: bad marshal data (unknown type code)
UpgradeStatus: Upgraded to precise on 2012-03-09 (4 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lp lpadmin mythtv netdev plugdev root scanner tape video

GuyR (guy-rouger) wrote :
visibility: private → public
tags: removed: need-duplicate-check
GuyR (guy-rouger) wrote :

Occurs each time
I must use comnd line
sudo apt-get update
sudo apt-get upgrade
Les paquets suivants seront mis à jour :
  cpp-4.4 gcc-4.4 gcc-4.4-base python-gobject-2 python-pyatspi2
  python-software-properties software-properties-common
  software-properties-gtk usb-creator-common usb-creator-gtk

But it is the same update-manager is broken

iuuuuan (ivan-janes) wrote :

I had same issue. Try to reinstall with synaptic package manager these two packages :
- update-manager
- update-manager-core

Search for update manager, right click both packages, select Mark for Reinstallation and click Apply

iuuuuan (ivan-janes) wrote :

After a reboot update-manager stop to work again ...

So I ran these commands from terminal :

sudo dpkg-reconfigure update-manager-core
sudo dpkg-reconfigure update-manager

Now update-manager works again ...

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed

I followed the above comment by iuuuuan and it worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers