Excruciatingly slow package list onscreen update

Bug #945536 reported by Nick Barcet on 2012-03-03
130
This bug affects 23 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Brian Murray
Precise
High
Brian Murray

Bug Description

Update-manager seem to take something like 0.3s to refresh each package in the list (when there is 343 updates, took about 3 min to refresh the whole list).

To reproduce:
- with some updates waiting
- open update-manager
- click "Description of update" expander
- click on the check button
- wait for the update progress window to close
-> Watch the onscreen package list being slowly updated one package after the other.

Possible cause: extraneous list refresh function being called after each addition/removal to the list

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.6
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Sat Mar 3 12:40:50 2012
DpkgHistoryLog.txt:

DpkgTerminalLog.txt:

EcryptfsInUse: Yes
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1330774583
 com.ubuntu.update-manager show-details true
 com.ubuntu.update-manager window-height 913
 com.ubuntu.update-manager window-width 1173
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: update-manager
UpgradeStatus: Upgraded to precise on 2012-02-16 (16 days ago)

Nick Barcet (nijaba) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. confirmed on Precise

Changed in update-manager (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → ubuntu-12.04-beta-2
tags: added: rls-mgr-p-tracking
Pablo Almeida (pabloalmeidaff9) wrote :

This only happens if the updates description box is shown, so it
looks like the problem is that update manager loads the descriptions
first and only then removes the items from the list.

Nick Barcet (nijaba) on 2012-03-05
summary: - Excrutiatinling slow package list onscreen update
+ Excruciatingly slow package list onscreen update
description: updated
DINAMIK (silpablo) wrote :

still happening in the beta

Changed in update-manager (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Sami Jaktholm (sjakthol) wrote :

This seems to be a problem with the Gtk. When self.store.clear() is called, the items are removed one by one. When an item is selected and it gets removed, the selection moves to the next item. This causes the Gtk to send signal about changed selection (cursor-changed of GtkTreeView) everytime the item with focus is removed.

Update manager invokes the on_treeview_update_cursor_changed function which starts doing things like updating the description and fetching the changelog and causes the lag. And when there's tons of updates to do, this will take a lot of time.

Patch attached containing a workaround for the issue (works for me).

Sami Jaktholm (sjakthol) wrote :

The attachment "Workaround for this issue" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in update-manager (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.156.11

---------------
update-manager (1:0.156.11) precise; urgency=low

  * DistUpgrade/DistUpgrade.cfg.lucid:
    - add in a missing backported package (LP: #969182)
  * DistUpgrade/Distupgrade.py:
    - workaround issue regarding removing selections, thanks to sampo555 for
      the patch (LP: #945536)
  * Automatic update of mirrors, demoted packages and of included source
    packages: base-installer
 -- Brian Murray <email address hidden> Thu, 12 Apr 2012 11:02:52 -0700

Changed in update-manager (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers