UI freeze exception

Bug #942590 reported by Boštjan Mejak on 2012-02-28
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

RELEASE TEAM: I would like to ask for a string-freeze exception to fix this misleading text

In Ubuntu 11.10 (currently the latest stable version of Ubuntu) I found that the Update Manager has this misguiding text displayed in its main window when and only when the updates are available. Below "Software updates are available for your computer" it says this:

"If you don't want to install them now, choose "Update Manager" from Applications later."

And what is wrong here? Well, Ubuntu doesn't have the "Applications" menu anymore. Actually, the old desktop menus in Ubuntu are now long gone, so please re-word this line of text. The place where the user can choose to open the Update Manager later is in the menu that has a "power" icon in the top-right of the screen. Point the user there in the Update Manager when he/she has updates available. Thanks.

tags: added: dist-upgrade
tags: added: update-manager
removed: dist-upgrade
Boštjan Mejak (bostjan.mejak) wrote :

Additional note: The ''menu that has a "power" icon in the top-right of the screen'' that I was referring to is called a session menu.

Boštjan Mejak (bostjan.mejak) wrote :

Please fix this now that Ubuntu 12.04 is still in alpha stage.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Notice that is says "Applications later" not menu. In the dash it is possible to view installed applications and find update-manager. In precise the text displayed is also conditional now and changes depending on whether or not unity is running.

Changed in update-manager (Ubuntu):
importance: Undecided → Low
Boštjan Mejak (bostjan.mejak) wrote :

I chatted with Michael Vogt a.k.a. mvo on irc.freenode.net, the creator of update-manager package, and he instruct me to make a patch for update-manager and was perfectly happy that I make this changes. I did create a patch and so now I am giving it to the world. :) I hope you like my little contribution. Keep up the good work with the Ubuntu project. I love it very much. Peace...

P.S.: Michael, I hope you had a good night sleep. Now it's my turn. :)

The attachment "My solution to the problem..." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

I removed my first patch because I made a mistake in it. My second patch is now okay. I have fixed only those strings under the statement "if is_unity_running()" because the fixed text applies only in the situation when the user has the Unity desktop environment installed.

Michael, I must inform you that the strings that I have fixed are translatable strings, so please inform the translators that they need to update their translations for this package, after you'll apply the patch of course. ;)

Matthew Paul Thomas (mpt) wrote :

Hi John. Thank you for your patch. I have three small suggestions and one big suggestion.

Small suggestions:

1. For readability, instructional text -- whether it appears in a UI or in help -- should not include any ellipses in labels that it is referring to. So "Updates Available..." should instead be "Updates Available".

2. The old text had the same problem, but since you're changing it: UI text should use typographical apostrophes ’ and quotes “”, not Ascii quotes ' "". Abbreviated example of how to do this in Python: _(u"If you don\u2019t want them now, choose \u201cUpdates Available\u201d later.")

3. The accessible title of the last menu is "Device", so the text should refer to it as "the device menu", not "the Session menu".

The big suggestion is that I'd actually prefer the second sentence to be removed altogether. :-) Two reasons for this. First, though the menu has the accessible title "Device", that's not obvious (as you demonstrated yourself), and there's nothing visible that hints which menu is "the device menu" -- so the instruction probably isn't useful anyway. And second, I'd like to move towards the design shown in <https://wiki.ubuntu.com/SoftwareUpdates#alert>, where the only secondary text is context-sensitive (e.g. "The computer will need to restart afterwards.").

Boštjan Mejak (bostjan.mejak) wrote :

Matthew, I like the idea of removing the second sentence altogether, so I made a new patch and removed those second sentences. I also removed the whole "is_unity_running()" thing. Some minor changes were also made, like there was an occurence of "Ubuntu Linux" which I found totally unnecessary as all other occurences say "Ubuntu", so that was changed to only "Ubuntu". I hope my contribution with this patch is welcome to the Ubuntu community.

Developers, if you please, review the patch and commit it if you find it well done. Also, make sure that all the translators are going to be informed about these changes, so that they will, too, accomodate their translations accordingly. Thanks.

Boštjan Mejak (bostjan.mejak) wrote :

Michael, you have asked me on IRC to review my patch again if everything looks good. I have done that and I assure you that the patch is now, finally, perfected and ready to be commited. So, if you please, go ahead and commit. ;)

Matthew Paul Thomas (mpt) wrote :

Thanks again John. You're right to change "Ubuntu Linux" to "Ubuntu". I just have one niggle:

- text_header= "<big><b>%s</b></big>" % _("The software on this computer is up to date.")
+ text_header= "<big><b>%s</b></big>" % _("The software on this computer is up-to-date.")

This should stay as it is. Compound adjectives should generally be hyphenated ("This is an up-to-date computer", "This is open-source software"), but adjective phrases should not be ("This computer is up to date", "This software is open source").

Boštjan Mejak (bostjan.mejak) wrote :

Matthew, you're absolutely right. I fixed my patch now and am uploading it for your another revision. If you now see it fit, then please apply it and commit it. ;)

Boštjan Mejak (bostjan.mejak) wrote :

Matthew, I have a question for you. In UpdateManager/UpdateManager.py there's this code:

if num_updates == 0:
          text_header= "<big><b>%s</b></big>" % _("The software on this computer is up to date.")

Since this string is going to be displayed as a title in bold and not as a normal text label -- should we remove the dot so that the string would be _("The software on this computer is up to date") ??

Boštjan Mejak (bostjan.mejak) wrote :

patch4.diff labeled "This is it" was commited by mvo... Thanks for that. I only need Matthew to tell me about the previous question I was asking. So what's up with that string in question Matthew?

Adolfo Jayme (fitojb) on 2012-03-02
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Committed
Matthew Paul Thomas (mpt) wrote :

The primary text for an alert should be complete sentences, regardless of whether it is bold.

    The software on this computer is up to date.

It's easy to understand this when considering that sometimes the primary text is a question.

    Are you sure you want to close all programs and log out of the computer?

And sometimes it is multiple sentences.

    Ubuntu can’t be updated at the moment. Please try again later.

It would be inconsistent for some of these sentences to have punctuation while others didn't.

Boštjan Mejak (bostjan.mejak) wrote :

My last patch that fixes a missing dot.

Michael Vogt (mvo) on 2012-03-02
summary: - update-manager misguiding text
+ UI freeze exception
description: updated

It looks like this should go in. Please get an ack from docs and translation
teams and then we can approve it.

Michael Vogt (mvo) wrote :

Thanks Scott! Much appreciated.

Michael Vogt (mvo) wrote :

I will mail the docs and translations team now.

Boštjan Mejak (bostjan.mejak) wrote :

With the help of bzr-grep tool I was able to discover that the string "There are no updates to install." (found in UpdateManager/UpdateManager.py) is missing the dot in the .po files. It would be nice if the dot was there in the .po files as well. Please notify the documentation team and/or translation team as you see fit. Thanks.

Boštjan Mejak (bostjan.mejak) wrote :

... The .pot file is okay (the mentioned string has the dot at the end), but the string in the .po files doesn't have the dot at the end. Why is that so? And can you fix that as well and make it into 12.04 LTS?

Scott Kitterman (kitterman) wrote :

That change can be covered by the same exception. I'll leave it to mvo to upload the correct fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.156.7

---------------
update-manager (1:0.156.7) precise; urgency=low

  [ Michael Vogt ]
  * DistUpgrade/DistUpgradeCache.py:
    - fix nvidia detection, thanks to Brian Murray
  * DistUpgrade/xorg_fix_proprietary.py:
    - fix crash when apt_pkg is not initialized (LP: #942106)
  * DistUpgrade/DistUpgradeController.py, DistUpgrade/mirrors.cfg:
    - support upgrades with commercial-ppas in the sources.list
      (LP: #939461) and add tests
  * UpdateManager/UpdateManager.py:
    - fix inaccurate string, thanks to JohnNapster (LP: #942590)

  [ Brian Murray ]
  * DistUpgrade/removal_blacklist.cfg:
    - Only blacklist unity-2d, not all packages whose names start with
      unity-2d. (LP: #940196)
 -- Michael Vogt <email address hidden> Mon, 05 Mar 2012 09:02:14 +0100

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers