use FD.o icon naming

Bug #921310 reported by Daniel Fore on 2012-01-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Undecided
elementary Drive-by Contributors
update-manager (Ubuntu)
Low
Robert Roth

Bug Description

Update manager currently uses the icon name "update-manager" for it's app icon. It would be nice to use the FD.o icon name "system-software-update" instead.

Related branches

Daniel Fore (danrabbit) on 2012-01-25
tags: added: bitesize
Robert Roth (evfool) on 2012-01-26
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in update-manager (Ubuntu):
assignee: nobody → Daniel Polehn (dpolehn-gmail)
Daniel Fore (danrabbit) on 2012-01-30
Changed in elementaryos:
status: New → Confirmed
milestone: none → 0.2-luna
Changed in update-manager (Ubuntu):
assignee: Daniel Polehn (dpolehn-gmail) → nobody
Robert Roth (evfool) on 2012-02-13
Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
Changed in elementaryos:
milestone: 0.2-luna → luna-beta1

Doesn't seem to have anything to do with elementary OS; I can't afford patching update-manager just for the sake of having a proper icon name.

Changed in elementaryos:
status: Confirmed → Invalid
milestone: luna-beta1 → none
Daniel Fore (danrabbit) wrote :

It affects us because we ship it. It doesn't need to be patched, it needs to be fixed upstream. It would be better to leave it confirmed and assign it to drive by.

Changed in elementaryos:
status: Invalid → Confirmed
assignee: nobody → elementary Drive-by Contributors (elementary-driveby)
Robert Roth (evfool) on 2012-03-05
Changed in update-manager (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Michael Vogt (mvo) on 2012-03-05
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in elementaryos:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.156.8

---------------
update-manager (1:0.156.8) precise; urgency=low

  [ Robert Roth ]
  * Update icon name to use FD.o standard (LP: #921310)

  [ Julien Lavergne ]
  * DistUpgrade/DistUpgrade.cfg, DistUpgrade/removal_blacklist.cfg,
    UpdateManager/Core/utils.py,
    AutoUpgradeTester/profile/lubuntu/DistUpgrade.cfg:
   - Add Lubuntu support, and don't upgrade gnome-components which have been
     removed from Lubuntu installation (LP: #945215)

  [ Barry Warsaw ]
  * Improve the warning issued when i8xx graphics hardware is
    detected. (LP: #941172)

  [ Brian Murray ]
  * DistUpgrade/removal_blacklist.cfg:
    - blacklist gnome-session so that users can always login after a failed
      partial upgrade (LP: #946539)

  [ James Hunt ]
  * Only attempt to stop screensaver if DISPLAY set, and throw away
    xdg-screensaver output. (LP: #883618)

  [ Colin Watson ]
  * Use 'from dbus.mainloop.glib import DBusGMainLoop;
    DBusGMainLoop(set_as_default=True)' to set up the main loop, rather than
    importing the deprecated dbus.glib.

  [ Gabor Kelemen ]
  * Fix misplaced parentheses. LP: #952959
 -- Michael Vogt <email address hidden> Tue, 13 Mar 2012 15:29:59 +0100

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers