install missing lang-pack or updates result in a loop

Bug #903271 reported by Sam_ on 2011-12-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Was reproducable.
After installation and updating open language-selector from g-c-c or dash.
It searches for missing lang-packs and advises to install missing aspell-de, confirm to install.
Result: the wheel spins forever, no package will be installed. Tested twice.
## Same behaviour with update-manager, comment #2
Workaround: install aspell-de via terminal, afterwards language-selector opens fine without complains.

Open language-selector in a terminal.
Output:
~$ gnome-language-selector

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed
/usr/lib/python2.7/dist-packages/LanguageSelector/LocaleInfo.py:125: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  if lang_name == self._lang[lang]:
^CTraceback (most recent call last):
  File "/usr/bin/gnome-language-selector", line 27, in <module>
    options=options)
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 245, in __init__
    self.verifyInstalledLangPacks()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 699, in verifyInstalledLangPacks
    self.commit(missing, [])
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 636, in commit_aptdaemon
    self._wait_for_aptdaemon_finish()
  File "/usr/lib/python2.7/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 614, in _wait_for_aptdaemon_finish
    time.sleep(0.02)
KeyboardInterrupt

## Canceld with ctrl+c

~$ apt-cache policy language-selector-gnome
language-selector-gnome:
  Installed: 0.59
  Candidate: 0.59
  Version table:
 *** 0.59 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: language-selector-gnome 0.59
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Uname: Linux 3.2.0-4-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Mon Dec 12 17:24:24 2011
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: language-selector
UpgradeStatus: No upgrade log present (probably fresh install)

Sam_ (and-sam) wrote :
description: updated
Sam_ (and-sam) wrote :

Same issue with update-manager, it pops up, click to install does nothing, the wheel spins endless.
~$ update-manager

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/UpdateManager/MetaReleaseGObject.py", line 42, in check
    def check(self):
KeyboardInterrupt
^C
kill -9 2873
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 584, in msg_reply_handler
    def msg_reply_handler(message):
KeyboardInterrupt
Killed

## ctrl+c did nothing so I've killed it on another tab.

Sam_ (and-sam) wrote :

In the meantime I've assigned to update-manager and add tag language-selector.

affects: language-selector (Ubuntu) → update-manager (Ubuntu)
description: updated
Sam_ (and-sam) on 2011-12-13
tags: added: language-selector
Sam_ (and-sam) on 2011-12-14
summary: - install missing lang-pack does nothing
+ install missing lang-pack or updates results in a loop

Few minutes ago update-manager pop-up appears and displayed two updates.
Click on install worked as expected and installed the two packages.
But click on 'check' button results in a loop again and does nothing.

Logout-in didn't help.

## Not reprocable. (video)
Running update-manager with prefix LANG=C via terminal allowed to check package cache.

## Reproducable.
Running it again via terminal without the prefix results in a loop.
$ update-manager

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed

Gdk-CRITICAL **: gdk_window_get_pointer: assertion `GDK_IS_WINDOW (window)' failed
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/UpdateManager/MetaReleaseGObject.py", line 42, in check
    def check(self):
KeyboardInterrupt
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/UpdateManager/MetaReleaseGObject.py", line 42, in check
    def check(self):
KeyboardInterrupt
Killed

## Need to be killed via pid.

Sam_ (and-sam) on 2011-12-14
summary: - install missing lang-pack or updates results in a loop
+ install missing lang-pack or updates result in a loop
description: updated
Sam_ (and-sam) wrote :

Really tricky since there're different results.
On first attempt run 'apt-get update' via terminal.
When there're updates update-manager will pop-up and allows to install them.
When there're no updates, run update-manager from dash or via terminal, it'll allow to check package cache.

Close update-manager.
Afterwards directly run 'apt-get update' again, open update-manager, it loops again on check of package cache.
Output from this procedure is always:
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 653, in update_last_updated_text
    def update_last_updated_text(self, user_data):
KeyboardInterrupt

Wait about ten minutes.
Run 'apt-get update' again, open update-manager, it allows installation or to check package cache.

If 'apt-get update' wasn't issued in a terminal before update-manager results in a loop, either on attempt to install or check.
Output from this procedure is always (without updating via terminal before):
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/UpdateManager/MetaReleaseGObject.py", line 42, in check
    def check(self):
KeyboardInterrupt

## I've made four different videos, if they're necessary to visualize what I mean let me know.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Sam_ (and-sam) wrote :

Just now without running apt-get update before, update-manager displayed and installed updates.
Afterwards click on 'check' again results in a loop.
Run update-manager via terminal results in the same output as mentioned.
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/UpdateManager/MetaReleaseGObject.py", line 42, in check
    def check(self):
KeyboardInterrupt
Killed

python:
  Installed: 2.7.2-9ubuntu1
  Candidate: 2.7.2-9ubuntu1
  Version table:
 *** 2.7.2-9ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Sam_ (and-sam) wrote :

After recent updates today (incl. language-selector and aptdaemon) the loop and not_recognizing_authentication bug 905442 seemed to be solved.
I'll monitor the next days and if it doesn't occur again mark this one as solved.
The attached history.log shows that I had to upgrade via terminal first and after requested reboot update-manager worked flawless.

Sam_ (and-sam) wrote :

Forgot to mention the python traceback has also vanished, terminal output only displays some gdk-critical and gtk-warnings.

Sam_ (and-sam) wrote :

Update-manager worked again flawless today. Confirmed from Bug #894671 aptdaemon fixed.

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers