Lucid to Precise upgrade fails: release upgrader fails to start

Bug #898482 reported by Erick Brunzell on 2011-12-01
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Critical
Canonical Foundations Team
Precise
Critical
Canonical Foundations Team

Bug Description

Just tried a Lucid to Precise Alpha 1 dist-upgrade by running "update-manager -d -c" and the Update Manager shows 12.04 available but clicking on Upgrade just causes the terminal to output:

can't load DistUpgradeViewGtk (Unknown internal child: selection)
can't load DistUpgradeViewGtk3 (No module named gi)
can't load DistUpgradeViewKDE (coercing to Unicode: need string or buffer, tuple found)
Must be connected to a terminal.

I had not thought of even trying this earlier as I'd doubt any early testers would typically do that but I thought I should report it all the same.

Erick Brunzell (lbsolost) wrote :

Just checking /var/log/dist-upgrade and the term.log is blank but I'm attaching the brief main.log.

tags: added: distribution-upgrade
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for testing this that early. I can confirm this error and thus setting the status 'triaged'

Changed in update-manager (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
summary: - Lucid to Precise upgrade fails
+ Lucid to Precise upgrade fails: release upgrader fails to start
Changed in update-manager (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.154.6

---------------
update-manager (1:0.154.6) precise; urgency=low

  * DistUpgrade/DistUpgrade.ui:
    - remove <child internal-child="selection"> as this is not
      supported by the gtkbuilder in lucid and makes the release
      upgrader crash (LP: #898482)
 -- Michael Vogt <email address hidden> Thu, 01 Dec 2011 16:38:56 +0100

Changed in update-manager (Ubuntu Precise):
status: Triaged → Fix Released
cpatrick08 (cpatrick08) wrote :

then shouldn't that version of update-manager be backported to lucid since the orginal reporter was trying to upgrade lucid to precise instead of just putting it in precise

cpatrick08 (cpatrick08) wrote :

i tried to do sudo update-manager -c -d in the terminal and got following error message

authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg'
extracting 'precise.tar.gz'
WARNING: Failed to read mirror file
Traceback (most recent call last):
  File "/tmp/tmpASDH1E/precise", line 7, in <module>
    sys.exit(main())
  File "/tmp/tmpASDH1E/DistUpgradeMain.py", line 218, in main
    if app.run():
  File "/tmp/tmpASDH1E/DistUpgradeController.py", line 1687, in run
    return self.fullUpgrade()
  File "/tmp/tmpASDH1E/DistUpgradeController.py", line 1561, in fullUpgrade
    if not self.getRequiredBackports():
  File "/tmp/tmpASDH1E/DistUpgradeController.py", line 1504, in getRequiredBackports
    self._view.getInstallProgress())

cpatrick08 (cpatrick08) wrote :

attached is log files from error message upgrade

cpatrick08 (cpatrick08) wrote :

attached is log files from error message upgrade

cpatrick08 (cpatrick08) wrote :
cpatrick08 (cpatrick08) wrote :

term.log is empty and therefore cannot upload

tags: added: lucid precise
Brian Murray (brian-murray) wrote :

cpatrick08 - when you use update-manager -d it downloads the precise version of update-manager to use for the distribution upgrade so this only needs to be fixed in Precise. It would be helpful if you were to report a new bug about this issue since yours is different while it creates the same problem.

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/898482

asux (ckasux) wrote :

 my upgrade when,t fine update-manager -d .
but on reboot it frozz at bios setup screen .asus pk5 pro mother/b.
i just hit reboot switch and all was good .
still had root login .
i install from synaptic package manager as well lubuntu edbuntu kde installed ok but lost root after reboot

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers