update apport package hook in natty

Bug #878585 reported by Brian Murray
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned
Natty
High
Brian Murray

Bug Description

The version of the update-manager apport package hook asks users if they are having issues performing a distribution upgrade and if they are collects different information. However, this would be useful information to gather for people upgrading *to* Oneiric - not those already running it. Subsequently, the apport package hook for update-manager should be updated in Natty.

TEST CASE:
1) execute 'ubuntu-bug update-manager'
2) observe no question being asked by apport

install package from -proposed
1) execute 'ubuntu-bug update-manager'
2) observe apport asking "Is the issue you are reporting one you encountered when upgrading Ubuntu from one release to another?"

Changed in update-manager (Ubuntu Natty):
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu):
status: New → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

Attached is a debdiff which includes the new apport package hook.

Changed in update-manager (Ubuntu Natty):
milestone: none → natty-updates
description: updated
tags: added: testcase
Changed in update-manager (Ubuntu Natty):
status: Triaged → In Progress
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Brian, or anyone else affected,

Accepted update-manager into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Natty:
I have reproduced the problem with update-manager 1:0.150.4 in natty-updates and have verified that the version of update-manager 1:0.150.5 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.150.5

---------------
update-manager (1:0.150.5) natty-proposed; urgency=low

  * update apport package hook to the same one as in Oneiric (LP: #878585)
 -- Brian Murray <email address hidden> Wed, 19 Oct 2011 17:13:17 -0700

Changed in update-manager (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers