update-manager crashed with AttributeError in _try_show_release_notes_textview(): 'Window' object has no attribute 'window'

Bug #859862 reported by Mitchel
190
This bug affects 22 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

update-manager -d

Upon clicking upgrade to 11.10. Already have 11.10 sources.list/packages from a previously failed do-release-upgrade but /etc/lsb-release still shows 11.04.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.152.19
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Mon Sep 26 19:43:46 2011
ExecutablePath: /usr/bin/update-manager
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/update-manager -d
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
PythonArgs: ['/usr/bin/update-manager', '-d']
SourcePackage: update-manager
Title: update-manager crashed with AttributeError in _try_show_release_notes_textview(): 'Window' object has no attribute 'window'
UpgradeStatus: Upgraded to natty on 2011-09-25 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
VarLogDistupgradeHistorylog:
 Start-Date: 2011-09-25 21:14:02
 Install: ubuntuone-couch:amd64 (0.3.0-0ubuntu2, automatic)
 Upgrade: firefox-globalmenu:amd64 (7.0+build2+nobinonly-0ubuntu1, 7.0+build2+nobinonly-0ubuntu2), unity-place-applications:amd64 (0.4.6-0ubuntu1, 0.4.8-0ubuntu1), deja-dup:amd64 (19.92-0ubuntu1, 19.92-0ubuntu2), firefox:amd64 (7.0+build2+nobinonly-0ubuntu1, 7.0+build2+nobinonly-0ubuntu2), onboard:amd64 (0.95.1-0ubuntu2, 0.95.1-0ubuntu3), unity-lens-applications:amd64 (0.4.6-0ubuntu1, 0.4.8-0ubuntu1), firefox-gnome-support:amd64 (7.0+build2+nobinonly-0ubuntu1, 7.0+build2+nobinonly-0ubuntu2)
 End-Date: 2011-09-25 21:14:43

Revision history for this message
Mitchel (mitchel) wrote :
tags: removed: need-duplicate-check
Michael Vogt (mvo)
Changed in update-manager (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.152.20

---------------
update-manager (1:0.152.20) oneiric; urgency=low

  * DistUpgrade/DistUpgradeQuirks.py:
    - increase the default cache size on a multiarch system to
      avoid potential crash in natty apt (LP: #854090)
  * DistUpgrade/DistUpgradeController.py, UpdateManager/Core/utils.py:
    - do not leak password from sources.list entries into the logfile
      (LP: #839094)
  * UpdateManager/UpdateManager.py:
    - do not crash if a package can not be put into "install" state,
      instead, just keep the old (unmarked) state (LP: #850482)
  * UpdateManager/DistUpgradeFetcher.py:
    - fix crash for changed gtk2 -> gtk3 API (LP: #859862)
  * UpdateManager/backend/InstallBackendAptdaemon.py:
    - remove debug output (LP: #855495)
 -- Michael Vogt <email address hidden> Fri, 30 Sep 2011 16:09:55 +0200

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
tags: added: oneiric
tags: added: bugpattern-needed
information type: Private → Public
To post a comment you must log in.