Ubuntu

update-manager crashed with SystemError in mark_install(): E:Unable to correct problems, you have held broken packages.

Reported by Mauricio Pretto on 2011-09-14
226
This bug affects 25 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: update-manager 1:0.152.18
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Wed Sep 14 19:54:25 2011
ExecutablePath: /usr/bin/update-manager
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/update-manager
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with SystemError in mark_install(): E:Unable to correct problems, you have held broken packages.
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Mauricio Pretto (pretto) wrote :
tags: removed: need-duplicate-check
Changed in update-manager (Ubuntu):
status: New → Confirmed
RedSingularity (redsingularity) wrote :

Since there is no private info in this report, I am marking it public.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

visibility: private → public
Changed in update-manager (Ubuntu):
status: Confirmed → New
RedSingularity (redsingularity) wrote :

Please attach the files in:

/var/log/dist-upgrade

Thanks.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in update-manager (Ubuntu):
status: New → Incomplete
tags: added: bugpattern-needed
summary: - update-manager crashed with SystemError in mark_install(): E:Unable to
- correct problems, you have held broken packages.
+ [MASTER] update-manager crashed with SystemError in mark_install():
+ E:Unable to correct problems, you have held broken packages.

Bug 852502 has a VarLogDistupgradeApttermlog in it which says:

dpkg: dependency problems prevent configuration of ubuntu-desktop:^M
 ubuntu-desktop depends on unity-2d; however:^M
  Package unity-2d is not installed.^M
dpkg: error processing ubuntu-desktop (--configure):^M
 dependency problems - leaving unconfigured^M

Brian Murray (brian-murray) wrote :

Bug 859888 also has a VarLogDistupgradeApttermlog which has a problem with a different origin:

dpkg: dependency problems prevent configuration of ubuntu-desktop:^M
 ubuntu-desktop depends on libatk-adaptor; however:^M
  Package libatk-adaptor is not installed.^M
dpkg: error processing ubuntu-desktop (--configure):^M
 dependency problems - leaving unconfigured^M

Jean-Baptiste Lallement (jibel) wrote :

This is a generic error that can be caused by any broken dependency on release upgrade. The bug here is that update-manager should not crash with a trace in the first place.

summary: - [MASTER] update-manager crashed with SystemError in mark_install():
- E:Unable to correct problems, you have held broken packages.
+ update-manager crashed with SystemError in mark_install(): E:Unable to
+ correct problems, you have held broken packages.
tags: removed: bugpattern-needed
Changed in update-manager (Ubuntu):
importance: Undecided → High
tags: added: rls-mgr-o-tracking
Michael Vogt (mvo) on 2011-09-30
Changed in update-manager (Ubuntu):
status: Incomplete → In Progress
Michael Vogt (mvo) on 2011-09-30
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.152.20

---------------
update-manager (1:0.152.20) oneiric; urgency=low

  * DistUpgrade/DistUpgradeQuirks.py:
    - increase the default cache size on a multiarch system to
      avoid potential crash in natty apt (LP: #854090)
  * DistUpgrade/DistUpgradeController.py, UpdateManager/Core/utils.py:
    - do not leak password from sources.list entries into the logfile
      (LP: #839094)
  * UpdateManager/UpdateManager.py:
    - do not crash if a package can not be put into "install" state,
      instead, just keep the old (unmarked) state (LP: #850482)
  * UpdateManager/DistUpgradeFetcher.py:
    - fix crash for changed gtk2 -> gtk3 API (LP: #859862)
  * UpdateManager/backend/InstallBackendAptdaemon.py:
    - remove debug output (LP: #855495)
 -- Michael Vogt <email address hidden> Fri, 30 Sep 2011 16:09:55 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.