Ubuntu

Upgrade to Xubuntu 11.10 a3 causes huge parts of Gnome to be installed

Reported by Dmitry "Divius" Tantsur on 2011-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Among them are:
gnome-session
gnome-control-center
indicator-*
compiz*
nautilus

and so on.
Still, ubuntu-desktop is NOT going to be installed, only xubuntu-desktop.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.150.3
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Aug 5 14:44:37 2011
DpkgHistoryLog.txt:
 Start-Date: 2011-08-05 13:08:55
 Upgrade: libsmbclient:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), firefox-trunk-gnome-support:amd64 (8.0~a1~hg20110727r73410+nobinonly-0ubuntu1~umd1~natty, 8.0~a1~hg20110804r73824+nobinonly-0ubuntu1~umd1~natty), firefox-trunk:amd64 (8.0~a1~hg20110727r73410+nobinonly-0ubuntu1~umd1~natty, 8.0~a1~hg20110804r73824+nobinonly-0ubuntu1~umd1~natty), smbclient:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), firefox-trunk-globalmenu:amd64 (8.0~a1~hg20110727r73410+nobinonly-0ubuntu1~umd1~natty, 8.0~a1~hg20110804r73824+nobinonly-0ubuntu1~umd1~natty), firefox-globalmenu:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1), libwbclient0:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), libpam-smbpass:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), firefox-branding:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1), firefox-dbg:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1), samba-common:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), firefox:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1), firefox-locale-en:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1), samba:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), firefox-locale-ru:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1), samba-common-bin:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), winbind:amd64 (3.5.8~dfsg-1ubuntu2.2, 3.5.8~dfsg-1ubuntu2.3), firefox-gnome-support:amd64 (6.0~b3+build2+nobinonly-0ubuntu0.11.04.1~mfn1, 6.0~b4+build1+nobinonly-0ubuntu0.11.04.1~mfn1)
 End-Date: 2011-08-05 13:09:34
GConfNonDefault:
 /apps/update-manager/check_new_release_ignore=
 /apps/update-manager/first_run=false
 /apps/update-manager/show_details=true
 /apps/update-manager/window_size=(1918,1010)
InstallationMedia: Xubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101008.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ru_RU:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to natty on 2011-08-05 (0 days ago)

tags: added: oneiric
Jean-Baptiste Lallement (jibel) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in update-manager (Ubuntu):
status: New → Incomplete

I don't need to upgrade to get these files, right?

term.log is empty.

Changed in update-manager (Ubuntu):
status: Incomplete → New

These lines seem to cause the problem:

new important dependency: indicator-status-provider-pidgin
  Installing indicator-status-provider-pidgin as Рекомендует of pidgin-libnotify
    Installing libindicator-messages-status-provider1 as Зависит of indicator-status-provider-pidgin
    Installing indicator-messages as Зависит of indicator-status-provider-pidgin
      Installing libdbusmenu-glib4 as Зависит of indicator-messages
      Installing libdbusmenu-gtk3-4 as Зависит of indicator-messages
      Installing libindicator3-6 as Зависит of indicator-messages
      Installing indicator-applet as Рекомендует of indicator-messages
        Installing gnome-panel as Зависит of indicator-applet
           ....

P.S.
"Рекомендует" means "Recommends"
"Зависит" means "Depends"

Deleting pidgin-inotify solved some part of a problem. Still it wants to install a lot of indicator-* shit. Investigating...

Installing nautilus-data as Зависит of file-roller
is it THAT necessary?

Installing lightdm as Зависит of xubuntu-default-settings
A what if I already have gdm?

Installing gnome-bluetooth as Рекомендует of network-manager-gnome
   ...
    Installing gnome-user-share as Рекомендует of gnome-bluetooth
Not too well. I have neither gnome, nor bluetooth.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers