Ubuntu

DistUpgradeApport.py doesn't check for 0 byte files

Reported by Brian Murray on 2011-04-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned
Natty
Low
Unassigned

Bug Description

Binary package hint: update-manager

TEST CASE:
- regression test should be enough as its not clear what the best way to trigger this problem is
  the fix is pretty trivial

I've seen multiple bug reports with an attachment named VarLogDistUpgradeTermlog.gz that is 37 bytes and contains no data. (See bug 701317 for an example) I believe update-manager creates this log file (term.log) before actually writing to it so we have a 0 byte file. Then if update-manager crashes (when doing a distribution upgrade) all the files in /var/log/dist-upgrade are passed to apport and added to bug reports as attachments. Then when trying to work with these attachments in Launchpad we receive an unexpected end of file.

Brian Murray (brian-murray) wrote :

This will stop zero byte files from getting passed to apport.

Brian Murray (brian-murray) wrote :

To clarify if you download https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/701317/+attachment/1790752/+files/VarLogDistupgradeTermlog.gz and use gunzip with it you'll receive an unexpected end of file.

Changed in update-manager (Ubuntu Natty):
status: New → Triaged
milestone: none → natty-updates
importance: Undecided → Low
Michael Vogt (mvo) wrote :

Thanks! I merged this into trunk and uploaded it to natty-proposed now.

Changed in update-manager (Ubuntu Natty):
status: Triaged → In Progress
Changed in update-manager (Ubuntu):
status: New → In Progress
Clint Byrum (clint-fewbar) wrote :

I've rejected the proposed upload version 1:0.150.2 because of the additional update 1:0.150.1, which was not included in the .changes file.

@mvo: 1.0.150.2 needs to be built with dpkg-buildpackage -v1:0.150 to properly pick up the changes in 1:0.150.1

Michael Vogt (mvo) on 2011-05-02
Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
importance: Undecided → Medium
description: updated

Accepted update-manager into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Natty:
I ran many release upgrades with update-manager 1:0.150.2 in -proposed to test other SRUs and haven't found any regression.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.150.2

---------------
update-manager (1:0.150.2) natty-proposed; urgency=low

  * debian/control:
    - point to "natty" branch
  * DistUpgrade/DistUpgrade.cfg:
    - remove "kde-plasmoid-cwp" early as it will break upgrades
      later (LP: #773022)
  * DistUpgrade/DistUpgradeCache.py:
    - do not fail if not all meta-package can not be upgraded, packages
      like ubuntu-desktop and xubuntu-desktop have implicit conflicts
      LP: #775411

update-manager (1:0.150.1) natty-proposed; urgency=low

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeApport.py:
    - do not report zero size attachments (LP: #772052)
  * DistUpgrade/DistUpgrade.cfg:
    - enable apport for distribution upgrades (LP: #772913)
  * DistUpgrade/DistUpgradeController.py:
    - use service to start apport

  [ Michael Vogt ]
  * DistUpgrade/DistUpgrade.cfg:
    - Remove 'dontzap' from kubuntu-desktops rules (LP: #769680).
      This fixes a upgrade issue when a old package is leftover
 -- Michael Vogt <email address hidden> Mon, 02 May 2011 09:52:35 +0200

Changed in update-manager (Ubuntu Natty):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers