cp bug

Bug #761348 reported by Javier Resendiz

This bug report was converted into a question: question #153077: Help needed in changing the boot screen and removing the ubuntu logo..

4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

 I was trying to change the boot screen and remove the ubuntu logo.
 I was trying to run in terminal.

javier@javier:~$ sudo apt-get install plymouth-theme-*
[sudo] password for javier:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting plymouth-theme-ubuntu-text for regex 'plymouth-theme-*'
Note, selecting plymouth-theme for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-kubuntu-logo for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-sabily for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-text for regex 'plymouth-theme-*'
Note, selecting ubuntustudio-plymouth-theme for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-ubuntustudio for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-glow for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-ubuntu-logo for regex 'plymouth-theme-*'
Note, selecting xubuntu-plymouth-theme for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-script for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-spinfinity for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-solar for regex 'plymouth-theme-*'
Note, selecting lubuntu-plymouth-theme for regex 'plymouth-theme-*'
Note, selecting plymouth-theme-fade-in for regex 'plymouth-theme-*'
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
javier@javier:~$

 sudo cp /usr/share/applications/gnome-appearance-properties.desktop/usr/share/gdm/autostart/LoginWindow

this was the answer;

cp: missing destination file operand after `/usr/share/applications/gnome-appearance-properties.desktop/usr/share/gdm/autostart/LoginWindow'
Try `cp --help' for more information.
javier@javier:~$ cp --help
Usage: cp [OPTION]... [-T] SOURCE DEST
  or: cp [OPTION]... SOURCE... DIRECTORY
  or: cp [OPTION]... -t DIRECTORY SOURCE...
Copy SOURCE to DEST, or multiple SOURCE(s) to DIRECTORY.

Mandatory arguments to long options are mandatory for short options too.
  -a, --archive same as -dR --preserve=all
      --backup[=CONTROL] make a backup of each existing destination file
  -b like --backup but does not accept an argument
      --copy-contents copy contents of special files when recursive
  -d same as --no-dereference --preserve=links
  -f, --force if an existing destination file cannot be
                                 opened, remove it and try again (redundant if
                                 the -n option is used)
  -i, --interactive prompt before overwrite (overrides a previous -n
                                  option)
  -H follow command-line symbolic links in SOURCE
  -l, --link link files instead of copying
  -L, --dereference always follow symbolic links in SOURCE
  -n, --no-clobber do not overwrite an existing file (overrides
                                 a previous -i option)
  -P, --no-dereference never follow symbolic links in SOURCE
  -p same as --preserve=mode,ownership,timestamps
      --preserve[=ATTR_LIST] preserve the specified attributes (default:
                                 mode,ownership,timestamps), if possible
                                 additional attributes: context, links, xattr,
                                 all
      --no-preserve=ATTR_LIST don't preserve the specified attributes
      --parents use full source file name under DIRECTORY
  -R, -r, --recursive copy directories recursively
      --remove-destination remove each existing destination file before
                                 attempting to open it (contrast with --force)
      --sparse=WHEN control creation of sparse files
      --strip-trailing-slashes remove any trailing slashes from each SOURCE
                                 argument
  -s, --symbolic-link make symbolic links instead of copying
  -S, --suffix=SUFFIX override the usual backup suffix
  -t, --target-directory=DIRECTORY copy all SOURCE arguments into DIRECTORY
  -T, --no-target-directory treat DEST as a normal file
  -u, --update copy only when the SOURCE file is newer
                                 than the destination file or when the
                                 destination file is missing
  -v, --verbose explain what is being done
  -x, --one-file-system stay on this file system
      --help display this help and exit
      --version output version information and exit

By default, sparse SOURCE files are detected by a crude heuristic and the
corresponding DEST file is made sparse as well. That is the behavior
selected by --sparse=auto. Specify --sparse=always to create a sparse DEST
file whenever the SOURCE file contains a long enough sequence of zero bytes.
Use --sparse=never to inhibit creation of sparse files.

The backup suffix is `~', unless set with --suffix or SIMPLE_BACKUP_SUFFIX.
The version control method may be selected via the --backup option or through
the VERSION_CONTROL environment variable. Here are the values:

  none, off never make backups (even if --backup is given)
  numbered, t make numbered backups
  existing, nil numbered if numbered backups exist, simple otherwise
  simple, never always make simple backups

As a special case, cp makes a backup of SOURCE when the force and backup
options are given and SOURCE and DEST are the same name for an existing,
regular file.

Report cp bugs to <email address hidden>
GNU coreutils home page: <http://www.gnu.org/software/coreutils/>
General help using GNU software: <http://www.gnu.org/gethelp/>
Report cp translation bugs to <http://translationproject.org/team/>

Aslo tried to remove the ubuntu logo thru startup manager by
changing 1280x1024 and 24 bits in the "Resolution" and "Color depth" drop-down menus. Also, check the "Show boot splash" option, and you can reduce the "Timeout in seconds" option to 0 (zero)!

But no luck Ubuntu Logo is still active. I think my plymouth themes are missing.

Can you help? thanks in advance.

Revision history for this message
Rohit R (rr0hit) wrote :

You seem to have missed a space between "/usr/share/applications/gnome-appearance-properties.desktop" and "/usr/share/gdm/autostart/LoginWindow"

Your command should be

sudo cp /usr/share/applications/gnome-appearance-properties.desktop /usr/share/gdm/autostart/LoginWindow

Not a bug. Marking as invalid.

Changed in update-manager (Ubuntu):
status: New → Invalid
Changed in update-manager (Ubuntu):
status: Invalid → New
Revision history for this message
Rohit R (rr0hit) wrote :

Did the comment #1 solve your problem ? If not what error message do you get on using the modified command suggested?

Rohit R (rr0hit)
Changed in update-manager (Ubuntu):
status: New → Incomplete
Revision history for this message
Javier Resendiz (javier-resendiz) wrote :

Hi rr0hit,

 I tried your command and it worked fine, thanks.

But when I tried to change the background screen also this is what it showed after command;

        gksudo nautilus /usr/share/backgrounds

The window came up I copied my pictures into the file and close it, this came up after;

javier@javier:~$ gksudo nautilus /usr/share/backgrounds
Initializing nautilus-gdu extension
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

Not sure what to do?

I also tried to remove the ubuntu logo at boot screen also not working, thru the startup manager
by changing 1280x1024 and 24 bits in the "Resolution" and "Color depth" drop-down menus. Also, checked the "Show boot splash" option, and you can reduce the "Timeout in seconds" option to 0 (zero)!

And that did not work also, do you have any suggestions?

Thanks in advance for your help!

** (nautilus:7341): WARNING **: Could not inhibit power management: The name org.gnome.SessionManager was not provided by any .service files

(nautilus:7341): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

** (nautilus:7341): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed

Revision history for this message
Rohit R (rr0hit) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Javier Resendiz (javier-resendiz) wrote :

Hey rr0hit,

thanks for your time on what I though was a bug.
Will redirect to questions.

thanks,

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers