update-manager refuses to upgrade from apt-proxy

Bug #73463 reported by Joachim Sauer on 2006-11-27
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt
Nominated for Feisty by Joachim Sauer

Bug Description

We're running several Ubuntu workstations and servers (plus a few Debian ones as well) and have setup a central apt-proxy to speed up updates. This works just fine for day-to-day usage and saves quite a lot of bandwidth and time.

Unfortunately update-manager doesn't allow a distribution upgrade via the apt-proxy, as it detects it as a unofficial repostitory and thus disables it. This way, also universe/multiverse will be disabled, because it only adds main back in.

So if we were to update using "update-manager -d", we'd
- have to download 700MB+ each time, even though we've got it in our apt-proxy alread
- loose all non-main software in the process (eclipse + sun-java for example).

The alternative is to update using synaptic/aptitude/apt-get, but it's quite tricky to get correct and not the suggested way, if I understood correctly.

John Vivirito (gnomefreak) wrote :

Thank you for reporting this bug with us. Can you please attach the files in /var/log/dist-upgrade.

Changed in update-manager:
status: Unconfirmed → Needs Info
Joachim Sauer (saua) wrote :

Sorry for the delay, I didn't have access to the affected computer until now.

Joachim Sauer (saua) wrote :

Has there been any progress on the problem? Or do you need any more information?

Joachim Sauer (saua) wrote :

This bug has been open for quite some time and I think it would be a good idea to fix it before feisty is released (if possible). I've attached the log file from back then and can now reproduce it when I try to use the update-manager to update to feisty.

Changed in update-manager:
status: Needs Info → Unconfirmed
Joachim Sauer (saua) wrote :

This is the content of /var/log/update-manager after I've run "update-manager -d -c" on an up-to-date Ubuntu 6.10. I've canceled the update, since our apt-proxy was disabled in sources.list.

Michael Vogt (mvo) wrote :

Hello rentar,

thanks for testing the upgrade. Could you please try to disable the 'deb http://archive.ubuntu.com/ubuntu/ edgy main' line and try again? Then it should ask you if the complete sources.list should be rewritten.

Thanks,
 michael

Michael Vogt (mvo) on 2007-03-23
Changed in update-manager:
status: Unconfirmed → Needs Info
Joachim Sauer (saua) wrote :

I don't have any such line in my sources.list.

Basically this bug is about the fact, that update-manager doesn't realize that the repository that's provided by our apt-proxy is a valid repository for updating.

The part, where it only re-adds main is probably a consequence of that.

I'm attaching my sources.list (which is pretty standard, except that archive.ubuntu.com is replace by 192.168.1.17:8090, where our local apt-proxy is running).

The fact that "real" third-party repositories are disabled is no problem at all.

Joachim Sauer (saua) wrote :

I think a real fix for this problem would require a more in-depth check for wether a specified repository is a valid mirror, than just checking the list against a known-good list of mirrors.

Alternatively a command line switch that told update-manager to accept an url as a valid mirror would be a useable workaround.

Andrew Bennetts (spiv) wrote :

This has just happened to me when upgrading from edgy to feisty. Both the 700MB+ download not going through the proxy, and the non-main components being lost. Very irritating.

Can apt-proxy please at least tell me if it doesn't think it has an official repository, so I can realise there's a problem before the upgrade happens?

Michael Vogt (mvo) on 2007-03-24
Changed in update-manager:
status: Needs Info → Confirmed
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This will work for a edgy->feisty upgrade. If the sources.list contains no valid mirror it will ask to just "dumb" rewrite it.

Cheers,
 Michael

Changed in update-manager:
assignee: nobody → mvo
status: Confirmed → Fix Released
Joachim Sauer (saua) wrote :

Should this already work? I've just tried it and the behaviour did not change (in a fully updated edgy eft). It still disables all apt-proxy repositories and re-adds only main. This is on a different machine without any (enable) third-party repositories, so it doesn't even mention that id disables anything. Maybe I'm missing something but this does not look fixed to me.

(unfortunately I don't know what the correct procedure for re-opening a bug on launchpad is, so I just set it to unconfirmed. I hope that's at least somewhat acceptable).

Changed in update-manager:
status: Fix Released → Unconfirmed
Joachim Sauer (saua) wrote :

Sorry, the comment about not getting a note about disabling third-party repositories was wrong, I seem to have clicked it away without noticing.

Here's the sources.list that update-manager created

Michael Vogt (mvo) wrote :

Thanks, I can reproduce the failure here. A fix is currently in the testing phase.

Changed in update-manager:
importance: Undecided → Medium
status: Unconfirmed → In Progress
Michael Vogt (mvo) wrote :

I commited the fix to my bzr archive and it will be part of the next upload.

I would appreciate testing once it hit the archive.

Thanks,
 Michael

Changed in update-manager:
status: In Progress → Fix Committed
Michael Vogt (mvo) on 2007-04-05
Changed in update-manager:
status: Fix Committed → Fix Released
Kai Schroeder (kai-schroeder) wrote :

does this fix the following bug?
#68467 restricted component lost from sources.list during upgrade

Joachim Sauer (saua) wrote :

The fix works like a charm, thanks. I think this fixes Bug #68467 as well (at least for me it did).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers