Update Manager fails when trying to upgrade to 10.10

Bug #717489 reported by Dean Hoover on 2011-02-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I am attempting to upgrade to version 10.10 on my netbook, and it keeps giving an error. This error is reported when using both the GUI and from a terminal using do-release-upgrade:

An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the
'update-manager' package and include the files in
/var/log/dist-upgrade/ in the bug report.

I did a quick search and it did say something about a mirror for the google talk source list, so i removed the package, tried again, but got the same result. Standard 10.04 LTS updates work fine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: update-manager 1:0.134.11
ProcVersionSignature: Ubuntu 2.6.32-28.55-generic 2.6.32.27+drm33.12
Uname: Linux 2.6.32-28-generic i686
Architecture: i386
Date: Fri Feb 11 17:54:32 2011
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager

Dean Hoover (kb7qdi) wrote :
RedSingularity (redsingularity) wrote :

This looks like a duplicate of another well known bug. Before I mark it could you attach your sources list file? Thanks.

Changed in update-manager (Ubuntu):
status: New → Incomplete
tags: added: lucid2maverick
removed: lucid ubuntu-une
Dean Hoover (kb7qdi) wrote :

Here are the sources list files you requested.

I did a quick search on the error, but I guess I didn't dig hard enough. If you could send me the bug number, I can see if it matches what is going on here.

Thanks.
Dean

RedSingularity (redsingularity) wrote :

Dont worry about it. Its not the same issue. You dont have the xorg edgers package in your sources.

Lets see the whole apt directory....post the output of:

ls -l /etc/apt

Thanks.

Dean Hoover (kb7qdi) wrote :

Here are the results:

root@kb7qdi-laptop:~# ls -l /etc/apt
total 44
drwxr-xr-x 2 root root 4096 2011-02-11 17:11 apt.conf.d
drwxr-xr-x 2 root root 4096 2010-04-14 23:33 preferences.d
-rw------- 1 root root 0 2010-04-29 06:25 secring.gpg
-rw-r--r-- 1 root root 2953 2011-02-11 17:48 sources.list
drwxr-xr-x 2 root root 4096 2011-02-11 17:08 sources.list.d
-rw-r--r-- 1 root root 2953 2011-02-11 17:46 sources.list.distUpgrade
-rw------- 1 root root 1200 2010-04-29 06:25 trustdb.gpg
-rw-r--r-- 1 root root 7924 2010-12-15 20:49 trusted.gpg
-rw-r--r-- 1 root root 6713 2010-04-29 06:25 trusted.gpg~
drwxr-xr-x 2 root root 4096 2010-04-14 23:33 trusted.gpg.d

RedSingularity (redsingularity) wrote :

Thanks. Attach any files located in the "sources.list.d" directory. There may be a few.

Dean Hoover (kb7qdi) wrote :
RedSingularity (redsingularity) wrote :

Run the following:

sudo mv /etc/apt/sources.list.d/google-talkplugin.list /etc/apt/sources.list.d/google-talkplugin.list.temp

That will temporarily stop the google repo from loading. After you have done this run:

sudo apt-get update

Then Remove all the files in /var/log/dist-upgrade. Run the upgrade again. If it fails again, attach the new log files that will be located in /var/log/dist-upgrade.

RedSingularity (redsingularity) wrote :

Found it and confirmed on my system. This is a duplicate of bug 614993. Marking.

Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed
Dean Hoover (kb7qdi) wrote :

Still didn't work, but I think it went further than it did before.

Attaching the files in /var/log/dist-upgrade.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers