Upgrader needs better free-space checking for /boot

Bug #70683 reported by ronrafajko on 2006-11-07
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt

Bug Description

I updated Ubuntu from 6.06 Dapper Drake to 6.10 Edgy Eft over the Internet.
I am on an Alienware AMD64 laptop.
I believe I used the command: sudo update-manager -c to upgrade.
The upgrade did not seem to go very well with multiple errors during the process.
On reboot after everything appeared to finish, I get these errors:

Failed to allocate mem resource #6: ___________ for _______________
RAMDISK: ran out of compressed data
invalid compressed format (err=1)
Kernel panic -not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

This happens when I boot GRUB with the 2.6.15-27-amd64-genericDefault kernel (the top entry).
When I boot the 2.6.17-10-generic kernel I only get the fourth error, then the machine reboots.
I have tried the recovery mode line items, and all of the others without getting to a login screen.
I did some searching on the forums and found the kernel panic error on previous version upgrades, but not Eft.
I can try to boot from a live CD and grab the dist-upgrade file if you want that.
Let me know what you would like me to try.

THANKS!

ronrafajko (ron-rafajko) wrote :

I am dead in the water (stuck with Windoz XP on this dual boot laptop)!
H-E-L-P !

towsonu2003 (towsonu2003) wrote :

Thanks for your bug report. Could you please include the logs from /var/log/dist-upgrade/

Sorry, I am new to Linux and Ubuntu.
Since I cannot get logged in I presume I boot from a
live CD/DVD and then mount the old file system and
copy off the file. What are the commands to do that?

THANKS!

--- towsonu2003 <email address hidden> wrote:

> Thanks for your bug report. Could you please include
> the logs from
> /var/log/dist-upgrade/
>
> ** Changed in: Ubuntu
> Sourcepackagename: None => update-manager
> Status: Unconfirmed => Needs Info
>
> --
> Upgrade from Dapper to Edgy with update-manager
> failed
> https://launchpad.net/bugs/70683
>

____________________________________________________________________________________
Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail beta.
http://new.mail.yahoo.com

Well, get a live CD (edgy live CD or Knoppix). They usually have graphical mounters for HD. Then open your browser and point it to where those log files are to upload them.

If this does not work, show me the output of "fdisk -l" from the command line. And if possible tell me what partition you think the logs are on.

Here are the files.

THANKS!

--- towsonu2003 <email address hidden> wrote:

> Thanks for your bug report. Could you please include
> the logs from
> /var/log/dist-upgrade/
>
> ** Changed in: Ubuntu
> Sourcepackagename: None => update-manager
> Status: Unconfirmed => Needs Info
>
> --
> Upgrade from Dapper to Edgy with update-manager
> failed
> https://launchpad.net/bugs/70683
>

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

towsonu2003 (towsonu2003) wrote :

thanks :) I'll leave the rest to those with more experience :)

Changed in update-manager:
status: Needs Info → Unconfirmed
ronrafajko (ron-rafajko) wrote :

Any thoughts on the logs gentlemen?
This nice machine is gathering dust.

ronrafajko (ron-rafajko) wrote :

Anyone listening?
Is there a way to reinstall 6.10 and fix the botched install, without deleting my previous directory structure (i.e. upgrade, not new install of the OS)?

Rolf Leggewie (r0lf) wrote :

This is the bug tracker. Please open a support request ticket from the Support link on this page. Be as verbose as you can once more on what the current situation is and how you got there.

Let me know about the URL for the Support request and I will take a look. I cannot make any promises but I am confident your situation can be rectified.

Michael Vogt (mvo) wrote :

Thanks for your bugreport and the logs.

The reason for the failre are too little free space on /boot:

2006-10-26 11:59:34,934 DEBUG Free space on /boot: 5704704

Setting up linux-image-2.6.17-10-generic (2.6.17-10.33) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.17-10-generic
gzip: stdout: No space left on device
Failed to create initrd image.

Cheers,
 Michael

Changed in update-manager:
importance: Undecided → High
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

I fixed this in my local tree and it will be part of the next dist-upgrader upload.

Changed in update-manager:
status: Confirmed → Fix Committed
ronrafajko (ron-rafajko) wrote :

Rolf:
My support request is at: https://answers.launchpad.net/distros/ubuntu/+ticket/2783

Michael:
How did you fix the issue? I could not find bug 5704704.

Rolf Leggewie (r0lf) wrote :

Well, it seems your support request is already being handled.

Michael was not talking about a bug number but about a line from the logs you posted, namely from main.log. That one indicated about 5MB free space on boot, too little to install linux-image-2.6.17-10-generic. That was the reason your install did not complete.

Michael Vogt (mvo) wrote :

Done in the current release upgrader

Changed in update-manager:
assignee: nobody → mvo
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers