Launchpad links in the bug-fix description field don't lauch Firefox when set as default

Bug #693131 reported by Alex Cockell on 2010-12-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Brian Murray

Bug Description

--------------------

Bug summary: Seems that a script in gnome-control-center is not acting properly. [[/usr/bin/gnome-default-applications-properties]] The GUI does not edit the default browser located in the script x-www-browser. As long as epiphany-browser is installed, it remains the default browser even when editing gnome-default-applications-properties. In order to change the default browser launched by the script "x-www-browser", one needs to run the following command manually: update-alternatives --config x-www-browser

Recommend using another script to execute the "default" browser in update-manager.

--------------------
I fired up Update Manager to check what fixes were waiting - decided to have a look at the related Launchpad report against one of the kernel updates... instead of opening up a tab in Firefox as I expected, it started another program called the "Gnome Web Browser". In turn, this messed up my audio playback - I had to reboot to get my audio back. This affected ALL audio playback whether from my browser or from other audio apps (Totem, Rhythmbox etc).

I tested with iPlayer - and while I could watch images, there was no audio at all until I rebooted.

I have Firefox set as my default browser in System Preferences - surely this option should be used by all apps requesting web-page output?

What was concerning was - I had Firefox open at the time -

Expected behaviour... that the Launchpad page would open up in a new tab within Firefox.

Please fix.

ProblemType: BugDistroRelease: Ubuntu 10.04
Package: update-manager 1:0.134.11
ProcVersionSignature: Ubuntu 2.6.32-26.48-generic 2.6.32.24+drm33.11
Uname: Linux 2.6.32-26-generic i686
Architecture: i386
Date: Tue Dec 21 18:35:00 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bashSourcePackage: update-manager

Related branches

Alex Cockell (alcockell) wrote :
Sean Salsman (sean-salsman) wrote :

I was unable to reproduce this issue in Ubuntu 10.10 x86_64. When I clicked on the Launchpad report in Update Manager, it pulled up in Firefox with no issues.

Sean Salsman (sean-salsman) wrote :

I'm using update-manager 1:0.142.19

RedSingularity (redsingularity) wrote :

This seems to be a nautilus problem since it has to do with opening default programs. Changing package. Once you rebooted was this issue repeatable or is it working as expected now?

affects: update-manager (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: New → Incomplete
Chris Coulson (chrisccoulson) wrote :

nautilus has nothing to do with this. Without understanding how update-manager opens the browser and doing more investigation, you should just leave the bug there

affects: nautilus (Ubuntu) → update-manager (Ubuntu)

On Sat, 2011-01-01 at 02:16 +0000, RedSingularity wrote:
> This seems to be a nautilus problem since it has to do with opening
> default programs. Changing package. Once you rebooted was this issue
> repeatable or is it working as expected now?
>
> ** Package changed: update-manager (Ubuntu) => nautilus (Ubuntu)

As there are no security updates coming in, I'm unable to retest.

--

Alex Cockell
Reading, Berks, UK
<email address hidden>

RedSingularity (redsingularity) wrote :

Ok. I am not able to reproduce on my machine at the moment using the same update-manager version. Please retest when possible and report back with the results. It may have been a one time anomaly. If not we can investigate further. Please disregard the package reassignment error, my mistake. Thanks!

Alex Cockell (alcockell) wrote :

I tried again today - clicked on the link https://launchpad.net/bugs/699885 in Update Manager when looking at linux-headers-2-6-28-32 changes... GNOME Web Browser opened up rather than Firefox - when I have Firefox set as my Preferred Browser.

Surely Update Manager should look at my preferences.

Please resolve.

Changed in update-manager (Ubuntu):
status: Incomplete → New
RedSingularity (redsingularity) wrote :

Tried it again in 10.04 and 10.10 install with no problems. Under "system>preferences>preferred applications" what command is the system using to launch firefox?

----- Original message -----
> Tried it again in 10.04 and 10.10 install with no problems.  Under
> "system>preferences>preferred applications" what command is the system
> using to launch firefox?

Just Firefox selected from the list box.

>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/693131
>
> Title:
>    Launchpad links in the bug-fix description field don't lauch Firefox
>    when set as default
>
> Status in “update-manager” package in Ubuntu:
>    New
>
> Bug description:
>    Binary package hint: update-manager
>
>    I fired up Update Manager to check what fixes were waiting - decided
>    to have a look at the related Launchpad report against one of the
>    kernel updates... instead of opening up a tab in Firefox as I
>    expected, it started another program called the "Gnome Web Browser".
>    In turn, this messed up my audio playback - I had to reboot to get my
>    audio back.  This affected ALL audio playback whether from my browser
>    or from other audio apps (Totem, Rhythmbox etc).
>
>    I tested with iPlayer - and while I could watch images, there was no
>    audio at all until I rebooted.
>
>    I have Firefox set as my default browser in System Preferences -
>    surely this option should be used by all apps requesting web-page
>    output?
>
>    What was concerning was - I had Firefox open at the time -
>
>    Expected behaviour... that the Launchpad page would open up in a new
>    tab within Firefox.
>
>    Please fix.
>
>    ProblemType: Bug
>    DistroRelease: Ubuntu 10.04
>    Package: update-manager 1:0.134.11
>    ProcVersionSignature: Ubuntu 2.6.32-26.48-generic 2.6.32.24+drm33.11
>    Uname: Linux 2.6.32-26-generic i686
>    Architecture: i386
>    Date: Tue Dec 21 18:35:00 2010
>    PackageArchitecture: all
>    ProcEnviron:
>      LANG=en_GB.utf8
>      SHELL=/bin/bash
>    SourcePackage: update-manager
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/693131/+subscribe

Set a custom command of:

firefox %s

and see if that works for a while.

Also, do you use the gnome-browser at all?

On Mon, 2011-01-31 at 17:49 +0000, RedSingularity wrote:
> Set a custom command of:
>
> firefox %s
>
> and see if that works for a while.
>
> Also, do you use the gnome-browser at all?
>

I haven't used the GNOME browser at all... and "firefox %s" is the
command issued anyway when i select Firefox...

--

Alex Cockell
Reading, Berks, UK
<email address hidden>

Update-manager is using the code x-www-browser to open the "default" browser. Unfortunately, the preference settings GUI is not really changing the "default" browser in x-www-browser. As long as epiphany is installed it has preference over other browsers when executing the command x-www-browser. When using other programs that do not initiate x-www-browser, preferred browser will launch.

Try this in a terminal to confirm:

x-www-browser

Did it open firefox or epiphany?

Alex Cockell (alcockell) wrote :

On Mon, 2011-01-31 at 22:27 +0000, RedSingularity wrote:
> Update-manager is using the code x-www-browser to open the "default"
> browser. Unfortunately, the preference settings GUI is not really
> changing the "default" browser in x-www-browser. As long as epiphany is
> installed it has preference over other browsers when executing the
> command x-www-browser. When using other programs that do not initiate x
> -www-browser, preferred browser will launch.
> Try this in a terminal to confirm:
>
> x-www-browser
>
> Did it open firefox or epiphany?
>

Opened GNOME Web Browser - I take that is Epiphany? Surely it should
start Firefox if that's the Preferred app?

--

Alex Cockell
Reading, Berks, UK
<email address hidden>

You are correct. It should. The bug is in a script that changes the x-www-browser file. I am marking the bug as confirmed and will edit the description for the developers. In the meantime in order to get a choice of a preferred web browser, uninstall epiphany since you do not use it anyway.

sudo apt-get autoremove epiphany-browser

Then try the following command in terminal again:

x-www-browser

This time firefox should open without a problem.

affects: update-manager (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
description: updated
Chris Coulson (chrisccoulson) wrote :

x-www-browser is an alternative, managed by the alternatives system. Alternatives are known to suck (they are system-wide preferences, and *not* user preferences). If update-manager really is using x-www-browser, then it needs fixing to not use that.

In any case, this doesn't have anything to do with gnome-control-center

affects: gnome-control-center (Ubuntu) → update-notifier (Ubuntu)
Alex Cockell (alcockell) wrote :

On Tue, 2011-02-01 at 18:38 +0000, RedSingularity wrote:
> You are correct. It should. The bug is in a script that changes the x
> -www-browser file. I am marking the bug as confirmed and will edit the
> description for the developers. In the meantime in order to get a
> choice of a preferred web browser, uninstall epiphany since you do not
> use it anyway.
>
> sudo apt-get autoremove epiphany-browser
>
> Then try the following command in terminal again:
>
> x-www-browser
>
> This time firefox should open without a problem.

Is it safe to remove gnome-dbg? As that one was marked as one that
would be deleted...

--

Alex Cockell
Reading, Berks, UK
<email address hidden>

Ok, I guess we will file the report against the update-manager.

Yes you can remove gnome-dbg.

description: updated
tags: added: bitesize
Draycen DeCator (ddecator) wrote :

Since this report is requesting a change be made to the Update Manager to help improve it, and not to fix something that is broken, I am marking this report as "Wishlist."

There also appears to be enough information for the developers to work on this report, so I am marking it "Triaged" by request of RedSingularity.

Thank you again for helping to make Ubuntu better, and please continue to report any bugs that you find!

Changed in update-notifier (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
affects: update-notifier (Ubuntu) → update-manager (Ubuntu)
Changed in update-manager (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.147

---------------
update-manager (1:0.147) natty; urgency=low

  [ Brian Murray]
  * UpdateManager/ReleaseNotesViewer.py: fix the path for gnome-open
    and default to xdg-open (LP: #693131)

  [ Michael Vogt ]
  * DistUpgrade/apt_clone.py:
    - use apt_clone.py from the apt-clone package
  * debian/control:
    - add apt-clone to the build-depends
  * DistUpgrade/DistUpgradePatcher.py:
    - add native ed-style patch implementation as e.g. chroots
      may not have ed installed and its critical to be able to
      ensure that pycompile is correct before the upgrade starts
  * do-release-upgrade:
    - use apt.progress.text.AcquireProgress to fix deprecation warning
  * DistUpgrade/DistUpgradeViewText.py:
    - fix deprecation warning (LP: #744990)
  * fix deprecation warnings in auxiliary scripts
  * DistUpgrade/DistUpgradeAptCdrom.py:
    - fixes with the python-apt 0.8 API
 -- Michael Vogt <email address hidden> Thu, 31 Mar 2011 17:58:14 +0200

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers