Error upgrading dapper to edgy

Bug #68502 reported by James Collins on 2006-10-26
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Hi,

I have attempted upgrading from dapper to edgy using the
gksu "update-manager -c -d"
command, however I have received numerous error messages throughout the upgrade process.

The error messages instructed me to report a bug, and include the files in /var/log/dist-upgrade/, so here they are attached below.

It seems the upgrade has halted half way through, with a message saying to try and run "sudo dpkg --configure -a". After trying this, it outputs:

dpkg: dependency problems prevent configuration of courier-authlib-userdb:
 courier-authlib-userdb depends on courier-authlib; however:
  Package courier-authlib is not installed.
 courier-authlib-userdb depends on courier-authlib (>= 0.58); however:
  Package courier-authlib is not installed.
dpkg: error processing courier-authlib-userdb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vlc-plugin-arts:
 vlc-plugin-arts depends on vlc-nox; however:
  Package vlc-nox is not installed.
 vlc-plugin-arts depends on libvlc0 (>= 0.8.6-svn20061012.debian); however:
  Package libvlc0 is not installed.
dpkg: error processing vlc-plugin-arts (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vlc:
 vlc depends on vlc-nox (= 0.8.6-svn20061012.debian-1ubuntu1); however:
  Package vlc-nox is not installed.
 vlc depends on libsdl-image1.2 (>= 1.2.5); however:
  Package libsdl-image1.2 is not installed.
 vlc depends on libvlc0 (>= 0.8.6-svn20061012.debian); however:
  Package libvlc0 is not installed.
dpkg: error processing vlc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of courier-base:
 courier-base depends on courier-authlib; however:
  Package courier-authlib is not installed.
 courier-base depends on courier-authlib-userdb; however:
  Package courier-authlib-userdb is not configured yet.
dpkg: error processing courier-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of courier-authdaemon:
 courier-authdaemon depends on courier-base (>= 0.47); however:
  Package courier-base is not configured yet.
dpkg: error processing courier-authdaemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vlc-plugin-alsa:
 vlc-plugin-alsa depends on vlc; however:
  Package vlc is not configured yet.
dpkg: error processing vlc-plugin-alsa (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of courier-ssl:
 courier-ssl depends on courier-base (>= 0.53.2); however:
  Package courier-base is not configured yet.
dpkg: error processing courier-ssl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of courier-pop:
 courier-pop depends on courier-base (>= 0.53.2); however:
  Package courier-base is not configured yet.
dpkg: error processing courier-pop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of courier-pop-ssl:
 courier-pop-ssl depends on courier-pop; however:
  Package courier-pop is not configured yet.
 courier-pop-ssl depends on courier-ssl (>= 0.53.2); however:
  Package courier-ssl is not configured yet.
dpkg: error processing courier-pop-ssl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wxvlc:
 wxvlc depends on vlc; however:
  Package vlc is not configured yet.
dpkg: error processing wxvlc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of courier-maildrop:
 courier-maildrop depends on courier-base (>= 0.53.2); however:
  Package courier-base is not configured yet.
dpkg: error processing courier-maildrop (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 courier-authlib-userdb
 vlc-plugin-arts
 vlc
 courier-base
 courier-authdaemon
 vlc-plugin-alsa
 courier-ssl
 courier-pop
 courier-pop-ssl
 wxvlc
 courier-maildrop
-----------

What can I do to correct this issue?

Thanks very much.

James Collins (james-collins) wrote :
description: updated
James Collins (james-collins) wrote :
Download full text (3.9 KiB)

I have tried several things, and have now run

sudo apt-get update

sudo apt-get dist-upgrade, which suggested to use the -f option.

This produces:

sudo apt-get -f upgrade
Password:
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following NEW packages will be installed:
  courier-authlib libsdl-image1.2 libvlc0 vlc-nox
The following packages have been kept back:
  amule azureus libggi2 libgnomebt0 linux-image-386
  linux-restricted-modules-386 mplayer nautilus-sendto python-netcdf thunar
The following packages will be upgraded:
  brltty courier-authdaemon courier-imap courier-imap-ssl ddclient gnome-pilot
  gnome-pilot-conduits gnome-system-tools jackd kappfinder kde-style-lipstik
  kdemultimedia-kappfinder-data klaptopdaemon kuser kwifimanager lame
  libapache-mod-php4 libapache2-mod-php4 libapache2-mod-python2.4
  libapache2-svn libasn1-6-heimdal libavifile-0.7c2 libbcprov-java libbeagle0
  libbeecrypt6 libbrlapi1 libcompfaceg1 libdb-file-lock-perl libdb1-compat
  libdb3 libdb3-util libdbd-mysql-perl libdbi-perl libdvbpsi4 libeel2-2
  libeel2-data libexo-0.3-0 libgdchart-gd1-noxpm libgeoip1 libglib2-ruby
  libglide2 libgnome2-perl libgnome2-vfs-perl libgnucrypto-java
  libgnujaxp-java libgnujaxp-jni libgnutls12 libgssapi4-heimdal
  libgstreamer0.8-ruby libgtk-perl libjack0.100.0-0 libjessie-java
  libkrb5-17-heimdal liblircclient0 liblockfile1 liblog4j1.2-java
  libmail-imapclient-perl libmcal0 libmhash2 libnet-daemon-perl
  libnet-dns-perl libnet-ssleay-perl libnetcdf3 libnetpbm9
  libparse-recdescent-perl libplrpc-perl libpt-1.10.0 libpt-plugins-alsa
  libpt-plugins-v4l libpt-plugins-v4l2 libraptor1 librasqal0 librdf0
  libroken16-heimdal librpm4 librrd2 libscim8c2a libsigc++-1.2-5c2 libskim0
  libsmpeg0 libssl0.9.7 libsvga1 libswt3.1-gtk-java libswt3.1-gtk-jni libtagc0
  libtasn1-2 libterm-readkey-perl libtool libvcdinfo0 libxfce4mcs-client3
  libxfce4mcs-manager3 libxfce4util4 libxfcegui4-4 libxine-extracodecs
  libxxf86dga1 libzzip-0-12 linux-386 logwatch man2html mc menu menu-xdg
  mjpegtools mozilla-acroread mozilla-mplayer mozilla-thunderbird
  myspell-en-us mysql-admin mysql-admin-common nautilus nautilus-cd-burner
  nautilus-data netkit-inetd netpbm nmap ntp ntp-server ntp-simple numlockx
  nvidia-kernel-common odbcinst1debian1 openoffice.org openoffice.org-math
  pdmenu php-pear php4-cgi php4-cli php4-common php4-domxml php4-gd php4-ldap
  php4-mysql php4-snmp php5-cli php5-common php5-mysql php5-mysqli po-debconf
  postgresql-client-common postgresql-common powernowd procmail proftpd
  proftpd-doc python-cddb python-epydoc python-eunuchs python-examples
  python-genetic python-geoip python-gst python-gst0.10 python-parted
  python-pisock python-pqueue python-pyao python-pyogg python-pyvorbis
  python-stats python-unit python2.4-examples python2.4-librdf quota rar
  reportbug rhythmbox rkhunter rpm rrdtool ruby1.8 sane-utils sasl2-bin
  sbackup scim-qtimm skim snmp sound-juicer sqwebmail ssh ssh-askpass-gnome
  streamripper streamtuner subtitleripper totem totem-gstreamer tsclient
  ttf-arabeyes ttf-arphic-bsmi00lp ttf-arphic-gbsn00lp ttf-arphic-gkai00mp
  ttf-bengali-fonts tt...

Read more...

James Collins (james-collins) wrote :

I have since executed the following commands, and things seem to be going well:

apt-get install courier-authlib libsdl-image1.2 libvlc0 vlc-nox

dpkg --ignore-depends= -i courier-authdb_0.58-4ubuntu1_i386.deb
apt-get -f install
apt-get update
apt-get dist-upgrade

Most of the packages have now been set up. There are just a few left.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers