false positive regarding update just after an automaticaly warned update

Bug #68331 reported by K. Deniz Ogut on 2006-10-26
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

My OS: Ubuntu Edgy Eft RC (I hope its RC yet, last updated today (24 October 2006). I used to use Ubuntu 6.06 and had 6.10 via Web upgrade.

Seems to be an update-manager and/or Synaptic issue

The problem is as follows:
When I am warned about the updates automatically by means of that orange button appearing on the uppermost Gnome panel, I click on it and proceed the update. At the beginning the orange warning button warned me that there are 1 updates to be installed. (This was today's case: just something like ubuntu-docs.) After the installation successfully done, that update window refreshes itself in some way as usual. After that, the same window (Re-translating the title of the window from Turkish to English: Software Updates, You can install 3 updates, Distribution updates) tells and advices me to install some more updates. How and why did they appear? Below are the list of software automatically checked and asking me to be installed:

e2fsprogs
From version 1.39-1 to 1.39-1

initscripts
From version 2.86.ds1-14.1ubuntu16 to 2.86.ds1-14.1ubuntu16

volumeid
From version 093-0ubuntu18 to 093-0ubuntu18

As its obvious, each of them have the same version codes regarding "from" and "to" info.

And what's more: Below of that window there is a section for more info on the to-be-updated software. For those three checked/proposed to-be-installed software, that window's "changes and update info" section's "changes" tab states (when you select any of them by clicking on) -again re-translating from Turkish- as follows:
"The list of the changes is not accessible"

On that update info window, there are some more software listed but they are not checked/proposed to be installed. If it may be useful, these are;

hpijs, python-adns, python-clientcookie, python-crypto, python-egenix, mxdatetime, python-egenix-mxproxy, python-egenix-mxstack, python-egenix, mxtexttools, python-gadfly, python-htmlgen, python-htmltmpl, python-imaging, python-imaging-sane, python-jabber, python-kjbuckets, python-Idap, python-mysqldb, python-pam, python-pexpect, python-pgsql, python-pylibacl, python-pyopenssl, python-pyxattr, python-reportlab, python-simpletal, python-soappy, python-sqlite, python-syck, python-xmpp.

For those automatically unchecked ones update version codes seem to be real, at least "from"s and "to"s codes are different and I can see some info on "changes and update info" section "changes" tab when I click on any of them.

Up to this point I doubt that those update offers are not "valid" in some way. To test it, I close that window without installing those "updates", open Synaptic and ask for choosing "all changes" without refreshing it, Synaptic still offers me those three:

e2fsprogs
initscripts
volumeid

I say "cancel" and then refresh Synaptic. It does so. After all package info are downloaded, I again say "select all updates". Result: No updates to be applied available!

What expected: No more update warning after all offered by that orange button are installed. If -for some reason- there are really more updates, those should be seen after refreshing Synaptic, as well.

Reproducable or not: I don't know what to do in order to reproduce the situation, but as I remember I had the same issue some time ago with again Edgy Eft but before RC, during the last phases of Beta.

Michael Vogt (mvo) on 2007-03-09
Changed in update-manager:
importance: Undecided → Medium

After five months and many standard updates the situation is still the same. Those 3 false offer appears all the time after updates. The bug report seems to be "unconfirmed" at the moment; if there's some more info needed, i can send them as well.

Michael Vogt (mvo) wrote :

Thanks for your bugreport and sorry for the late reply.

Can you please run (in a terminal):
$ sudo apt-get dist-upgrade --simulate

and attach the output here?

Thanks,
 Michael

Hi,

Attached.

Regards,

Deniz

Michael Vogt (mvo) wrote :

Thanks a lot for this additional information.

Could you please also attach your /etc/apt/sources.list?

Thanks,
 Michael

Hi Dear Friend Michael,

Attached.

Regards,

Deniz

Hello,

Today (March 27, 2007), I performed an update upon the automatic warning as usual. There were 24 updates and I believe them to be in action for the last couple of days. (My last update was something like 1 week ago and the situation was still the same at that time.) After installing them I didn't get that "false positive". When the installation of the updates finished, there are no more "offers". I'm not sure if its just valid for this time or the problem (if it was a real problem) is fixed in some way by Michael and/or by other developers.

If there's something more to be asked please do so soon, because I'm planning to upgrade to Ubuntu 7.04 and I might not be able to create the situation again or the outputs of the possible commands from developers may not work for the situation anymore.

Regards,

Deniz

Hello,

After today's (March 28, 2007) updates those 3 offer reappeared again: "You can install 3 updates..."

Regards,

Deniz

Hello,

My vmware-player package on Ubuntu 7.10 has a similar problem. Synaptic and apt-get both suggest to upgrade from 1:2.0.2-1~ppa5 to 1:2.0.2-1~ppa5 .

I had the same problem with an older version of vmware-player (a version ending with ppa3, don't know the exact number).

Synaptic and apt-get both already "upgraded" the package to the same version and they still keep on asking to upgrade to the same version.

Notice that vmware-player could not be authenticated. (I installed it from a source at launchpad.)

I attached my sources.list and my terminal told me the following:

root@peter-linux-laptop:/home/peter# apt-get dist-upgrade --simulate
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  vmware-player
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst vmware-player [1:2.0.2-1~ppa5] (1:2.0.2-1~ppa5 Ubuntu:7.10/gutsy)
Conf vmware-player (1:2.0.2-1~ppa5 Ubuntu:7.10/gutsy)

root@peter-linux-laptop:/home/peter# apt-show-versions | grep vmware-player
vmware-player-kernel-modules/gutsy uptodate 1:2.0.2-1~ppa5
vmware-player/gutsy uptodate 1:2.0.2-1~ppa5
vmware-player-kernel-modules-2.6.22-14/gutsy uptodate 1:2.0.2-1~ppa5

Regards,
Peter

istblacken (behlulkahyaoglu) wrote :

i have a similar problem with ubuntu 8.04. false positive update notification this time for two file only.

Michael Vogt (mvo) wrote :

It looks like this is a duplicate of another report, I need the following information:

$ apt-cache show e2fsprogs
$ dpkg -p e2fsprogs

and let me know what server you use (in your /etc/apt/sources.list)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers