update-manager segfaults after upgrading a package

Bug #681454 reported by Jean-Baptiste Lallement on 2010-11-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: update-manager

In Natty, Unity and Gnome u-m segfaults after upgrading a new package

Steps to reproduce:
- Install hello_2.5-1_i386.deb
- Launch u-m
- Click on install

Result:
- The package installs correctly
- u-m crashes with "Segmentation Fault"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.145.3
ProcVersionSignature: Ubuntu 2.6.37-5.14-generic 2.6.37-rc2
Uname: Linux 2.6.37-5-generic i686
Architecture: i386
Date: Thu Nov 25 17:06:18 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager

Jean-Baptiste Lallement (jibel) wrote :
summary: - update-manager segfaults after upgrading a new package
+ update-manager segfaults after upgrading a package
Changed in update-manager (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → natty-alpha-1
tags: added: mago
Michael Vogt (mvo) wrote :

I just tested this on my freshly upgraded natty system (amd64 though) and can not reproduce it. Could you please attach a apport crash?

Changed in update-manager (Ubuntu):
status: Triaged → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

It looks like bug 677442, bug 677510 and bug 681264

Michael Vogt (mvo) on 2010-11-26
Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed
Michael Vogt (mvo) wrote :

Hm, I still can not reproduce the segfault on my box.

Changed in update-manager (Ubuntu):
milestone: natty-alpha-1 → natty-alpha-2
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) on 2010-12-13
Changed in update-manager (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Michael Vogt (mvo)
Jean-Baptiste Lallement (jibel) wrote :

I'm closing this report. This issue fixed itself and I'm unable to reproduce the problem on the system which had it.
Thanks.

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers