update-manager fails to start

Bug #671222 reported by Stephen Cradock on 2010-11-05
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Python
Invalid
Undecided
Unassigned
Software Updater
Fix Released
Undecided
Unassigned
python2.7 (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
High
Luis Oscar Alves Borges

Bug Description

Binary package hint: update-manager

after upgrading update-manager on Nov/04/2010 the program fails to start from the menu.

Running "update-manager" in a terminal generates the following failure message:

~$ update-manager
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 32, in <module>
    from UpdateManager.UpdateManager import UpdateManager
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 32, in <module>
    import gconf
ImportError: No module named gconf

There are already a couple of confirming reports in the Natty forum.......

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.145
ProcVersionSignature: Ubuntu 2.6.36-1.7-generic 2.6.36
Uname: Linux 2.6.36-1-generic x86_64
Architecture: amd64
Date: Thu Nov 4 17:32:01 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager

Stephen Cradock (s-cradock) wrote :
Quackers (quackers) wrote :

Same here

Roy Jamison (xteejx) wrote :

I can confirm this with update-manager version 1:0.145 in natty

Changed in update-manager (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Roy Jamison (xteejx) wrote :

Looking at the diff between the Maverick and Natty versions, there doesn't appear to be any changes in update-manager that could have caused this, setting python-2.7 as also affected.

Changed in python2.7 (Ubuntu):
status: New → Incomplete
Changed in python:
status: New → Invalid
Roy Jamison (xteejx) on 2010-11-06
Changed in update-manager:
status: New → Confirmed
Stephen Cradock (s-cradock) wrote :

The immediate cause of this failure is that the package python-gconf has not been upgraded to python2.7, so the module gconf is not available. There are other modules missing too, so this is basically due to an incomplete upgrade of python2.7. No doubt some good soul is busily working to bring all the missing modules in...... Thanks!

Roy Jamison (xteejx) wrote :

I'll ask MOTU if this is planning to be upgraded soon to fix this problem.

Scott Kitterman (kitterman) wrote :

Actually this is, I think, an update-manager bug. python-gconf does need to be rebuilt for python2.7, but python2.6 is the default python in Natty and so that's what update-manager should be using.

Stephen Cradock (s-cradock) wrote :

Scott, you are correct. The first line of /usr/bin/update-manager contains the string python2.7

Changing this to python2.6 restores the update-manager program to normal functionality.

Quackers (quackers) wrote :

Thanks SC, I changed the first line entry to python2.6 and UM is now working again. As you said it would :-)

Roy Jamison (xteejx) wrote :

Here is a fix that should work. It changes the XS-Python-Version to explicitly set python2.6 during build.
At least until it is rewritten for 2.7 anyway.

Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
Changed in python2.7 (Ubuntu):
status: Incomplete → Invalid
Barry Warsaw (barry) on 2010-11-07
tags: added: python27
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Barry Warsaw (barry) wrote :

python-gconf is in the source package gnome-python right? I think someone with upload rights needs to trigger a rebuild of that package to pick up the Python 2.7 support. It builds fine for me in my sbuild.

Barry Warsaw (barry) wrote :

FWIW, I'm building both gconf and gnome-python in the ~pythoneers/py27stack PPA. Once that's done, I'll test upgrade-manager.

Barry Warsaw (barry) wrote :

Looks like we need to rebuild python-apt too.

Roy Jamison (xteejx) wrote :

Thank you for the progress update, very much appreciated! :)

Barry Warsaw (barry) wrote :

You might also want to follow bug 672843 as it's currently blocking progress on this.

Barry Warsaw (barry) wrote :

Latest update: python-apt builds fine in my PPA now too, with no changes, so I have no idea what's going on. In any case, python-dbus now needs a rebuild.

Barry Warsaw (barry) wrote :

Okay, rebuilding python-dbus does fix update-manager so that it runs, but this Python bug causes it to crash:

http://bugs.python.org/issue10379

(a regression in acceptable input values for locale.format())

I'll see if I can patch u-m to work around this, and work on getting a fix in upstream Python.

I'll also request rebuilds for the following packages: dbus-python, python-apt, gnome-python

Barry Warsaw (barry) wrote :

The update-manager fix has been uploaded, and between mvo and cjwatson, the dependent packages will get rebuilt. So I think this bug can be closed.

Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
Changed in update-manager:
status: Confirmed → Fix Released
Noel J. Bergman (noeljb) wrote :

I just received the updates noted so far, and still get the error. Current packages are:

  python-apt-common 0.7.98.1ubuntu2
  python-apt 0.7.98.1ubuntu2
  python-dbus 0.83.0-1ubuntu4
  update-manager 1:0.145.1
  update-manager-core 1:0.145.1
  python-gconf 2.28.1-1ubuntu2

$ update-manager
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 32, in <module>
    from UpdateManager.UpdateManager import UpdateManager
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 32, in <module>
    import gconf
ImportError: No module named gconf

Do we still need another module rebuilt?

@noeljb: The current version of python-gconf is 2.28.1-1ubuntu3, please update your system.

Barry Warsaw (barry) wrote :

Yes, I think this bug is legitimately resolved. It works for me (caveat below) on a fully updated Natty VM.

There is however a different bug in the backend when updating the package list. I'll file a separate bug on that because it is a completely different problem, probably unrelated to the Python 2.7 transition.

Noel J. Bergman (noeljb) wrote :

Yes, the other updates come through this AM, and update-manager is working here, too.

tags: added: mago
Changed in update-manager (Ubuntu):
assignee: Michael Vogt (mvo) → Luis Oscar Alves Borges (fumacalindo)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.