update-manager shows error message twice for software sources without changelog support

Bug #665173 reported by Victor Zamanian on 2010-10-22
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Robert Roth

Bug Description

Binary package hint: update-manager

When running update-manager, and there are updates for packages that come from repositories that do not support changelogs, there is a message in the "Description of Update", part of the GUI (in the Changes-tab) and it has a message that looks like this:

"This change is not coming from a source that supports changelogs.This change is not coming from a source that supports changelogs."

and exactly like that (without the quotes). The message is, as can be seen here, printed twice.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: update-manager 1:0.142.21
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Oct 22 17:29:36 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager

Related branches

Victor Zamanian (victorz) wrote :
Victor Zamanian (victorz) wrote :
Lilonius (ilirjusufi) wrote :

I got it for the sp-auth package. It is a library used by Sopcast player. Here is a screen-shot

Robert Roth (evfool) on 2011-02-15
Changed in update-manager (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
Robert Roth (evfool) on 2011-04-04
Changed in update-manager (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Robert Roth (evfool)
Robert Roth (evfool) on 2011-04-05
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.147.3

---------------
update-manager (1:0.147.3) natty; urgency=low

  * merged lp:~evfool/update-manager/fix665173 (LP: #665173),
    many thanks to Robert Roth (update the test a bit)
  * merged lp:~evfool/update-manager/fix150677 (LP: #150677),
    many thanks to Robert Roth
  * merged lp:~evfool/update-manager/fix727069 (LP: #727069),
    many thanks to Robert Roth
 -- Michael Vogt <email address hidden> Wed, 06 Apr 2011 17:32:35 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions