update-manager crashed with DBusException in _run()

Bug #626798 reported by sethloco on 2010-08-30
This bug affects 421 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
High
Unassigned
Natty
High
Unassigned
policykit (Ubuntu)
High
Canonical Foundations Team
Natty
High
Canonical Foundations Team
update-manager (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Upgrading via apt-get works just fine.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: update-manager 1:0.142.11
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Mon Aug 30 08:39:38 2010
ExecutablePath: /usr/bin/update-manager
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.6 /usr/bin/update-manager
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with DBusException in _run()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

sethloco (sethloco78-linux) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
Michael Vogt (mvo) on 2011-03-09
visibility: private → public
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

I can trigger this bug by clicking on install and then just wait in the password dialog. Eventually this crash will happen.

tags: added: bugpattern-written
removed: bugpattern-needed
Changed in aptdaemon (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in aptdaemon (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
RedSingularity (redsingularity) wrote :

Confirmed here as well. Followed Michael's instruction in comment 2. Just let the password dialog hang and the error appears.

Colin Watson (cjwatson) on 2011-04-02
Changed in aptdaemon (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
sarton85 (sarton85) wrote :

Update Manager just crashed when trying to update Ubuntu 11.04. I have just upgraded my computer from an Ubuntu 10.10 install. Apt-get in terminal is working fine.

This is the error it gave: "update-manager crashed with DBusException in _run(): org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

I am sure that the network connection wasn't broken.

John Winterton (jwinterton) wrote :

I did a load from the beta1 disk today and got several errors. I booted and ran dpkg from the boot, and all sieems to have gone OK, however, I will report another problem with fglrx when I get back on 11.04 under low-graphics mode.

My hardware is set for constant uptime, and was up for about an hour I
think, however something was making it unstable and I opened a guest
session. All was fine there. When I closed that, and went back, I got the
error.

On Mon, Apr 4, 2011 at 7:34 PM, John Winterton <email address hidden> wrote:

> I did a load from the beta1 disk today and got several errors. I booted
> and ran dpkg from the boot, and all sieems to have gone OK, however, I
> will report another problem with fglrx when I get back on 11.04 under
> low-graphics mode.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (749592).
> https://bugs.launchpad.net/bugs/626798
>
> Title:
> update-manager crashed with DBusException in _run()
>
> Status in “aptdaemon” package in Ubuntu:
> Triaged
> Status in “policykit” package in Ubuntu:
> New
> Status in “update-manager” package in Ubuntu:
> Confirmed
> Status in “aptdaemon” source package in Natty:
> Triaged
> Status in “policykit” source package in Natty:
> New
> Status in “update-manager” source package in Natty:
> Confirmed
>
> Bug description:
> Binary package hint: update-manager
>
> Upgrading via apt-get works just fine.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: update-manager 1:0.142.11
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> Date: Mon Aug 30 08:39:38 2010
> ExecutablePath: /usr/bin/update-manager
> InterpreterPath: /usr/bin/python2.6
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python2.6 /usr/bin/update-manager
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/update-manager']
> SourcePackage: update-manager
> Title: update-manager crashed with DBusException in _run()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/626798/+subscribe
>

--
Click this link to view my resume on google docs:
https://docs.google.com/Doc?docid=0AXvu1Pk_YSHfZGMyZDNjMmdfN2Y2azRxbWQz&hl=en

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.147.2

---------------
update-manager (1:0.147.2) natty; urgency=low

  * UpdateManager/backend/InstallBackendAptdaemon.py:
    - no not trigger a apport exception on user auth issues and if
      the user does not type the password in time (LP: #626798)
 -- Michael Vogt <email address hidden> Tue, 05 Apr 2011 15:49:58 +0200

Changed in update-manager (Ubuntu Natty):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.41+bzr614-0ubuntu1

---------------
aptdaemon (0.41+bzr614-0ubuntu1) natty; urgency=low

  * New bzr bugfix snapshot:
    - fix i18n crash (LP: #724735)
    - Allow to specify package names with an architecture
      (for multiarch)
    - Client: Exit the transaction processing if there has been an
      error
    - Make the run method of the GTK2 progress dialog deferable
      (LP: #626798)
  * debian/patches/01_relax_lintian_checks.patch:
    - add lp:~mvo/aptdaemon/relax-lintian-checks as distro patch
      until upstream (LP: #712377)
 -- Michael Vogt <email address hidden> Tue, 05 Apr 2011 16:31:37 +0200

Changed in aptdaemon (Ubuntu Natty):
status: Triaged → Fix Released
Kate Stewart (kate.stewart) wrote :

policy-kit has status new, and is still lingering. I've gone ahead and marked it confirmed, if its not valid, and the bug is completely fixed. Please indicate. Setting priority base on the number of duplicates associated with this bug.

Changed in policykit (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
sk (yahs) wrote :

Error fixed for me.
I update Natty daily (last one 18th April) and everything is working well.

Phil Mundy (p-p-mundy) wrote :

Mines now ok since manual fix, at least for
last updates.
Cheers.

-- Sent from my HTC Desire on 3 --

----- Reply message -----
From: "sk" <email address hidden>
Date: Mon, Apr 18, 2011 17:57
Subject: [Bug 626798] Re: update-manager crashed with DBusException in _run()
To: <email address hidden>

Error fixed for me.
I update Natty daily (last one 18th April) and everything is working well.

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (762571).
https://bugs.launchpad.net/bugs/626798

Title:
  update-manager crashed with DBusException in _run()

Status in “aptdaemon” package in Ubuntu:
  Fix Released
Status in “policykit” package in Ubuntu:
  Confirmed
Status in “update-manager” package in Ubuntu:
  Fix Released
Status in “aptdaemon” source package in Natty:
  Fix Released
Status in “policykit” source package in Natty:
  Confirmed
Status in “update-manager” source package in Natty:
  Fix Released

Bug description:
  Binary package hint: update-manager

  Upgrading via apt-get works just fine.

  ProblemType: Crash
  DistroRelease: Ubuntu 10.10
  Package: update-manager 1:0.142.11
  ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
  Uname: Linux 2.6.35-19-generic i686
  NonfreeKernelModules: wl
  Architecture: i386
  Date: Mon Aug 30 08:39:38 2010
  ExecutablePath: /usr/bin/update-manager
  InterpreterPath: /usr/bin/python2.6
  PackageArchitecture: all
  ProcCmdline: /usr/bin/python2.6 /usr/bin/update-manager
  ProcEnviron:
   PATH=(custom, user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  PythonArgs: ['/usr/bin/update-manager']
  SourcePackage: update-manager
  Title: update-manager crashed with DBusException in _run()
  UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/626798/+subscribe

dghws@cox.net (dghws) wrote :

Problem was corrected with latest updates.
Thanks

---- Kate Stewart <email address hidden> wrote:
> policy-kit has status new, and is still lingering. I've gone ahead and
> marked it confirmed, if its not valid, and the bug is completely fixed.
> Please indicate. Setting priority base on the number of duplicates
> associated with this bug.
>
> ** Changed in: policykit (Ubuntu Natty)
> Status: New => Confirmed
>
> ** Changed in: policykit (Ubuntu Natty)
> Importance: Undecided => High
>
> ** Changed in: policykit (Ubuntu Natty)
> Assignee: (unassigned) => Canonical Foundations Team (canonical-foundations)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (753055).
> https://bugs.launchpad.net/bugs/626798
>
> Title:
> update-manager crashed with DBusException in _run()
>
> Status in “aptdaemon” package in Ubuntu:
> Fix Released
> Status in “policykit” package in Ubuntu:
> Confirmed
> Status in “update-manager” package in Ubuntu:
> Fix Released
> Status in “aptdaemon” source package in Natty:
> Fix Released
> Status in “policykit” source package in Natty:
> Confirmed
> Status in “update-manager” source package in Natty:
> Fix Released
>
> Bug description:
> Binary package hint: update-manager
>
> Upgrading via apt-get works just fine.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: update-manager 1:0.142.11
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> Date: Mon Aug 30 08:39:38 2010
> ExecutablePath: /usr/bin/update-manager
> InterpreterPath: /usr/bin/python2.6
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python2.6 /usr/bin/update-manager
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/update-manager']
> SourcePackage: update-manager
> Title: update-manager crashed with DBusException in _run()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/626798/+subscribe

Bill Pearce (pearceg) wrote :

Hi, It is fixed for my desktop computer and I am upto date. I still
have problems with a netrbook which I was last able to update 2 weeks
ago. However I will wait until apr 28 and reinstall Xubuntu on it.

On 04/18/2011 12:19 AM, Kate Stewart wrote:
> policy-kit has status new, and is still lingering. I've gone ahead and
> marked it confirmed, if its not valid, and the bug is completely fixed.
> Please indicate. Setting priority base on the number of duplicat

dino99 (9d9) wrote :
Changed in policykit (Ubuntu):
status: Confirmed → Invalid
Changed in policykit (Ubuntu Natty):
status: Confirmed → Invalid

"[Bug 626798] Re: update-manager crashed with DBusException in _run()"
dino99 doc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers