Ubuntu

"Exception: No date tag found" in ubuntu-support-status

Reported by Tomas Cassidy on 2010-08-23
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Robert Roth
Lucid
Low
Unassigned

Bug Description

Binary package hint: update-manager

I got the following error when running ubuntu-support-status:

$ ubuntu-support-status
Traceback (most recent call last):
  File "/usr/bin/ubuntu-support-status", line 105, in <module>
    (still_supported, support_str) = get_maintenance_status(cache, pkg.name, support_tag)
  File "/usr/bin/ubuntu-support-status", line 37, in get_maintenance_status
    raise Exception("No date tag found")
Exception: No date tag found

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: update-manager-core 1:0.134.10
ProcVersionSignature: Ubuntu 2.6.32-24.41-server 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-server x86_64
Architecture: amd64
Date: Mon Aug 23 10:23:48 2010
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager

Related branches

Tomas Cassidy (tomas-cassidy) wrote :
Krzysztof Klimonda (kklimonda) wrote :

I can confirm that. What seems to be happening is that some packages (in my case linux-image-2.6.32-23-virtual) are not in lucid pocket but only in lucid-updates but ubuntu-support-status checks them all against lucid pocket:
(from /usr/bin/ubuntu-support-status)
    # try to figure out the support dates of the release and make
    # sure to look only for stuff in "Ubuntu" and "distro_codename"
    # (to exclude stuff in ubuntu-updates for the support time
    # calculation because the "Release" file time for that gets
    # updated regularly)
    releasef = get_release_filename_for_pkg(cache, pkgname,
                                            "Ubuntu", CODENAME)

in this case get_release_filename_for_pkg returns None and so does the following call to get_release_date_from_release_file. Because of that time_t is unset and exception raised.

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Anakin Starkiller (sunrider) wrote :

Any workaround ?

Workaround:

@@ -30,6 +30,9 @@
     # updated regularly)
     releasef = get_release_filename_for_pkg(cache, pkgname,
                                             "Ubuntu", CODENAME)
+ if not releasef:
+ releasef = get_release_filename_for_pkg(cache, pkgname,
+ "Ubuntu", CODENAME + "-updates")
     time_t = get_release_date_from_release_file(releasef)
     # check the release date and show support information
     # based on this

Workaround

tags: added: patch
Robert Roth (evfool) on 2011-07-12
Changed in update-manager (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Robert Roth (evfool) on 2011-07-18
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Robert Roth (evfool) on 2011-07-25
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released

This bug is still found in version 1:0.134.12.1 found in Ubuntu 10.04 LTS (lucid).
Are there any plans for a fix for lucid?

Changed in update-manager (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches