Failing to fetch some packages should display a better/nicer error message

Bug #61852 reported by wiertel on 2006-09-22
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Michael Vogt

Bug Description

It happend one deb file is missing in pool on server. When I let update-manager to do dist-upgrade it shows me info about critical error, says something about bug.
I think it could be nice message instead of this.
update-manager has no chance to clean up, sources.list.distUpgrade was mentioned. Is there anything else it could possibly messed up?

[edit] Well, it seems that the exception was raised when it tried to clean up.

wiertel (wiertel) wrote :
wiertel (wiertel) on 2006-09-22
description: updated
Michael Vogt (mvo) on 2006-09-25
Changed in update-manager:
importance: Untriaged → Medium
status: Unconfirmed → Confirmed

Thanks for your bugreport.

I fixed the error when it tries to restore the sources.list. It will still abort when it can't find a file, but at least in a more graceful way.

Cheers,
 Michael

Changed in update-manager:
assignee: nobody → mvo
status: Confirmed → In Progress
Michael Vogt (mvo) on 2006-10-06
Changed in update-manager:
importance: Medium → Wishlist
status: In Progress → Confirmed
Diego Gaustein (gregorovius) wrote :

I had the same thing happen to me. Update-manager aborted because it couldn't find one package in ~1400 (mostly because of a shaky internet conenction), asked me to fill out a bug report, said my system could be left in a broken state, etc; when all it needed was to retry.

I think a better aproach would be to try to fetch the package again a couple of times, or ask for user input.

Jean-Baptiste Lallement (jibel) wrote :

This is fixed in the newest releases of update-manager.

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments