update-manager crashed with TransactionFailed in _run()

Bug #616107 reported by aguy on 2010-08-10
688
This bug affects 112 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

tried to perform update-manager -d and then an upgrade using update manager

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: update-manager 1:0.142.6
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CheckboxSubmission: db218ff4bfb847568a3eec852625430b
CheckboxSystem: abf102d6ef41328208f5c1554651535a
Date: Tue Aug 10 23:32:33 2010
ExecutablePath: /usr/bin/update-manager
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.6 /usr/bin/update-manager -d
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.utf8
PythonArgs: ['/usr/bin/update-manager', '-d']
SourcePackage: update-manager
Title: update-manager crashed with TransactionFailed in _run()
UserGroups: adm admin audio cdrom lpadmin netdev operator plugdev sambashare syslog video

visibility: private → public
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
MoLE (moleonthehill) wrote :

Confirmed bug in latest natty shapshot.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Don Owen (donald.e.owen) wrote :

Also getting bug on amd64 build, nightly natty build, current date.

Barry Drake (b-drake) wrote :

Failed while trying to update 'GStreamer plugins' package. Natty nightly build current date.

Dider (fazerdider) on 2011-04-03
Changed in update-manager (Ubuntu):
status: Confirmed → In Progress
Dider (fazerdider) on 2011-04-03
Changed in update-manager (Ubuntu):
status: In Progress → Incomplete
status: Incomplete → Confirmed
ginosal (driver-8) wrote :

Fixed (I think) on my Natty beta by running:

sudo apt-get install -f

in a terminal. It fixed missing dependencies.

Not yet.. Terminal output:

Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer
required:
  lib32gomp1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 231 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing libc6 (--configure):
 libc6:amd64 2.13-0ubuntu12 cannot be configured because libc6:i386 is
in a different version (2.13-0ubuntu11)
dpkg: dependency problems prevent configuration of libc-dev-bin:
 libc-dev-bin depends on libc6 (>> 2.13~); however:
  Package libc6 is not configured yet.
 libc-dev-bin depends on libc6 (<< 2.14); however:
  Package libc6 is not configured yet.
dpkg: error processing libc-dev-bin (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a
followup error from a previous failure.

No apport report written because the error message indicates its a
followup error from a previous failure.
                                            dpkg: dependency problems
prevent configuration of libc6-dev:
 libc6-dev depends on libc6 (= 2.13-0ubuntu12); however:
  Package libc6 is not configured yet.
 libc6-dev depends on libc-dev-bin (= 2.13-0ubuntu12); however:
  Package libc-dev-bin is not configured yet.
dpkg: error processing libc6-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-i386:
 libc6-i386 depends on libc6 (= 2.13-0ubuntu12); however:
  Package libc6 is not configured yet.
dpkg: error processing libc6-i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors
were encountered while processing:
 libc6
 libc-dev-bin
 libc6-dev
 libc6-i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

On Thu, 2011-04-07 at 13:34 +0000, ginosal wrote:
> Fixed (I think) on my Natty beta by running:
>
> sudo apt-get install -f
>
> in a terminal. It fixed missing dependencies.
>

Brian Murray (brian-murray) wrote :

Looking at the duplicates of this bug:

LP: #616107 has a total of 49 duplicates
DistroRelease
  [22] Ubuntu 10.10: 611353, 612280, 612581, 614172, 617422, 617538, 617684, 617829, 630187, 643231, 647322, 648725, 648989, 649301, 649617, 651056, 652368, 653497, 674106, 693485, 719864, 765566
  [27] Ubuntu 11.04: 710353, 710460, 711041, 712135, 713631, 713709, 714423, 716181, 716650, 719562, 720963, 721333, 722096, 722496, 723519, 724418, 728906, 730182, 734511, 739690, 743790, 744171, 748802, 749549, 752081, 757995, 771478

This doesn't seem to appear in a release newer than Natty. Additionally, there no other crashes with 'transactionfailed ... cache-broken' in them.

tags: added: natty
removed: bugpattern-needed
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Mörgæs (moergaes) wrote :

This seems to be fixed, so closing the report.
If a similar bug appears in 13.10 please open a new one.

Changed in update-manager (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.