Kubuntu upgrade 9.10 -> 10.4 fails: rarian-compat conflicts with scrollkeeper / scrollkeeper (version 0.8.1-4ubuntu1) is present and unpacked but not configured.

Bug #573476 reported by Aaron Novstrup on 2010-05-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Distribution upgrade failed during the "Installing the upgrades" phase with the message "Could not install the upgrade The upgrade is now aborted. Your system could be in an unusable state. A recover will run now (dpkg --configure -a). Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report. E:Sub-process /usr/bin/dpkg return an error code (1), E:Sub-process /usr/bin/dpkg return an error code (1)"

Aaron Novstrup (slick50) wrote :
Aaron Novstrup (slick50) wrote :
Aaron Novstrup (slick50) wrote :
Aaron Novstrup (slick50) wrote :
Aaron Novstrup (slick50) wrote :
Aaron Novstrup (slick50) wrote :
Monkey (monkey-libre) on 2010-05-02
tags: added: karmic2lucid
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

The relevant error is
---
Preparing to replace scrollkeeper 0.3.14-16ubuntu1 (using .../scrollkeeper_0.8.1-4ubuntu1_all.deb) ...
Unpacking replacement scrollkeeper ...
dpkg: warning: unable to delete old directory '/var/lib/scrollkeeper': Directory not empty
Preparing to replace librarian0 0.8.1-2ubuntu3 (using .../librarian0_0.8.1-4ubuntu1_amd64.deb) ...
Unpacking replacement librarian0 ...
Selecting previously deselected package rarian-compat.
dpkg: regarding .../rarian-compat_0.8.1-4ubuntu1_amd64.deb containing rarian-compat:
 rarian-compat conflicts with scrollkeeper
  scrollkeeper (version 0.8.1-4ubuntu1) is present and unpacked but not configured.
dpkg: error processing /var/cache/apt/archives/rarian-compat_0.8.1-4ubuntu1_amd64.deb (--unpack):
 conflicting packages - not installing rarian-compat

summary: - Kubuntu upgrade 9.10 -> 10.4 fails
+ Kubuntu upgrade 9.10 -> 10.4 fails: rarian-compat conflicts with
+ scrollkeeper / scrollkeeper (version 0.8.1-4ubuntu1) is present and
+ unpacked but not configured.
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
ilia Lobsanov (ilia-lobsanov) wrote :

is there a workaround?

Bert Esser (bert-esser) wrote :

Having same problem and so I'm unable to update anything on my system.

ilia Lobsanov (ilia-lobsanov) wrote :

A workaround that works for me is:
sudo dpkg -r --force-depends scrollkeeper

Then you can:
sudo apt-get -f install
sudo apt-get upgrade

Bert Esser (bert-esser) wrote :

@ilia thanks a lot!!!
It works!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers