Karmic -> Lucid server upgrade package removal list incomplete

Bug #558438 reported by Scott Kitterman on 2010-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Excepts from the terminal log below. The upgrade tool says 29 packages will be removed, but when I look at details, I get a list of only 14. You can see then the ones that actually got removed.

Remove obsolete packages?

29 packages are going to be removed.

Remove: cpp-4.2 gcc-4.2-base libiw29 linux-image-2.6.31-11-generic
  linux-image-2.6.31-12-generic linux-image-2.6.31-14-generic
  linux-image-2.6.31-15-generic linux-image-2.6.31-16-generic
  linux-image-2.6.31-17-generic linux-image-2.6.31-19-generic mailx
  python2.5 python2.5-minimal

Removing gcc-4.2 ...
Removing cpp-4.2 ...
Removing db4.7-util ...
Removing gcc-4.2-base ...
Removing libbind9-50 ...
Removing libcompress-bzip2-perl ...
Removing libisccfg50 ...
Removing libdns53 ...
Removing libunbound1 ...
Removing libevent-1.4-2 ...
Removing libisccc50 ...
Removing libisc50 ...
Removing libiw29 ...
Removing liblwres50 ...
Removing libntfs-3g54 ...
Removing libyaml-0-1 ...
Removing linux-image-2.6.31-11-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-11-generic /boot/vmlinuz-2.6.31-11-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Removing linux-image-2.6.31-12-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-12-generic /boot/vmlinuz-2.6.31-12-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Removing linux-image-2.6.31-14-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-14-generic /boot/vmlinuz-2.6.31-14-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Removing linux-image-2.6.31-15-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-15-generic /boot/vmlinuz-2.6.31-15-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Removing linux-image-2.6.31-16-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-16-generic /boot/vmlinuz-2.6.31-16-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Removing linux-image-2.6.31-17-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-17-generic /boot/vmlinuz-2.6.31-17-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-19-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Removing linux-image-2.6.31-19-generic ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/last-good-boot 2.6.31-19-generic /boot/vmlinuz-2.6.31-19-generic
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.32-19-generic
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.28-15-server
Found kernel: /boot/memtest86+.bin
Replacing config file /var/run/grub/menu.lst with new version
Updating /boot/grub/menu.lst ... done

Removing mailx ...
Removing python-celementtree ...
Removing python-elementtree ...
Removing python2.5-dev ...
Removing python2.5 ...
Removing python2.5-minimal ...
Unlinking and removing bytecode for runtime python2.5
    python-pkg-resources: 2.6 (['install', 'ok', 'installed'])
    python-yaml: 2.6 (['install', 'ok', 'installed'])
    python-zope.interface: 2.6 (['install', 'ok', 'installed'])
    lsb-release: 2.6 (['install', 'ok', 'installed'])
    bzr: 2.6 (['install', 'ok', 'installed'])
    python-apport: 2.6 (['install', 'ok', 'installed'])
    python-dns: >= 2.3 (['install', 'ok', 'installed'])
    python-pexpect: all (['install', 'ok', 'installed'])
    python-newt: 2.6 (['install', 'ok', 'installed'])
    update-manager-core: 2.6 (['install', 'ok', 'installed'])
    python-spf: all (['install', 'ok', 'installed'])
    python-subnettree: all (['install', 'ok', 'installed'])
    python-serial: all (['install', 'ok', 'installed'])
    python-problem-report: 2.6 (['install', 'ok', 'installed'])
    ufw: 2.6 (['install', 'ok', 'installed'])
    command-not-found: 2.6 (['install', 'ok', 'installed'])
    python-pam: 2.6 (['install', 'ok', 'installed'])
    python-twisted-core: 2.6 (['install', 'ok', 'installed'])
    postfix-policyd-spf-python: >= 2.4 (['install', 'ok', 'installed'])
    python-oauth: >=2.4 (['install', 'ok', 'installed'])
    landscape-common: 2.6 (['install', 'ok', 'installed'])
    python-apt: 2.6 (['install', 'ok', 'installed'])
    language-selector-common: current (['install', 'ok', 'installed'])
Processing triggers for man-db ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

tags: added: iso-testing
Michael Vogt (mvo) on 2010-04-12
Changed in update-manager (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) on 2010-04-12
Changed in update-manager (Ubuntu Lucid):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.134.1

---------------
update-manager (1:0.134.1) lucid; urgency=low

  * DistUpgrade/DistUpgradeController.py:
    - honor "DEBIAN_FRONTEND=noninteractive" on pkg failure (LP: #538206)
  * DistUpgrade/DistUpgradeQuirks.py:
    - stop apparmor before dpkg starts on hardy -> lucid upgrades to
      avoid potentially confusing error messages during the upgrade
      (LP: #559433)
  * DistUpgrade/DistUpgradeCache.py, DistUpgrade/build-tarball.sh:
    - include obselte nvidia pkgnames to properly transition old
      to new drivers (LP: #553369)
  * DistUpgrade/DistUpgradeViewText.py:
    - show packages that will be removed (because they were auto installed)
      as well (LP: #558438)
    - fix i18n bug in details output
  * UpdateManager/Core/MyCache.py:
    - support third party changelogs by using ArchiveURI() and
      append a similar structure as changelogs.ubuntu.com uses
      (LP: #45129)
  * UpdateManager/Core/MetaRelease.py:
    - do not crash if meta-release file can not be parsed, just remove
      the broken file instead (LP: #558396)
 -- Michael Vogt <email address hidden> Mon, 12 Apr 2010 18:32:59 +0200

Changed in update-manager (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers