'The following updates will be skipped' message when a package is pinned via synaptic

Bug #55369 reported by Dennis Kaarsemaker
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Invalid
Medium
Michael Vogt

Bug Description

Everytime I start update-manager it will tell me it cannot upgrade fglrx-control and thus will skip this update. However, fglrx-control is already at the latest version!

dennis@mirage:~$ apt-cache policy fglrx-control
fglrx-control:
  Installed: 8.27.10-1
  Candidate: 8.27.10-1
  Version table:
 *** 8.27.10-1 0
        500 http://seveas.ubuntulinux.nl dapper-seveas/all Packages
        100 /var/lib/dpkg/status
     8.25.18+2.6.15.11-1 0
        500 http://nl.archive.ubuntu.com dapper/restricted Packages

(Yes, this is from a 3rd party repo but that should not make a difference)

Revision history for this message
John Vivirito (gnomefreak) wrote :

Ubuntu doesnt support 3rd party repos.

Changed in update-manager:
status: Unconfirmed → Rejected
Revision history for this message
Dennis Kaarsemaker (dennis) wrote :

Sigh... that is not an issue here. The problem is that update-manager thinks it should update something that's at the highest version.

Changed in update-manager:
status: Rejected → Unconfirmed
Revision history for this message
Sebastian Heinlein (glatzor) wrote :

We support third party repositories. Not providing support for the software in a third a party is different from providing the possibilty to use third party repos at all.

Revision history for this message
Michael Vogt (mvo) wrote :

Could you please run the following commands for me?

$ python -c 'import apt; print apt.Cache()["fglrx-control"].isUpgradable'

$ sudo apt-get dist-upgrade -s

Preferable if the system is otherwise up-to-date? I have seen this before I think but was not able to nail it down.

Cheers,
 Michael

Changed in update-manager:
assignee: nobody → mvo
importance: Untriaged → Medium
status: Unconfirmed → Needs Info
Revision history for this message
Dennis Kaarsemaker (dennis) wrote : Re: [Bug 55369] Re: Bogus 'the following updates will be skipped'

dennis@mirage:~$ sudo apt-get dist-upgrade -s
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade...Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dennis@mirage:~$ python -c 'import apt; print apt.Cache()["fglrx-control"].isUpgradable'
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not stable yet warnings.warn("apt API not stable yet", FutureWarning)
0

Revision history for this message
Dennis Kaarsemaker (dennis) wrote : Re: [Bug 55369] Bogus 'the following updates will be skipped'

I pinned the issue down (pun intended) and will leave it up to you to
determine whether this is a bug or not.

After looking through the update-manager source, I discovered the
markedKeep variable, and guess what:

>>> apt.Cache()['fglrx-control'].markedKeep
1

It turned out that I pinned it to an older version in synaptic, and
upgraded the package it with apt-get (which doesn't look at synaptics
pinning). I don't think update-manager should complain in this situation
though since the package is not upgradable.

Michael Vogt (mvo)
Changed in update-manager:
status: Needs Info → Confirmed
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: Confirmed → Incomplete
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers