Exception during pm.DoInstall()

Bug #534999 reported by Fionn on 2010-03-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

root@cardassian ~ # lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

root@cardassian ~ # do-release-upgrade -d
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'

Reading cache
Checking package manager
Continue running under SSH?
This session appears to be running under ssh. It is not recommended
to perform a upgrade over ssh currently because in case of failure it
is harder to recover.
If you continue, an additional ssh daemon will be started at port '9004'.
Do you want to continue?
Continue [yN] y

Starting additional sshd
To make recovery in case of failure easier, an additional sshd will
be started on port '9004'. If anything goes wrong with the running
ssh you can still connect to the additional one.

Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done downloading
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done

Updating repository information
Third party sources disabled
Some third party entries in your sources.list were disabled. You can
re-enable them after the upgrade with the 'software-properties' tool
or your package manager.
Done downloading
Checking package manager
Reading package lists: Donelucid-security/multiverse Packages: 99
Reading state information: Done
Reading state information: Done
Reading state information: Done

Calculating the changes
Support for some applications ended

Canonical Ltd. no longer provides support for the following software
packages. You can still get support from the community.

Demoted:
libcompress-bzip2-perl, libiw29, netcat-traditional

Calculating the changes
Starting
Starting 2
Investigating libparted1.8-12
Package libparted1.8-12 has broken Conflicts on libparted0
  Considering libparted0 9999 as a solution to libparted1.8-12 4
    Reinst Failed because of protected libparted0
  Removing libparted1.8-12 rather than change libparted0
Investigating parted
Package parted has broken Depends on libparted1.8-12
  Considering libparted1.8-12 4 as a solution to parted 3
  Re-Instated parted
Done

Do you want to start the upgrade?

3 packages are going to be removed. 65 new packages are going to be
installed. 313 packages are going to be upgraded.

You have to download a total of 168M. This download will take about
21 minutes with a 1Mbit DSL connection and about 6 hours with a 56k
modem.

Fetching and installing the upgrade can take several hours. Once the
download has finished, the process cannot be cancelled.

 Continue [yN] Details [d]y

Fetching
Done downloading

Upgrading
Done downloading
Exception during pm.DoInstall(): E:Couldn't configure pre-depend libplymouth2 for mountall, probably a dependency cycle.

Could not install the upgrades

The upgrade is now aborted. Your system could be in an unusable
state. A recovery will run now (dpkg --configure -a).

Please report this bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bug report.
installArchives() failed

Upgrade complete

The upgrade is completed but there were errors during the upgrade
process.

root@cardassian ~ # d update-manager
ii update-manager-core 1:0.126.9 manage release upgrades

Fionn (fbe) wrote :
tags: added: kernel-series-unknown
tags: removed: kernel-series-unknown
Changed in update-manager (Ubuntu):
status: New → Confirmed

Rerunning the command 'do-release-upgrade -d' a second time resolves this issue. It seems like one package is updated before it is suppose to be.

John Vivirito (gnomefreak) wrote :

Michael Vogt:
Im sure this is going to pass by your eyes. I was talking to mr. Lustfield in #ubuntu+1 and it seems that dpkg got ahead of itself by trying to configure plymouth before mountall but he states restarting the updates fixed it. This has happened to me in the past as well Jaunty cycle i think.

Simply redoing the upgrade didn't always fix it. Only part of the time.

do-release-upgrade -d
# breaks
aptitude install libplymouth2
# installs that and it's deps
do-release-upgrade -d

This is what made things work for me.

Is anyone still fighting this?

andy007 (andre-gritsan) wrote :

i have this problem
upgrade 10.04 to 10.10

'E:Couldn't configure pre-depend x11-common for x11-xkb-utils, probably a dependency cycle.'

Telefo (buonprezzo) wrote :

i have this problem too upgrading from 11.10 to 12.04
Exception during pm.DoInstall():
tha package involved is policykit-1-gnome

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers