Ubuntu

Restart is not supported if not using gnome session manager (affects XFCE & LXDE)

Reported by Kangarooo Jānis on 2010-03-01
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GKSu
Invalid
Undecided
Unassigned
Software Updater
New
Undecided
Unassigned
update-manager (Ubuntu)
Medium
TJ
Nominated for Lucid by Charlie Kravetz

Bug Description

Binary package hint: restartd

Installed xubuntu loged in made updates and restart required showed icon i clicked and error in picture shown

Kangarooo Jānis (kangarooo) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
4. The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
5. The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.
Thanks!

Changed in restartd (Ubuntu):
status: New → Incomplete
Kangarooo Jānis (kangarooo) wrote :

1. I installed xubuntu 2 days ago on 5 computers. After installing from live cd restarted and removed cd. Started pc. Autologin logs in. Made internet connection. Made updates. Grub-pc asked what version i want. I took take package maintainers version. When update finishes restart required button appears. I click it and Reboot Failed dialog appears. Failed to request reboot, please shutdown manually. I took screenshot and uploaded. now ill upload another one.
But when taking shutdown a dialog appears requesting password for shutdown. I couldnt take screenshot of that. Screenshot utility didnt work while that dialog was open. So thats another bug that shutdown after updates requires password.
2. I expect to restart happen after clicking that blue restart icon witch appears in taskbar after updates are made.
3. Look #1.
4. Xubuntu 9.10 on 4 pcs and 1laptop.
lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10
5. apt-cache policy restard
restartd:
  Installed: (none)
  Candidate: 0.2.2
  Version table:
     0.2.2 0
        500 http://lv.archive.ubuntu.com karmic/universe Packages
maybe i needed to take this info from that time when updates were made.

affects: restartd (Ubuntu) → update-manager (Ubuntu)
Kangarooo Jānis (kangarooo) wrote :

As i mentioned this affects 5 computers. I installed them using 2cds to make installing faster and cds were checked for errors and all is fine. So its big problem already in iso file.
Also as i mentioned clicking shutdown asked for password. So maybe becouse somehow on update system restarting was locked down thats why maybe restart couldnt work. So maybe a solutions could be
1. make restart have sudo access.
2. make nothing on update lock computers shuting down option.
is it correct that update-manager makes that restart blue icon?
and is it correct that gksu asks for password on shutdown? maybe that proses should be added as also affected?

Thank you for the better description of this bug. You are correct that this is a bug in Xubuntu 9.10.

Could you please add the log files from '/var/log/apt/term.log' to this bug report as a separate attachment? Thanks in advance.

Kangarooo Jānis (kangarooo) wrote :

Heres /var/log/apt/term.log
at first i got error from trying upload directly to LP. Cannot upload empty file.
then i sudo mousepad var/log/apt/term.log and its not empty. maybe couse its root it couldnt be uploaded but thats strange. its not like uploading is writing its only reading.
so i tryd copying to home Dir but got error Failed to copy "/var/log/apt/term.log" to "/home/kng/term.log".
Failed to open "/var/log/apt/term.log" for reading (Permission denied). Do you want to skip it?

Why to copy it needs to open it? Just copy..
Is there easyr way to upload files like this? Now i copyd all whats inside in new file and uploading it.

Thanks for your supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Kangarooo Jānis (kangarooo) wrote :

I just installed xubuntu 9.10 for another friend and made updates and heres another screenshot of restart not working.
Is this beeing now fixed?

This bug report is marked "confirmed" in the yellow status line at the top of the report. That means it can be looked at by a developer. Please look at https://wiki.ubuntu.com/Bugs/Status for more information about the status of bugs. Of course, with over 1000 bugs a day reported, it is difficult for the developers to get to every one of them within a few days.

Screenshots are great to show what the bug looks like. Unfortunately, most of the time they do not give any information about why the bug occurred. Normally, that requires the log files be attached, where the error occurs.

Changed in gksu:
status: New → Invalid
tags: added: karmic xubuntu
TJ (tj) wrote :

Confirming this affects Xubuntu but not Ubuntu. The cause appears to be a reliance on gnome session manager to trigger the restart:

UpdateManager/UpdateManager.py::592

  def show_reboot_required_dialog(self):
    self.dialog_reboot.set_transient_for(self.window_main)
    self.dialog_reboot.set_title("")
    res = self.dialog_reboot.run()
    self.dialog_reboot.hide()
    if res == gtk.RESPONSE_OK:
      try:
          bus = dbus.SessionBus()
          proxy_obj = bus.get_object("org.gnome.SessionManager",
         "/org/gnome/SessionManager")
          iface = dbus.Interface(proxy_obj, "org.gnome.SessionManager")
          iface.RequestReboot()
          # FIXME: try sesion restart with hal?
      except dbus.DBusException, e:
          pass

TJ (tj) wrote :

Attached is a patch that potentially fixes this issue. I cannot test it right now because I have yet to find a way to force update-manager to perform a restart action when the updated packages don't require one.

To apply it locally to the installed update-manager Python script:

cd $HOME
# download patch into user home directory
cd /usr/share/pyshared
sudo patch -p1 -i $HOME/01_update-manager_support_XFCE_shutdown.patch

Now, next time update-manager offers the restart now/later dialog, and the user chooses "Now", the script should try and fail to connect to the Gnome session manager over Dbus and then try to connect to the XFCE session manager instead.

Changed in update-manager (Ubuntu):
assignee: nobody → TJ (intuitivenipple)
status: Confirmed → In Progress
summary: - On Clean install after update restart didnt work.
+ Restart is not supported if not using gnome session manager (affects
+ XFCE & KDE?)
tags: added: patch
tags: added: xupatch
removed: xubuntu
tags: added: xubuntu
removed: xupatch

Unable to patch source

neil@desktop:~/Reviews/update-manager-0.142.1$ patch -p1 -i 01_update-manager_support_XFCE_shutdown.patch
patching file UpdateManager/UpdateManager.py
Hunk #1 FAILED at 597.
1 out of 1 hunk FAILED -- saving rejects to file UpdateManager/UpdateManager.py.rej

tags: added: patch-needswork
removed: patch
Julien Lavergne (gilir) wrote :

IMO, you should also add a fallback to ConsoleKit Restart method, so no XFCE and no GNOME session should work also.

Lionel Le Folgoc (mrpouit) wrote :

Here's a new proposed patch (unfortunately, I wasn't aware of this bug report so I redid it from scratch...), to use consolekit if gnome-session isn't available. I tested on xubuntu natty, and it worked fine here.
I'll push it to the bzr branch in a few hours, and probably upload it tomorrow.

tags: added: natty patch
removed: patch-needswork
summary: Restart is not supported if not using gnome session manager (affects
- XFCE & KDE?)
+ XFCE & LXDE)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.146.1

---------------
update-manager (1:0.146.1) natty; urgency=low

  [ Michael Vogt ]
  * merged lp:~evfool/update-manager/fix689034:
    - Some basic string fixes (lp:#689034), thanks to Robert Roth
  * UpdateManager/Core/roam.py:
    - add backend for roaming detection, thanks to Alex Chiang
    - display warning when on 3g and when roaming (fixes half of
      LP: 323108)
  * merged lp:~thibault-lemaitre/ubuntu/natty/update-manager/from_pkg.isInstalled_to_pkg.is_installed
    that fixes a bunch of deprecated python-apt issues (many thanks!)

  [ Lionel Le Folgoc ]
  * UpdateManager/UpdateManager.py: try to reboot using consolekit if
    gnome-session isn't present (fixes rebooting on Xfce and LXDE, lp: #530161).
 -- Michael Vogt <email address hidden> Tue, 01 Mar 2011 08:55:53 +0100

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers