Comment 5 for bug 47648

2006-05-31 12:59:13,682 DEBUG The package 'linux-image-2.6.10-6-amd64-generic' is marked for removal but it's in the removal blacklist
2006-05-31 12:59:20,253 ERROR Dist-upgrade failed: 'A essential package would have to be removed'

-> after removing this hoary kernel image it works.