[dist-upgrader] Dapper Update fails myteriously during installing the ugprade (nothing in the logs)

Bug #46784 reported by Nikolaus Rath on 2006-05-26
16
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

After trying to upgrade from Breezy to dapper using

# update-manager -d

and clicking some buttons, the updater tells me that it

"Couldn't install upgrades. System can be in an unusable state. A recovery was run (dpkg --configure -a). installArchives() failed".

I didn't see anything suspicious in the terminal frame.

Needless to say that this message makes me kind of nervous.

-

-

-

Odd enough, those logfiles don't indicate any errors. Could you post the
output of:

apt-cache policy
apt-cache policy ubuntu-desktop

[0] nokile:~$ apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://security.ubuntu.com dapper-security/multiverse Packages
     release v=6.06,o=Ubuntu,a=dapper-security,l=Ubuntu,c=multiverse
     origin security.ubuntu.com
 500 http://security.ubuntu.com dapper-security/universe Packages
     release v=6.06,o=Ubuntu,a=dapper-security,l=Ubuntu,c=universe
     origin security.ubuntu.com
 500 http://security.ubuntu.com dapper-security/restricted Packages
     release v=6.06,o=Ubuntu,a=dapper-security,l=Ubuntu,c=restricted
     origin security.ubuntu.com
 500 http://security.ubuntu.com dapper-security/main Packages
     release v=6.06,o=Ubuntu,a=dapper-security,l=Ubuntu,c=main
     origin security.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-backports/multiverse Packages
     release v=6.06,o=Ubuntu,a=dapper-backports,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-backports/universe Packages
     release v=6.06,o=Ubuntu,a=dapper-backports,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-backports/restricted Packages
     release v=6.06,o=Ubuntu,a=dapper-backports,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-backports/main Packages
     release v=6.06,o=Ubuntu,a=dapper-backports,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-updates/multiverse Packages
     release v=6.06,o=Ubuntu,a=dapper-updates,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-updates/universe Packages
     release v=6.06,o=Ubuntu,a=dapper-updates,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-updates/restricted Packages
     release v=6.06,o=Ubuntu,a=dapper-updates,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper-updates/main Packages
     release v=6.06,o=Ubuntu,a=dapper-updates,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper/multiverse Packages
     release v=6.06,o=Ubuntu,a=dapper,l=Ubuntu,c=multiverse
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper/universe Packages
     release v=6.06,o=Ubuntu,a=dapper,l=Ubuntu,c=universe
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper/restricted Packages
     release v=6.06,o=Ubuntu,a=dapper,l=Ubuntu,c=restricted
     origin de.archive.ubuntu.com
 500 http://de.archive.ubuntu.com dapper/main Packages
     release v=6.06,o=Ubuntu,a=dapper,l=Ubuntu,c=main
     origin de.archive.ubuntu.com
Pinned packages:
[0] nokile:~$ apt-cache policy ubuntu-desktop
ubuntu-desktop:
  Installed: 0.80
  Candidate: 0.116
  Version table:
     0.116 0
        500 http://de.archive.ubuntu.com dapper/main Packages
 *** 0.80 0
        100 /var/lib/dpkg/status
[0] nokile:~$

Nikolaus Rath (nikratio) wrote :

Semms that the update also messed up the package DB.. I just tried:

[0] nokile:~$ sudo aptitude install gnus
Password:
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
The following packages are unused and will be REMOVED:
  dash libdb1-compat libdb3 libgcj6-common libglide2 libreiserfs0.3-0 libsigc++-1.2-5c2
  xserver-xorg-driver-glide
The following packages have been kept back:
  acpi-support appres aptitude-doc-en aspell aspell-de at auctex bbdb bc beforelight bicyclerepair
[....]
The following packages will be upgraded:
  gnus
1 packages upgraded, 0 newly installed, 8 to remove and 744 not upgraded.
Need to get 0B of archives. After unpacking 11.6MB will be freed.
Do you want to continue? [Y/n/?]
Writing extended state information... Error!
E: I wasn't able to locate file for the acpi-support package. This might mean you need to manually fix this package.
E: Couldn't lock list directory..are you root?

Please wait for comments from Michael Vogt (apt guru), who may know why
and how it failed.

Thanks for your bugreport.

The logs look indeed fine. Could you please check if:
$ sudo apt-get install -f
prints anything? And the commands that Dennis asked for as well please.

Thanks,
 Michael

Changed in update-manager:
assignee: nobody → mvo
status: Unconfirmed → Needs Info
Michael Vogt (mvo) wrote :

I wonder if the problem has something to do with the conffile prompts. Maybe there is a bug in the handling of those. I'll try to reproduce.

Please run:
# apt-get install -f
and
# apt-get dist-upgrade
to fix your system (sorry for this).

Cheers,
 Michael

Michael Vogt (mvo) wrote :

Could you alsp attach your sources.list please?

-

Ok, I got my system working again, but this update was really badly screwed.

While running apt-get dist-upgrade, the system (I suppose it was the panel, but that wasn't clear from the dialog) started to complain about missing icons, giving me a new error dialog every 2 seconds. Then the panel and the applets started crashing.

When the update was over, I wasn't able to log into X11 again, after the GDM login I only got a blank screen. After changing the session type back and forth from failsafe to gnome, it worked again.

Furthermore, /etc/init.d/ifrename complained about a missing /sbin/ifrename. Apparently the package was removed and the init script didn't check for the existance of the binary.

pcmcia-cs now complains on startup, that the kernel actually needs pcmcia-utils, but I cannot uninstall pcmcia because ubuntu-dekstop depends on bluez which depends on pcmcia-cs.

My xscreensaver settings (especially that it should ask for a password) were lost and I wasn't informed about that.

The panel settings were also completely gone.

Nikolaus Rath (nikratio) wrote :

And I just realised that printing didn't work any longer. Any printing attempts lead to no result at all. Opening the printer status window causes the application to freeze. Removing the printer and adding it again worked around the problem.

bigg (bachmeil) wrote :

I got the same error. In my case I can't even open my terminal or any other programs, so I can't post the log files or run any other commands. I had a different error related to mozilla-firefox-locale-ko earlier, so that may have something to do with it.

Michael Vogt (mvo) wrote :

@bigg: if you boot with a live-cd, can you access the logs then? I would really like to see them to check if they give me a clue what went wrong.

Thanks,
 Michael

Sorry, guess I didn't think of that. The system was
all messed up when I rebooted, so I installed from
scratch.

--- Michael Vogt <email address hidden> wrote:

> @bigg: if you boot with a live-cd, can you access
> the logs then? I would
> really like to see them to check if they give me a
> clue what went wrong.
>
> Thanks,
> Michael
>
> --
> Dapper Update fails
> https://launchpad.net/bugs/46784
>

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

@Nikolaus Rath: do you have anything interessting in /var/log/syslog? How much RAM do you have? I suspect a memory leak for this problem and was wondering if the OOM-killer may have kicked in.

Sorry, nothing suspicious in the syslog. I've 512 MB RAM + 1 GB swap.

JW (jw-00000) wrote :

I just had that same error while upgrading to Dapper with the Update Manager. When I restarted the Update Manager it requested me to run "sudo apt-get install -f". I ran it, but an error occurred while configuring debconf. The following was printed on my screen:

Instellen van debconf (1.4.72ubuntu9) ...
Compiling /usr/lib/python2.4/site-packages/kuartetlib/ScrollPane.py ...
  File "/usr/lib/python2.4/site-packages/kuartetlib/ScrollPane.py", line 11
    Pane.__init__(self, parent, x, y, size=[0,0], name='', border=0):
                                                                    ^
SyntaxError: invalid syntax

dpkg: fout bij afhandelen van debconf (--configure):
 subproces post-installation script gaf een foutwaarde 1 terug
dpkg: vereistenproblemen verhinderen de configuratie van x11-common:
 x11-common is afhankelijk van debconf (>= 0.5) | debconf-2.0; maar:
  Pakket debconf is nog niet geconfigureerd.
  Pakket debconf-2.0 is niet geïnstalleerd.
  Pakket debconf die voorziet in debconf-2.0 is nog niet geconfigureerd.
dpkg: fout bij afhandelen van x11-common (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Fouten gevonden tijdens behandelen van:
 debconf
 x11-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

JW (jw-00000) wrote :

After what happened yesterday I backed everything up on CD while my computer was still running. Luckily, because when I today tried to start the system, it wouldn't. An error is displayed saying the X server couldn't be loaded. The error message asks me if I want to see the log, and if I select Yes the error log says GDM couldn't start Xserver because it was not installed or GDM wasn't properly configured.

What do I do? Should I try to start from a Live CD, and are there any actions I can take to restore my system? Or is the only way out a clean install? And what about my data? My personal files (my whole home directory + hidden files in it) is backed up, but I would be happy if all configuration, settings, installed programs etc. would be restored too. Any ideas?

Michael Vogt (mvo) wrote :

@JW: can you please attach the files in /var/log/dist-upgrade*.log to this bugreport?

To recover you will probably have to get rid of the stuff from /usr/lib/python2.4/site-packages/kuartetlib

I was not able to find what package this is stuff is part of.

My dist-upgrade.log
(It's in Dutch, I can translate some parts if you'd like)

My dist-upgrade-apt.log

My dist-upgrade-term.log

Thanks for this update.

The error is caused by the kuratet dir in /usr/lib/python2.4/site-packages/kuartetlib

I noticed that http://www.kde-look.org/content/show.php?content=32541 seems to provide it. Please remove the directory from your system and run:
$ sudo dpkg --configure -a
$ sudo apt-get install -f
$ sudo apt-get dist-upgrade
$ sudo apt-get install kubuntu-desktop

to recover fully.

I'm afraid I will have to close this bug because there is little we can do about the kuartlib failure.

Cheers,
 Michael

Nikolaus Rath (nikratio) wrote :

Aeh, I (as initial reporter) don't use kubuntu and have no file named kuartlib on my system. So how can this bug be related to kuartlib at all?

Nikolaus Rath (nikratio) on 2006-08-21
Changed in update-manager:
status: Needs Info → Unconfirmed
flyapen (kkeppens) wrote :

The python problem with debconf is not only with python2.4 but also with python2.5 .
I was able to solve it with Michael's solution, thanks for that.

@Nikolaus Rath, You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in update-manager:
status: New → Incomplete

We are closing this report because you reported this bug a while ago and there is no recent duplicate nor user mentioning having the issue on Intrepid. If this is still an issue, don't hesitate to reopen the report. Thanks again!

Changed in update-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers