[dist-upgrader] Could not calculate breezy->dapper upgrade

Bug #46250 reported by adrian on 2006-05-24
20
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Hi, I made sure everything was up to date and I ran

gksudo "update-manager -d"

I clicked on upgrade and everything went with out problems untill it reached: "Downloading and Installing Upgrades"

dist-upgrade-apt.log:

/tmp/tmpGWgUUU/DistUpgradeViewGtk.py:76: GtkWarning: gtk_style_finalize: assertion `style->attach_count == 0' failed
  gtk.main_iteration()
Starting
Starting 2
Investigating x11-common
Package x11-common has broken dep on xfree86-common
  Considering xorg-common 1 as a solution to x11-common 2262
  Added xorg-common to the remove list
Package x11-common has broken dep on xorg-common
  Considering xorg-common 1 as a solution to x11-common 2262
  Added xorg-common to the remove list
Package x11-common has broken dep on xserver-common
  Considering xserver-common 0 as a solution to x11-common 2262
  Added xserver-common to the remove list
Package x11-common has broken dep on x-common
  Considering x-common 0 as a solution to x11-common 2262
  Added x-common to the remove list
  Fixing x11-common via remove of xorg-common
  Fixing x11-common via remove of xorg-common
  Fixing x11-common via remove of xserver-common
  Fixing x11-common via remove of x-common
Investigating locales
Package locales has broken dep on base-config
  Considering base-config -1 as a solution to locales 1135
  Added base-config to the remove list
  Considering base-config -1 as a solution to locales 1135
  Fixing locales via remove of base-config
Investigating openoffice.org-l10n-en-us
Package openoffice.org-l10n-en-us has broken dep on myspell-dictionary-en-us
Investigating openoffice.org-core
Package openoffice.org-core has broken dep on openoffice.org2-l10n-1.9.129
  Considering openoffice.org2-l10n-en-us 6 as a solution to openoffice.org-core 37
  Added openoffice.org2-l10n-en-us to the remove list
Package openoffice.org-core has broken dep on openoffice.org-help-1.9.129
  Considering openoffice.org2-help-en-us 0 as a solution to openoffice.org-core 37
  Added openoffice.org2-help-en-us to the remove list
Package openoffice.org-core has broken dep on openoffice.org2-core
  Considering openoffice.org2-core 8 as a solution to openoffice.org-core 37
  Added openoffice.org2-core to the remove list
  Fixing openoffice.org-core via remove of openoffice.org2-l10n-en-us
  Fixing openoffice.org-core via remove of openoffice.org2-help-en-us
  Fixing openoffice.org-core via remove of openoffice.org2-core
Investigating imake
Package imake has broken dep on xmkmf
  Considering xmkmf 14 as a solution to imake 29
  Added xmkmf to the remove list
  Fixing imake via remove of xmkmf
Investigating openoffice.org-common
Package openoffice.org-common has broken dep on openoffice.org-l10n-en-us
  Considering openoffice.org-l10n-en-us 38 as a solution to openoffice.org-common 28
  Holding Back openoffice.org-common rather than change openoffice.org-l10n-en-us
Investigating udev
Package udev has broken dep on hotplug
  Considering hotplug 2 as a solution to udev 25
  Added hotplug to the remove list
Package udev has broken dep on ifrename
  Considering ifrename 0 as a solution to udev 25
  Added ifrename to the remove list
  Considering ifrename 0 as a solution to udev 25
  Fixing udev via remove of hotplug
  Fixing udev via remove of ifrename
Investigating libcamel1.2-8
Package libcamel1.2-8 has broken dep on libcamel1.2-6
  Considering libcamel1.2-6 0 as a solution to libcamel1.2-8 24
  Added libcamel1.2-6 to the remove list
  Fixing libcamel1.2-8 via remove of libcamel1.2-6
Investigating language-support-en
Package language-support-en has broken dep on openoffice.org-l10n-en-us
  Considering openoffice.org-l10n-en-us 38 as a solution to language-support-en 21
  Removing language-support-en rather than change openoffice.org-l10n-en-us
Investigating libsigc++-2.0-0c2a
Package libsigc++-2.0-0c2a has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 21 as a solution to libsigc++-2.0-0c2a 19
  Holding Back libsigc++-2.0-0c2a rather than change libsigc++-2.0-0c2
Investigating libnotify1
Package libnotify1 has broken dep on libnotify0
  Considering libnotify0 0 as a solution to libnotify1 16
  Added libnotify0 to the remove list
  Fixing libnotify1 via remove of libnotify0
Investigating busybox-initramfs
Package busybox-initramfs has broken dep on busybox-cvs-initramfs
  Considering busybox-cvs-initramfs 0 as a solution to busybox-initramfs 14
  Added busybox-cvs-initramfs to the remove list
  Fixing busybox-initramfs via remove of busybox-cvs-initramfs
Investigating thunderbird-locale-en-gb
Package thunderbird-locale-en-gb has broken dep on mozilla-thunderbird
  Considering mozilla-thunderbird 1 as a solution to thunderbird-locale-en-gb 12
  Holding Back thunderbird-locale-en-gb rather than change mozilla-thunderbird
Package thunderbird-locale-en-gb has broken dep on language-support-en
  Considering language-support-en 21 as a solution to thunderbird-locale-en-gb 12
  Holding Back thunderbird-locale-en-gb rather than change language-support-en
  Or group keep for thunderbird-locale-en-gb
Investigating dbus
Package dbus has broken dep on libdbus-1-1
  Considering libdbus-1-1 4 as a solution to dbus 12
  Added libdbus-1-1 to the remove list
  Fixing dbus via remove of libdbus-1-1
Investigating openoffice.org-thesaurus-en-us
Package openoffice.org-thesaurus-en-us has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-thesaurus-en-us 12
  Holding Back openoffice.org-thesaurus-en-us rather than change openoffice.org-common
Package openoffice.org-thesaurus-en-us has broken dep on language-support-en
  Considering language-support-en 21 as a solution to openoffice.org-thesaurus-en-us 12
  Holding Back openoffice.org-thesaurus-en-us rather than change language-support-en
  Or group keep for openoffice.org-thesaurus-en-us
Investigating openoffice.org-l10n-en-gb
Package openoffice.org-l10n-en-gb has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-l10n-en-gb 12
  Holding Back openoffice.org-l10n-en-gb rather than change openoffice.org-common
Package openoffice.org-l10n-en-gb has broken dep on language-support-en
  Considering language-support-en 21 as a solution to openoffice.org-l10n-en-gb 12
  Holding Back openoffice.org-l10n-en-gb rather than change language-support-en
  Or group keep for openoffice.org-l10n-en-gb
Package openoffice.org-l10n-en-gb has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-l10n-en-gb 12
  Holding Back openoffice.org-l10n-en-gb rather than change openoffice.org-common
Package openoffice.org-l10n-en-gb has broken dep on language-support-en
  Considering language-support-en 21 as a solution to openoffice.org-l10n-en-gb 12
  Holding Back openoffice.org-l10n-en-gb rather than change language-support-en
  Or group keep for openoffice.org-l10n-en-gb
Package openoffice.org-l10n-en-gb has broken dep on myspell-dictionary-en-gb
Investigating openoffice.org-l10n-en-za
Package openoffice.org-l10n-en-za has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-l10n-en-za 12
  Holding Back openoffice.org-l10n-en-za rather than change openoffice.org-common
Package openoffice.org-l10n-en-za has broken dep on language-support-en
  Considering language-support-en 21 as a solution to openoffice.org-l10n-en-za 12
  Holding Back openoffice.org-l10n-en-za rather than change language-support-en
  Or group keep for openoffice.org-l10n-en-za
Package openoffice.org-l10n-en-za has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-l10n-en-za 12
  Holding Back openoffice.org-l10n-en-za rather than change openoffice.org-common
Package openoffice.org-l10n-en-za has broken dep on language-support-en
  Considering language-support-en 21 as a solution to openoffice.org-l10n-en-za 12
  Holding Back openoffice.org-l10n-en-za rather than change language-support-en
  Or group keep for openoffice.org-l10n-en-za
Package openoffice.org-l10n-en-za has broken dep on myspell-dictionary-en-za
Investigating openoffice.org-help-en-us
Package openoffice.org-help-en-us has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-help-en-us 12
  Holding Back openoffice.org-help-en-us rather than change openoffice.org-common
Package openoffice.org-help-en-us has broken dep on language-support-en
  Considering language-support-en 21 as a solution to openoffice.org-help-en-us 12
  Holding Back openoffice.org-help-en-us rather than change language-support-en
  Or group keep for openoffice.org-help-en-us
Investigating libgksuui1.0-1
Package libgksuui1.0-1 has broken dep on libgksuui1.0-0
  Considering libgksuui1.0-0 0 as a solution to libgksuui1.0-1 11
  Added libgksuui1.0-0 to the remove list
  Fixing libgksuui1.0-1 via remove of libgksuui1.0-0
Investigating libpt-1.10.0
Package libpt-1.10.0 has broken dep on libpt-1.8.3c2
  Considering libpt-1.8.3c2 3 as a solution to libpt-1.10.0 11
  Added libpt-1.8.3c2 to the remove list
  Fixing libpt-1.10.0 via remove of libpt-1.8.3c2
Investigating libsmpeg0
Package libsmpeg0 has broken dep on libsmpeg0c2
  Considering libsmpeg0c2 7 as a solution to libsmpeg0 10
  Added libsmpeg0c2 to the remove list
  Fixing libsmpeg0 via remove of libsmpeg0c2
Investigating aptitude
Package aptitude has broken dep on libsigc++-2.0-0c2a
  Considering libsigc++-2.0-0c2a 19 as a solution to aptitude 9
  Removing aptitude rather than change libsigc++-2.0-0c2a
Investigating libgksu1.2-1
Package libgksu1.2-1 has broken dep on libgksu1.2-0
  Considering libgksu1.2-0 0 as a solution to libgksu1.2-1 7
  Added libgksu1.2-0 to the remove list
  Fixing libgksu1.2-1 via remove of libgksu1.2-0
Investigating openoffice.org-java-common
Package openoffice.org-java-common has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-java-common 7
  Holding Back openoffice.org-java-common rather than change openoffice.org-common
Investigating libtag1c2a
Package libtag1c2a has broken dep on libtag1c2
  Considering libtag1c2 0 as a solution to libtag1c2a 6
  Added libtag1c2 to the remove list
  Fixing libtag1c2a via remove of libtag1c2
Investigating libglibmm-2.4-1c2a
Package libglibmm-2.4-1c2a has broken dep on libsigc++-2.0-0c2a
  Considering libsigc++-2.0-0c2a 19 as a solution to libglibmm-2.4-1c2a 5
  Holding Back libglibmm-2.4-1c2a rather than change libsigc++-2.0-0c2a
Investigating openoffice.org-draw
Package openoffice.org-draw has broken dep on openoffice.org-debian-files
  Considering openoffice.org-debian-files 4 as a solution to openoffice.org-draw 4
  Holding Back openoffice.org-draw rather than change openoffice.org-debian-files
Investigating ubuntu-minimal
Package ubuntu-minimal has broken dep on aptitude
  Considering aptitude 9 as a solution to ubuntu-minimal 4
  Removing ubuntu-minimal rather than change aptitude
Investigating openoffice.org2-common
Package openoffice.org2-common has broken dep on openoffice.org2-core
  Considering openoffice.org2-core 8 as a solution to openoffice.org2-common 4
  Removing openoffice.org2-common rather than change openoffice.org2-core
Investigating openoffice.org-base
Package openoffice.org-base has broken dep on openoffice.org-java-common
  Considering openoffice.org-java-common 7 as a solution to openoffice.org-base 4
  Holding Back openoffice.org-base rather than change openoffice.org-java-common
Investigating libmusicbrainz4c2a
Package libmusicbrainz4c2a has broken dep on libmusicbrainz4c2
  Considering libmusicbrainz4c2 0 as a solution to libmusicbrainz4c2a 3
  Added libmusicbrainz4c2 to the remove list
  Fixing libmusicbrainz4c2a via remove of libmusicbrainz4c2
Investigating mozilla-browser
Package mozilla-browser has broken dep on libnspr4
  Considering libnspr4 69 as a solution to mozilla-browser 3
  Removing mozilla-browser rather than change libnspr4
Investigating openoffice.org-writer
Package openoffice.org-writer has broken dep on openoffice.org-debian-files
  Considering openoffice.org-debian-files 4 as a solution to openoffice.org-writer 2
  Holding Back openoffice.org-writer rather than change openoffice.org-debian-files
Investigating openoffice.org-impress
Package openoffice.org-impress has broken dep on openoffice.org-draw
  Considering openoffice.org-draw 4 as a solution to openoffice.org-impress 2
  Holding Back openoffice.org-impress rather than change openoffice.org-draw
Investigating openoffice.org-math
Package openoffice.org-math has broken dep on openoffice.org-debian-files
  Considering openoffice.org-debian-files 4 as a solution to openoffice.org-math 2
  Holding Back openoffice.org-math rather than change openoffice.org-debian-files
Investigating openoffice.org-calc
Package openoffice.org-calc has broken dep on openoffice.org-debian-files
  Considering openoffice.org-debian-files 4 as a solution to openoffice.org-calc 2
  Holding Back openoffice.org-calc rather than change openoffice.org-debian-files
Investigating libgnomecupsui1.0-1c2a
Package libgnomecupsui1.0-1c2a has broken dep on libgnomecupsui1.0-1
  Considering libgnomecupsui1.0-1 0 as a solution to libgnomecupsui1.0-1c2a 1
  Added libgnomecupsui1.0-1 to the remove list
  Fixing libgnomecupsui1.0-1c2a via remove of libgnomecupsui1.0-1
Investigating libwpd8c2a
Package libwpd8c2a has broken dep on libwpd8c2
  Considering libwpd8c2 0 as a solution to libwpd8c2a 1
  Added libwpd8c2 to the remove list
  Fixing libwpd8c2a via remove of libwpd8c2
Investigating openoffice.org-gnome
Package openoffice.org-gnome has broken dep on openoffice.org2-gnome
  Considering openoffice.org2-gnome 0 as a solution to openoffice.org-gnome 1
  Added openoffice.org2-gnome to the remove list
  Considering openoffice.org2-gnome 0 as a solution to openoffice.org-gnome 1
  Fixing openoffice.org-gnome via remove of openoffice.org2-gnome
Investigating libdbus-glib-1-1
Package libdbus-glib-1-1 has broken dep on libdbus-1-1
  Considering libdbus-1-1 4 as a solution to libdbus-glib-1-1 1
  Removing libdbus-glib-1-1 rather than change libdbus-1-1
Investigating libopenh323-1.15.3c2
Package libopenh323-1.15.3c2 has broken dep on libpt-1.8.3c2
  Considering libpt-1.8.3c2 3 as a solution to libopenh323-1.15.3c2 1
  Removing libopenh323-1.15.3c2 rather than change libpt-1.8.3c2
Investigating openoffice.org-evolution
Package openoffice.org-evolution has broken dep on openoffice.org-base
  Considering openoffice.org-base 4 as a solution to openoffice.org-evolution 1
  Holding Back openoffice.org-evolution rather than change openoffice.org-base
Investigating openoffice.org
Package openoffice.org has broken dep on openoffice.org-writer
  Considering openoffice.org-writer 2 as a solution to openoffice.org 1
  Holding Back openoffice.org rather than change openoffice.org-writer
Investigating libgtkmm-2.4-1c2a
Package libgtkmm-2.4-1c2a has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 5 as a solution to libgtkmm-2.4-1c2a 1
  Holding Back libgtkmm-2.4-1c2a rather than change libglibmm-2.4-1c2a
Investigating libgconfmm-2.6-1c2
Package libgconfmm-2.6-1c2 has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 5 as a solution to libgconfmm-2.6-1c2 1
  Holding Back libgconfmm-2.6-1c2 rather than change libglibmm-2.4-1c2a
Investigating libjack0.80.0-0
Package libjack0.80.0-0 has broken dep on jackd
  Considering jackd 2 as a solution to libjack0.80.0-0 1
  Removing libjack0.80.0-0 rather than change jackd
Investigating libid3-3.8.3c2a
Package libid3-3.8.3c2a has broken dep on libid3-3.8.3c2
  Considering libid3-3.8.3c2 0 as a solution to libid3-3.8.3c2a 1
  Added libid3-3.8.3c2 to the remove list
  Fixing libid3-3.8.3c2a via remove of libid3-3.8.3c2
Investigating libnetcdf3
Package libnetcdf3 has broken dep on netcdfg3
  Considering netcdfg3 0 as a solution to libnetcdf3 1
  Added netcdfg3 to the remove list
  Fixing libnetcdf3 via remove of netcdfg3
Investigating openoffice.org2-math
Package openoffice.org2-math has broken dep on openoffice.org-math
  Considering openoffice.org-math 2 as a solution to openoffice.org2-math 0
  Removing openoffice.org2-math rather than change openoffice.org-math
Investigating xorg-driver-synaptics
Package xorg-driver-synaptics has broken dep on xfree86-driver-synaptics
  Considering xfree86-driver-synaptics 0 as a solution to xorg-driver-synaptics 0
  Removing xorg-driver-synaptics rather than change xfree86-driver-synaptics
Investigating gparted
Package gparted has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 5 as a solution to gparted 0
  Holding Back gparted rather than change libglibmm-2.4-1c2a
Investigating openoffice.org2-impress
Package openoffice.org2-impress has broken dep on openoffice.org-impress
  Considering openoffice.org-impress 2 as a solution to openoffice.org2-impress 0
  Removing openoffice.org2-impress rather than change openoffice.org-impress
Investigating alacarte
Package alacarte has broken dep on smeg
  Considering smeg 0 as a solution to alacarte 0
  Holding Back alacarte rather than change smeg
Investigating openoffice.org2
Package openoffice.org2 has broken dep on openoffice.org
  Considering openoffice.org 1 as a solution to openoffice.org2 0
  Removing openoffice.org2 rather than change openoffice.org
Investigating cupsys-driver-gimpprint-data
Package cupsys-driver-gimpprint-data has broken dep on cupsys-driver-gimpprint
  Considering cupsys-driver-gimpprint 1 as a solution to cupsys-driver-gimpprint-data 0
  Removing cupsys-driver-gimpprint-data rather than change cupsys-driver-gimpprint
Investigating hplip
Package hplip has broken dep on gtklp
  Considering gtklp 0 as a solution to hplip 0
  Holding Back hplip rather than change gtklp
Investigating ubuntu-desktop
Package ubuntu-desktop has broken dep on alacarte
  Considering alacarte 0 as a solution to ubuntu-desktop 0
  Removing ubuntu-desktop rather than change alacarte
Investigating openoffice.org2-writer
Package openoffice.org2-writer has broken dep on openoffice.org-writer
  Considering openoffice.org-writer 2 as a solution to openoffice.org2-writer 0
  Removing openoffice.org2-writer rather than change openoffice.org-writer
Investigating openoffice.org2-base
Package openoffice.org2-base has broken dep on openoffice.org-base
  Considering openoffice.org-base 4 as a solution to openoffice.org2-base 0
  Removing openoffice.org2-base rather than change openoffice.org-base
Investigating openoffice.org2-calc
Package openoffice.org2-calc has broken dep on openoffice.org-calc
  Considering openoffice.org-calc 2 as a solution to openoffice.org2-calc 0
  Removing openoffice.org2-calc rather than change openoffice.org-calc
Investigating openoffice.org2-evolution
Package openoffice.org2-evolution has broken dep on openoffice.org-evolution
  Considering openoffice.org-evolution 1 as a solution to openoffice.org2-evolution 0
  Removing openoffice.org2-evolution rather than change openoffice.org-evolution
Investigating openoffice.org2-draw
Package openoffice.org2-draw has broken dep on openoffice.org-draw
  Considering openoffice.org-draw 4 as a solution to openoffice.org2-draw 0
  Removing openoffice.org2-draw rather than change openoffice.org-draw
Investigating libsword5c2a
Package libsword5c2a has broken dep on libsword5
  Considering libsword5 0 as a solution to libsword5c2a 0
  Holding Back libsword5c2a rather than change libsword5
Investigating gnomesword
Package gnomesword has broken dep on libsword5c2a
  Considering libsword5c2a 0 as a solution to gnomesword 0
  Holding Back gnomesword rather than change libsword5c2a
Investigating gstreamer0.8-jack
Package gstreamer0.8-jack has broken dep on libjack0.80.0-0
  Considering libjack0.80.0-0 1 as a solution to gstreamer0.8-jack 0
  Removing gstreamer0.8-jack rather than change libjack0.80.0-0
Investigating hplip-base
Package hplip-base has broken dep on hplip-data
  Considering hplip-data 3 as a solution to hplip-base 0
  Removing hplip-base rather than change hplip-data
Investigating libcal3d11c2a
Package libcal3d11c2a has broken dep on libcal3d10c2
  Considering libcal3d10c2 0 as a solution to libcal3d11c2a 0
  Holding Back libcal3d11c2a rather than change libcal3d10c2
Investigating libnautilus-burn2
Package libnautilus-burn2 has broken dep on libdbus-1-1
  Considering libdbus-1-1 4 as a solution to libnautilus-burn2 0
  Removing libnautilus-burn2 rather than change libdbus-1-1
Investigating inkscape
Package inkscape has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 5 as a solution to inkscape 0
  Holding Back inkscape rather than change libglibmm-2.4-1c2a
Investigating gnomemeeting
Package gnomemeeting has broken dep on libopenh323-1.15.3c2
  Considering libopenh323-1.15.3c2 1 as a solution to gnomemeeting 0
  Removing gnomemeeting rather than change libopenh323-1.15.3c2
Investigating openoffice.org-core
Package openoffice.org-core has broken dep on openoffice.org-common
  Considering openoffice.org-common 28 as a solution to openoffice.org-core 37
  Holding Back openoffice.org-core rather than change openoffice.org-common
Investigating python-uno
Package python-uno has broken dep on openoffice.org-core
  Considering openoffice.org-core 37 as a solution to python-uno 2
  Removing python-uno rather than change openoffice.org-core
Investigating openoffice.org-gnome
Package openoffice.org-gnome has broken dep on openoffice.org-core
  Considering openoffice.org-core 37 as a solution to openoffice.org-gnome 1
  Holding Back openoffice.org-gnome rather than change openoffice.org-core
Investigating openoffice.org-gtk
Package openoffice.org-gtk has broken dep on openoffice.org-core
  Considering openoffice.org-core 37 as a solution to openoffice.org-gtk 1
  Holding Back openoffice.org-gtk rather than change openoffice.org-core
 Try to Re-Instate libgconfmm-2.6-1c2
 Try to Re-Instate gparted
Investigating python-soya
Package python-soya has broken dep on libcal3d11c2a
  Considering libcal3d11c2a 0 as a solution to python-soya 0
  Holding Back python-soya rather than change libcal3d11c2a
 Try to Re-Instate gnomesword
 Try to Re-Instate inkscape
 Try to Re-Instate python-soya
Done
Starting
Starting 2
Investigating libglibmm-2.4-1c2
Package libglibmm-2.4-1c2 has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libglibmm-2.4-1c2 14
  Added libsigc++-2.0-0c2 to the remove list
  Fixing libglibmm-2.4-1c2 via keep of libsigc++-2.0-0c2
Investigating libsigc++-2.0-0c2a
Package libsigc++-2.0-0c2a has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libsigc++-2.0-0c2a 13
  Added libsigc++-2.0-0c2 to the remove list
  Fixing libsigc++-2.0-0c2a via remove of libsigc++-2.0-0c2
Investigating libgtkmm-2.4-1c2
Package libgtkmm-2.4-1c2 has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libgtkmm-2.4-1c2 7
  Removing libgtkmm-2.4-1c2 rather than change libsigc++-2.0-0c2
Investigating libglademm-2.4-1c2
Package libglademm-2.4-1c2 has broken dep on libgtkmm-2.4-1c2
  Considering libgtkmm-2.4-1c2 7 as a solution to libglademm-2.4-1c2 1
  Removing libglademm-2.4-1c2 rather than change libgtkmm-2.4-1c2
Investigating libgnomemm-2.6-1c2
Package libgnomemm-2.6-1c2 has broken dep on libgtkmm-2.4-1c2
  Considering libgtkmm-2.4-1c2 7 as a solution to libgnomemm-2.6-1c2 1
  Removing libgnomemm-2.6-1c2 rather than change libgtkmm-2.4-1c2
Investigating libgconfmm-2.6-1c2
Package libgconfmm-2.6-1c2 has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 3 as a solution to libgconfmm-2.6-1c2 1
  Re-Instated libglibmm-2.4-1c2a
  Re-Instated libgconfmm-2.6-1c2
Investigating libgnomecanvasmm-2.6-1c2
Package libgnomecanvasmm-2.6-1c2 has broken dep on libgtkmm-2.4-1c2
  Considering libgtkmm-2.4-1c2 7 as a solution to libgnomecanvasmm-2.6-1c2 1
  Removing libgnomecanvasmm-2.6-1c2 rather than change libgtkmm-2.4-1c2
Investigating libgnome-vfsmm-2.6-1c2
Package libgnome-vfsmm-2.6-1c2 has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libgnome-vfsmm-2.6-1c2 1
  Removing libgnome-vfsmm-2.6-1c2 rather than change libsigc++-2.0-0c2
Investigating libgnomeuimm-2.6-1c2
Package libgnomeuimm-2.6-1c2 has broken dep on libglademm-2.4-1c2
  Considering libglademm-2.4-1c2 1 as a solution to libgnomeuimm-2.6-1c2 0
  Removing libgnomeuimm-2.6-1c2 rather than change libglademm-2.4-1c2
Investigating gparted
Package gparted has broken dep on libgtkmm-2.4-1c2a
  Considering libgtkmm-2.4-1c2a 2 as a solution to gparted 0
  Re-Instated libgtkmm-2.4-1c2a
  Re-Instated gparted
Investigating libglibmm-2.4-1c2
Package libglibmm-2.4-1c2 has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libglibmm-2.4-1c2 14
  Added libsigc++-2.0-0c2 to the remove list
  Fixing libglibmm-2.4-1c2 via keep of libsigc++-2.0-0c2
Investigating libsigc++-2.0-0c2a
Package libsigc++-2.0-0c2a has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libsigc++-2.0-0c2a 13
  Added libsigc++-2.0-0c2 to the remove list
  Fixing libsigc++-2.0-0c2a via remove of libsigc++-2.0-0c2
Investigating libglibmm-2.4-1c2a
Package libglibmm-2.4-1c2a has broken dep on libglibmm-2.4-1c2
  Considering libglibmm-2.4-1c2 14 as a solution to libglibmm-2.4-1c2a 3
  Holding Back libglibmm-2.4-1c2a rather than change libglibmm-2.4-1c2
Investigating libgtkmm-2.4-1c2a
Package libgtkmm-2.4-1c2a has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 3 as a solution to libgtkmm-2.4-1c2a 2
  Holding Back libgtkmm-2.4-1c2a rather than change libglibmm-2.4-1c2a
Investigating libgconfmm-2.6-1c2
Package libgconfmm-2.6-1c2 has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 3 as a solution to libgconfmm-2.6-1c2 1
  Removing libgconfmm-2.6-1c2 rather than change libglibmm-2.4-1c2a
Investigating gparted
Package gparted has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 3 as a solution to gparted 0
  Removing gparted rather than change libglibmm-2.4-1c2a
Investigating inkscape
Package inkscape has broken dep on libglibmm-2.4-1c2a
  Considering libglibmm-2.4-1c2a 3 as a solution to inkscape 0
    Reinst Failed because of libglibmm-2.4-1c2a
  Removing inkscape rather than change libglibmm-2.4-1c2a
Investigating libglibmm-2.4-1c2
Package libglibmm-2.4-1c2 has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 7 as a solution to libglibmm-2.4-1c2 14
  Added libsigc++-2.0-0c2 to the remove list
  Fixing libglibmm-2.4-1c2 via keep of libsigc++-2.0-0c2
Investigating libsigc++-2.0-0c2a
Package libsigc++-2.0-0c2a has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 14 as a solution to libsigc++-2.0-0c2a 13
  Holding Back libsigc++-2.0-0c2a rather than change libsigc++-2.0-0c2
Investigating aptitude
Package aptitude has broken dep on libsigc++-2.0-0c2a
  Considering libsigc++-2.0-0c2a 13 as a solution to aptitude 10
  Re-Instated libsigc++-2.0-0c2a
  Re-Instated aptitude
Investigating libsigc++-2.0-0c2a
Package libsigc++-2.0-0c2a has broken dep on libsigc++-2.0-0c2
  Considering libsigc++-2.0-0c2 14 as a solution to libsigc++-2.0-0c2a 13
  Holding Back libsigc++-2.0-0c2a rather than change libsigc++-2.0-0c2
Investigating aptitude
Package aptitude has broken dep on libsigc++-2.0-0c2a
  Considering libsigc++-2.0-0c2a 13 as a solution to aptitude 10
  Removing aptitude rather than change libsigc++-2.0-0c2a
Investigating ubuntu-minimal
Package ubuntu-minimal has broken dep on aptitude
  Considering aptitude 13 as a solution to ubuntu-minimal 6
    Reinst Failed because of aptitude
  Removing ubuntu-minimal rather than change aptitude
Investigating ubuntu-base
Package ubuntu-base has broken dep on ubuntu-minimal
  Considering ubuntu-minimal 13 as a solution to ubuntu-base 9999
  Added ubuntu-minimal to the remove list
  Fixing ubuntu-base via keep of ubuntu-minimal
 Try to Re-Instate ubuntu-minimal
Investigating ubuntu-minimal
Package ubuntu-minimal has broken dep on aptitude
  Considering aptitude 13 as a solution to ubuntu-minimal 9999
  Added aptitude to the remove list
Package ubuntu-minimal has broken dep on base-config
  Considering base-config 0 as a solution to ubuntu-minimal 9999
  Added base-config to the remove list
Package ubuntu-minimal has broken dep on hotplug
  Considering hotplug 0 as a solution to ubuntu-minimal 9999
  Added hotplug to the remove list
Package ubuntu-minimal has broken dep on ifrename
  Considering ifrename 0 as a solution to ubuntu-minimal 9999
  Added ifrename to the remove list
  Fixing ubuntu-minimal via keep of aptitude
  Fixing ubuntu-minimal via keep of base-config
  Fixing ubuntu-minimal via keep of hotplug
  Fixing ubuntu-minimal via keep of ifrename
Investigating locales
Package locales has broken dep on base-config
  Considering base-config 9999 as a solution to locales 1093
  Holding Back locales rather than change base-config
Investigating udev
Package udev has broken dep on hotplug
  Considering hotplug 9999 as a solution to udev 25
  Holding Back udev rather than change hotplug
Investigating belocs-locales-bin
Package belocs-locales-bin has broken dep on base-config
  Considering base-config 9999 as a solution to belocs-locales-bin 13
  Holding Back belocs-locales-bin rather than change base-config
 Try to Re-Instate aptitude
Investigating aptitude
Package aptitude has broken dep on libapt-pkg-libc6.3-6-3.10
  Considering apt 10 as a solution to aptitude 9999
  Added apt to the remove list
  Fixing aptitude via keep of apt
Investigating apt-utils
Package apt-utils has broken dep on libapt-pkg-libc6.3-6-3.11
  Considering apt 9999 as a solution to apt-utils 10
  Holding Back apt-utils rather than change libapt-pkg-libc6.3-6-3.11
 Try to Re-Instate apt
Re-Instated apt (9 vs 9)
Investigating mdadm
Package mdadm has broken dep on udev
  Considering udev 25 as a solution to mdadm 10
  Holding Back mdadm rather than change udev
Investigating hal
Package hal has broken dep on udev
  Considering udev 25 as a solution to hal 5
  Re-Instated udev
  Re-Instated hal
Investigating language-pack-en-base
Package language-pack-en-base has broken dep on locales
  Considering locales 1093 as a solution to language-pack-en-base 2
  Holding Back language-pack-en-base rather than change locales
Investigating language-pack-gnome-en-base
Package language-pack-gnome-en-base has broken dep on locales
  Considering locales 1093 as a solution to language-pack-gnome-en-base 2
  Holding Back language-pack-gnome-en-base rather than change locales
Investigating language-pack-eo-base
Package language-pack-eo-base has broken dep on locales
  Considering locales 1093 as a solution to language-pack-eo-base 2
  Holding Back language-pack-eo-base rather than change locales
Investigating language-pack-gnome-eo-base
Package language-pack-gnome-eo-base has broken dep on locales
  Considering locales 1093 as a solution to language-pack-gnome-eo-base 2
  Holding Back language-pack-gnome-eo-base rather than change locales
Investigating libc6
Package libc6 has broken dep on locales
  Considering locales 1093 as a solution to libc6 11460
  Holding Back libc6 rather than change locales
 Try to Re-Instate locales
Investigating udev
Package udev has broken dep on hotplug
  Considering hotplug 9999 as a solution to udev 25
  Holding Back udev rather than change hotplug
Investigating libc6-dev
Package libc6-dev has broken dep on libc6
  Considering libc6 11460 as a solution to libc6-dev 24
  Holding Back libc6-dev rather than change libc6
Investigating aptitude
Package aptitude has broken dep on libapt-pkg-libc6.3-6-3.10
  Considering apt 9999 as a solution to aptitude 9999
  Removing aptitude rather than change libapt-pkg-libc6.3-6-3.10
 Try to Re-Instate apt-utils
Re-Instated apt-utils (4 vs 3)
Investigating libc6-i686
Package libc6-i686 has broken dep on libc6
  Considering libc6 11460 as a solution to libc6-i686 10
  Holding Back libc6-i686 rather than change libc6
 Try to Re-Instate mdadm
Investigating ubuntu-minimal
Package ubuntu-minimal has broken dep on aptitude
  Considering aptitude 9999 as a solution to ubuntu-minimal 9999
  Removing ubuntu-minimal rather than change aptitude
Investigating hal
Package hal has broken dep on udev
  Considering udev 25 as a solution to hal 5
  Removing hal rather than change udev
 Try to Re-Instate language-pack-en-base
 Try to Re-Instate language-pack-gnome-en-base
 Try to Re-Instate language-pack-eo-base
 Try to Re-Instate language-pack-gnome-eo-base
Investigating hwdb-client
Package hwdb-client has broken dep on hal
  Considering hal 25 as a solution to hwdb-client 1
    Reinst Failed because of hal
  Removing hwdb-client rather than change hal
Investigating update-notifier
Package update-notifier has broken dep on hal
  Considering hal 25 as a solution to update-notifier 0
    Reinst Failed because of hal
  Removing update-notifier rather than change hal
Investigating gnome-volume-manager
Package gnome-volume-manager has broken dep on hal
  Considering hal 25 as a solution to gnome-volume-manager 0
    Reinst Failed because of hal
  Removing gnome-volume-manager rather than change hal
Investigating hal-device-manager
Package hal-device-manager has broken dep on hal
  Considering hal 25 as a solution to hal-device-manager 0
    Reinst Failed because of hal
  Removing hal-device-manager rather than change hal
 Try to Re-Instate libc6
Investigating ubuntu-base
Package ubuntu-base has broken dep on ubuntu-minimal
  Considering ubuntu-minimal 9999 as a solution to ubuntu-base 9999
  Considering ubuntu-minimal 9999 as a solution to ubuntu-base 9999
 Try to Re-Instate udev
 Try to Re-Instate libc6-dev
 Try to Re-Instate libc6-i686
Done

dist-upgrade.log

2006-05-23 17:53:56,048 DEBUG Foreign:
2006-05-23 17:53:56,048 DEBUG Obsolete:
2006-05-23 17:53:56,050 DEBUG updateSourcesList()
2006-05-23 17:53:56,056 DEBUG rewriteSourcesList()
2006-05-23 17:53:56,058 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu breezy main restricted'
2006-05-23 17:53:56,058 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu dapper main restricted' updated to new dist
2006-05-23 17:53:56,059 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu breezy-updates main restricted'
2006-05-23 17:53:56,059 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu dapper-updates main restricted' updated to new dist
2006-05-23 17:53:56,060 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu breezy-updates main restricted'
2006-05-23 17:53:56,060 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu dapper-updates main restricted' updated to new dist
2006-05-23 17:53:56,060 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu breezy universe'
2006-05-23 17:53:56,060 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu dapper universe' updated to new dist
2006-05-23 17:53:56,061 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu breezy-security main restricted'
2006-05-23 17:53:56,061 DEBUG entry 'deb http://security.ubuntu.com/ubuntu dapper-security main restricted' updated to new dist
2006-05-23 17:53:56,061 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted'
2006-05-23 17:53:56,062 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted' updated to new dist
2006-05-23 17:53:56,062 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu breezy-security universe'
2006-05-23 17:53:56,062 DEBUG entry 'deb http://security.ubuntu.com/ubuntu dapper-security universe' updated to new dist
2006-05-23 17:53:56,063 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu breezy-security universe'
2006-05-23 17:53:56,063 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu dapper-security universe' updated to new dist
2006-05-23 17:53:56,063 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu/ breezy universe main restricted multiverse'
2006-05-23 17:53:56,063 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu/ dapper universe main restricted multiverse' updated to new dist
2006-05-23 17:53:56,064 DEBUG examining: 'deb http://kubuntu.org/packages/kde351 breezy main'
2006-05-23 17:53:56,067 DEBUG entry '# deb http://kubuntu.org/packages/kde351 breezy main' was disabled (unknown mirror)
2006-05-23 17:53:56,067 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse'
2006-05-23 17:53:56,067 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse' updated to new dist
2006-05-23 17:53:56,068 DEBUG examining: 'deb http://people.ubuntu.com/~mvo/backports/update-manager /'
2006-05-23 17:53:56,071 DEBUG entry '# deb http://people.ubuntu.com/~mvo/backports/update-manager /' was disabled (unknown mirror)
2006-05-23 17:59:45,324 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'

Thanks for your bugreport.

Could you please attach the list of instlaled packages to this bugrpeort and your /etc/apt/sources.list? Get it via:
$ dpkg --get-selections | grep -v "deinstall" > installed.txt

I'll try to reproduce the problem then.

Thanks,
 Michael

Changed in update-manager:
assignee: nobody → mvo
status: Unconfirmed → Needs Info
Tim (tlrowe) wrote :

I also have this problem.

Rafał Próchniak (burlap) wrote :

Before using update-manager I tried "manually" prepare upgrade in synaptic. My results after using smart upgrade:

1. ubuntu-desktop is selected for removal due to problems with alacarte/smeg dependencies.

2. selecting ubuntu-desktop manually selects alacarte (and hplip) and marks smeg to be removed.

I haven't tried actual upgrade (yet).

Jerome S. Gotangco (jsgotangco) wrote :

Sorry for the delay, just got a bug report on this as well (marked it as dupe), will check this issue now.

Changed in update-manager:
status: Needs Info → Unconfirmed
Michael Vogt (mvo) on 2006-09-25
Changed in update-manager:
assignee: mvo → nobody
Paul Dufresne (paulduf) on 2007-11-16
Changed in update-manager:
status: New → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Thanks for reporting and providing logs. I'm sorry that we haven't gotten to this sooner.

Unfortunately Breezy -> Dapper upgrade problems will not be scheduled for resolving since Breezy is no longer supported.

Changed in update-manager:
status: Confirmed → Won't Fix

Which leaves me stuck using Breezy since the upgrade when originally scheduled two years ago didn't work. 

--- On Tue, 6/10/08, Henrik Nilsen Omma &lt;<email address hidden>&gt; wrote:
From: Henrik Nilsen Omma &lt;<email address hidden>&gt;
Subject: [Bug 46250] Re: [dist-upgrader] Could not calculate breezy-&gt;dapper upgrade
To: <email address hidden>
Date: Tuesday, June 10, 2008, 5:38 AM

Thanks for reporting and providing logs. I'm sorry that we haven't
gotten to this sooner.

Unfortunately Breezy -&gt; Dapper upgrade problems will not be scheduled
for resolving since Breezy is no longer supported.

** Changed in: update-manager (Ubuntu)
       Status: Confirmed =&gt; Won't Fix

--
[dist-upgrader] Could not calculate breezy-&gt;dapper upgrade
https://bugs.launchpad.net/bugs/46250
You received this bug notification because you are a direct subscriber
of a duplicate bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments