[dist-upgrader] ftp mirrors become disabled

Bug #46245 reported by Brandon Williams on 2006-05-24
34
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Open terminal, run 'sudo update-manager -d'. It finds the Dapper upgrade, proceeds without a problem until 'Downloading and installing the upgrades'. Downloads about 22 files, and the italics below the progressbar report 'Asking for confirmation' when a dialog prompts up with the following message:

"Could not calculate the upgrade.
A unresolvable problem occured while calculating the upgrade. Please report this as a bug."

Once 'close' is clicked, everything is reverted back to normal (thanks for that. :) )

Update-manager v 0.42.2ubuntu12~breezy1.

Thanks a lot for your bugreport.

Could you please attach the files in /var/log/dist-upgrade*.log to this bugreport?

Thanks,
 Michael

My /var/log/dist-upgrade.log file.

My /var/log/dist-upgrade-apt.log file.

Michael Vogt (mvo) wrote :

Thanks for the files. I found the problem and fixed it in my local repository. It will be part of the next upload.

If you want to work around it, please change your sources.list to only include http:// type urls (change the ftp:// to http://). If that works well for you, please let me know how the upgrade went :)

Changed in update-manager:
assignee: nobody → mvo
status: Unconfirmed → Fix Committed
Michael Vogt (mvo) on 2006-05-26
Changed in update-manager:
status: Fix Committed → Fix Released
Ryan Prior (ryanprior) wrote :

This error has showed up again in the Gutsy -> Hardy upgrade process.

Changed in update-manager:
assignee: mvo → nobody
status: Fix Released → New
Ryan Prior (ryanprior) wrote :
Ryan Prior (ryanprior) on 2008-01-13
Changed in update-manager:
status: New → Confirmed
Peter Kiss (yscik) wrote :

Same error showed up here, with freshly installed Gutsy, trying to upgrade to Hardy.
I looked up the software sources in the menu, found none checked in: after changing that fact and running update-manager again, the upgrade started smoothly.

Ryan Prior (ryanprior) wrote :

I tried refreshing my sources list but it did not solve the problem on my end.

Chris Smolyk (nessmuk) wrote :

This keeps coming up, even when the update manager says I'm up to date.

nessmuk

Brian Murray (brian-murray) wrote :

This particular bug is actually about ftp mirrors being disabled when performing a distribution upgrade from Breezy to Dapper and has already been fixed. Ryan and Chris who have commented on this bug report actually are experiencing different bug reports and should submit their bugs separately and include the same log files they've done here. Thanks!

Changed in update-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers