[dist.upgrader] "unresolvable problem" reported during Breezy->Dapper upgrade

Bug #45990 reported by g1annis on 2006-05-22
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

I try to update my Ubuntu 5.10 to 6.06 but there is a problem. While i wahe allready done the 2 first steps of updating, "...", "changing repositories", in the third part "downloading and installing updates" after having downloading all the 36 packs it starts "checking package manager". then stops and a window appears writting:

[quote]Could not calculate the upgrade
A unresolvable problem occured while calculating the upgrade. Please report this as a bug.[/quote]

Is it resolvable? Are there some setup in the existing version in my pc in order to accept the new update? What do i have to do?

Thanks for testing the new dist-upgrade tool.

Could you please attach the files /var/log/dist-upgrade*.log to the bugreport? This will make it a lot easier for me to identify what went wrong.

Thanks,
 Michael

g1annis (g1annis) wrote :
Download full text (31.2 KiB)

Thank you my friend. Above i will paste the log files, but because i run the greek translation, some word are in greek language. I will translate it into english, as far i can. I hope it will help you.

DIST-UPGRATE.LOG

2006-05-22 20:38:41,060 DEBUG Foreign:
2006-05-22 20:38:41,060 DEBUG Obsolete: w32codecs libdvdcss2 taglib-1.4
2006-05-22 20:38:41,063 DEBUG updateSourcesList()
2006-05-22 20:38:41,085 DEBUG rewriteSourcesList()
2006-05-22 20:38:41,087 DEBUG examining: 'deb-src http://gr.archive.ubuntu.com/ubuntu breezy main restricted'
2006-05-22 20:38:41,088 DEBUG entry 'deb-src http://gr.archive.ubuntu.com/ubuntu dapper main restricted' updated to new dist
2006-05-22 20:38:41,088 DEBUG examining: 'deb http://gr.archive.ubuntu.com/ubuntu breezy-updates main restricted universe multiverse'
2006-05-22 20:38:41,089 DEBUG entry 'deb http://gr.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse' updated to new dist
2006-05-22 20:38:41,089 DEBUG examining: 'deb-src http://gr.archive.ubuntu.com/ubuntu breezy-updates main restricted'
2006-05-22 20:38:41,090 DEBUG entry 'deb-src http://gr.archive.ubuntu.com/ubuntu dapper-updates main restricted' updated to new dist
2006-05-22 20:38:41,090 DEBUG examining: 'deb http://gr.archive.ubuntu.com/ubuntu breezy universe main restricted multiverse'
2006-05-22 20:38:41,090 DEBUG entry 'deb http://gr.archive.ubuntu.com/ubuntu dapper universe main restricted multiverse' updated to new dist
2006-05-22 20:38:41,091 DEBUG examining: 'deb-src http://gr.archive.ubuntu.com/ubuntu breezy universe'
2006-05-22 20:38:41,091 DEBUG entry 'deb-src http://gr.archive.ubuntu.com/ubuntu dapper universe' updated to new dist
2006-05-22 20:38:41,092 DEBUG examining: 'deb http://gr.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse'
2006-05-22 20:38:41,092 DEBUG entry 'deb http://gr.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse' updated to new dist
2006-05-22 20:38:41,093 DEBUG examining: 'deb-src http://gr.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse'
2006-05-22 20:38:41,093 DEBUG entry 'deb-src http://gr.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse' updated to new dist
2006-05-22 20:38:41,094 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted'
2006-05-22 20:38:41,094 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted' updated to new dist
2006-05-22 20:38:41,094 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu breezy-security universe main restricted multiverse'
2006-05-22 20:38:41,095 DEBUG entry 'deb http://security.ubuntu.com/ubuntu dapper-security universe main restricted multiverse' updated to new dist
2006-05-22 20:38:41,095 DEBUG examining: 'deb-src http://security.ubuntu.com/ubuntu breezy-security universe'
2006-05-22 20:38:41,096 DEBUG entry 'deb-src http://security.ubuntu.com/ubuntu dapper-security universe' updated to new dist
2006-05-22 20:41:36,523 ERROR Dist-upgrade failed: 'E:Αδύνατη η διόρθωση προβλημάτων, έχετε κρατούμενα ελαττωματικά πακέτα.'

Tr...

JWB (jwboyer) wrote :

I've also run into this problem trying to do this same upgrade. I'll attach my /var/log/dist-upgrade* files.

These are the log files that were produced from running the gksudo "update-manager -d" command.

Do we have news my friend?
Have you checked it out?

Michael Vogt (mvo) on 2006-05-24
Changed in update-manager:
assignee: nobody → mvo
status: Unconfirmed → Confirmed
Eamon Stack (eamon-eamonstack) wrote :
Download full text (17.0 KiB)

Same Problem
dist-upgrade.log

2006-06-14 23:04:05,413 DEBUG Foreign:
2006-06-14 23:04:05,413 DEBUG Obsolete: libglib2.0-0 libnjb5 libdvdcss2 libxrender1 w32codecs skype libfreetype6 tzdata libpango1.0-common libcairo2 libc6 libpango1.0-0 libusb-0.1-4
2006-06-14 23:04:05,415 DEBUG updateSourcesList()
2006-06-14 23:04:05,419 DEBUG rewriteSourcesList()
2006-06-14 23:04:05,420 DEBUG examining: 'deb http://ie.archive.ubuntu.com/ubuntu breezy-updates main restricted'
2006-06-14 23:04:05,420 DEBUG entry 'deb http://ie.archive.ubuntu.com/ubuntu dapper-updates main restricted' updated to new dist
2006-06-14 23:04:05,420 DEBUG examining: 'deb http://ie.archive.ubuntu.com/ubuntu breezy universe main restricted multiverse'
2006-06-14 23:04:05,421 DEBUG entry 'deb http://ie.archive.ubuntu.com/ubuntu dapper universe main restricted multiverse' updated to new dist
2006-06-14 23:04:20,803 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'

dist-upgrade-apt.log
Starting
Starting 2
Investigating x11-common
Package x11-common has broken dep on xfree86-common
  Considering xorg-common 1 as a solution to x11-common 1785
  Added xorg-common to the remove list
Package x11-common has broken dep on xorg-common
  Considering xorg-common 1 as a solution to x11-common 1785
  Added xorg-common to the remove list
Package x11-common has broken dep on xserver-common
  Considering xserver-common 0 as a solution to x11-common 1785
  Added xserver-common to the remove list
Package x11-common has broken dep on x-common
  Considering x-common 0 as a solution to x11-common 1785
  Added x-common to the remove list
  Fixing x11-common via remove of xorg-common
  Fixing x11-common via remove of xorg-common
  Fixing x11-common via remove of xserver-common
  Fixing x11-common via remove of x-common
Investigating openoffice.org-l10n-en-us
Package openoffice.org-l10n-en-us has broken dep on myspell-dictionary-en-us
Investigating openoffice.org-core
Package openoffice.org-core has broken dep on openoffice.org2-l10n-1.9.129
  Considering openoffice.org2-l10n-en-us 19 as a solution to openoffice.org-core 36
  Added openoffice.org2-l10n-en-us to the remove list
Package openoffice.org-core has broken dep on openoffice.org-help-1.9.129
  Considering openoffice.org2-help-en-us 13 as a solution to openoffice.org-core 36
  Added openoffice.org2-help-en-us to the remove list
Package openoffice.org-core has broken dep on openoffice.org2-core
  Considering openoffice.org2-core 10 as a solution to openoffice.org-core 36
  Added openoffice.org2-core to the remove list
  Fixing openoffice.org-core via remove of openoffice.org2-l10n-en-us
  Fixing openoffice.org-core via remove of openoffice.org2-help-en-us
  Fixing openoffice.org-core via remove of openoffice.org2-core
Investigating openoffice.org-common
Package openoffice.org-common has broken dep on openoffice.org-l10n-en-us
  Considering openoffice.org-l10n-en-us 50 as a solution to openoffice.org-common 28
  Holding Back openoffice.org-common rather than change openoffice.org-l10n-en-us
Investigating language-support-en
Package language-support-en has bro...

Ben Linker (ben-linker) wrote :
Download full text (66.0 KiB)

I have same issue - is there no workaround for this?

Dist-upgrade.log
2006-08-25 13:00:12,466 DEBUG Foreign: aalib1 libexif10 libosp4 libmysqlclient10 linux-image-2.6.10-5-386 pwgen libgnome-menu0 libwvstreams3-base libdb4.2++ xaw3dg libdevmapper1.00 libiw27 python2.4-opengl libpq3 python-numarray python-opengl python2.4-samba openjade libxaw8 docbook-dsssl python2.4-twisted-bin docbook libsoup2.2-7 openoffice.org-hyphenation-en-gb cramfsprogs python2.4-twisted libostyle1 python2.4-numarray libwnck16 python-twisted desktop-base libecal1.2-2 libegroupwise1.2-5 libdmx1 xlibs-data linux-restricted-modules-2.6.10-5-386 mdetect libxkbui1 libisc7 openoffice.org-hyphenation-en-us initrd-tools libflac6 libdps1 gnome-doc-tools libt1-5 libdns16
2006-08-25 13:00:12,468 DEBUG Obsolete: axigen
2006-08-25 13:00:12,472 DEBUG updateSourcesList()
2006-08-25 13:00:12,479 DEBUG rewriteSourcesList()
2006-08-25 13:00:12,482 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu/ breezy-updates main restricted universe multiverse'
2006-08-25 13:00:12,483 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse' updated to new dist
2006-08-25 13:00:12,484 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu/ breezy universe'
2006-08-25 13:00:12,485 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu/ dapper universe' updated to new dist
2006-08-25 15:23:20,442 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'

dist-upgrade-apt.log
Starting
Starting 2
Investigating base-files
Package base-files has broken dep on libpam-modules
Investigating libpango1.0-0
Package libpango1.0-0 has broken dep on libcairo2
Investigating libgtk2.0-0
Package libgtk2.0-0 has broken dep on libcairo2
Investigating libgnomevfs2-0
Package libgnomevfs2-0 has broken dep on libavahi-client3
Investigating libgnomeui-0
Package libgnomeui-0 has broken dep on libbonobo2-0
Investigating libgnutls11
Package libgnutls11 has broken dep on libgcrypt11
Investigating libgtk2.0-bin
Package libgtk2.0-bin has broken dep on libcairo2
Investigating libpango1.0-common
Package libpango1.0-common has broken dep on libcairo2
Investigating xserver-xorg-core
Package xserver-xorg-core has broken dep on x11-common
Investigating libgnomevfs2-common
Package libgnomevfs2-common has broken dep on gconf2
Investigating libcupsys2
Package libcupsys2 has broken dep on libgnutls12
Investigating libgnomeprint2.2-0
Package libgnomeprint2.2-0 has broken dep on libcupsys2
  Considering libcupsys2 54 as a solution to libgnomeprint2.2-0 54
  Removing libgnomeprint2.2-0 rather than change libcupsys2
Investigating libgstreamer0.8-0
Package libgstreamer0.8-0 has broken dep on libxml2
Investigating libgnomeprintui2.2-0
Package libgnomeprintui2.2-0 has broken dep on libgnomeprint2.2-0
  Considering libgnomeprint2.2-0 54 as a solution to libgnomeprintui2.2-0 35
  Removing libgnomeprintui2.2-0 rather than change libgnomeprint2.2-0
Investigating libgstreamer-plugins-base0.10-0
Package libgstreamer-plugins-base0.10-0 has broken dep on libgstreamer0.10-0
Investigating libstlport4.6c2
Package libstlport4.6c2 has broken dep on libstlport4.6
  Considering libstl...

Michael Vogt (mvo) wrote :

@Ben Linker: It looks like your sources.list lacks the "main" repository in your sources.list. Please change:

'deb http://archive.ubuntu.com/ubuntu/ breezy universe'
to
'deb http://archive.ubuntu.com/ubuntu/ breezy main restricted universe'

and try the upgrade again and let me know if it works then.

Thanks,
 Michael

g1annis (g1annis) wrote :

Thank you Michael.
But it seems that you have written the same thing 2 times. You say to change http://archive.ubuntu.com/ubuntu/, and above you give again the same adress.
It seems that you 've something wrong. Should you correct it please?
Thank you again.

Ben Linker (ben-linker) wrote :

Thank you - it worked (well at least it has started downloading the files, I guess I will find out in about 30 mins if the whole upgrade will suceed ...)

g1aanis - you need to add the words "main restricted" into the file between breezy and universe

I found the file in apt/etc (or was it etc/apt... can't remember and its in the middle of the upgrade now), and 1st attempt to edit it was read-only. I did su root gedit /etc/apt/sources.list and it asked for the password, then gave an error message, but opened the file in read/write mode so I obviously typed something wrong but fumbled it enough to edit! (this bit for any other newbs like me who don't knwo what they're doing !)

g1annis (g1annis) wrote :

you 're right

Thanks my friend

Michael Vogt (mvo) wrote :

Thanks Ben Linker and g1annis for testing it. I would be interessted in the result of the actual upgrade (if everything worked well). This particular problem (that the upgrader is not smart enough to figure that "main" was missing) is fixed in my development branch and we will not have this problem in the next ubuntu release anymore!

Thanks,
 Michael

Ben Linker (ben-linker) wrote :

So far so good on the upgrade - took 6 times longer than I thought but otherwise seemed to go through OK. One hassle (Which was there before but is very annoying) is that if it boots up and the screen isn't switched on, it starts in 640 x 480 mode and I can't switch back again without a complete reboot - did it to me twice yesterday (I use a screen switch box to my other PC) hence not much testing yet.

Regards,

Ben.

Michael Vogt (mvo) wrote :

Thanks Ben Linker for this update. I'm happy to hear that it went mostly ok. One final question, did it took 6 times longer than you thought because the initial estimated time was calculated inaccurate?

Ben Linker (ben-linker) wrote :

Hard to judge as it kept stopping and asking me questions - as I wasn't around most of the time I don't know how long it was waiting for.... however the inital download estimate was I think about 48 minutes - it might have been about right, wasn't too bothered at that stage. I assumed the update would take maybe another 10 - 15 minutes, (thats the bit after the downloading) but it took around 4 or 5 hours in the end, with the waiting time included.
That system was only a celeron 1100 with 512mb ram - runs the OS happily enough

Marking as fixed, based on mvo's comments.

Changed in update-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers