thinks that package information is 8 days old even after updating an hour ago (aptitude does not write update-stamp)

Bug #454941 reported by Kiri on 2009-10-18
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
aptitude
Fix Released
Unknown
aptitude (Ubuntu)
Medium
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I have an update warning.
I update using update-manager.
~1h later another update warning:

Your system is up-to-date.
The package information was last updated 8 days ago.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 18 22:00:39 2009
DistroRelease: Ubuntu 9.10
Package: update-manager 1:0.126.4
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: update-manager
Uname: Linux 2.6.31-14-generic i686

Related branches

Kiri (kiri) wrote :
Michael Vogt (mvo) wrote :

What is the output of:
$ ls -l /var/lib/apt/periodic
?

Changed in update-manager (Ubuntu):
status: New → Incomplete
Kiri (kiri) wrote :

-rw-r--r-- 1 root root 0 2009-10-20 09:08 download-upgradeable-stamp
-rw-r--r-- 1 root root 0 2009-10-20 09:00 update-stamp
-rw-r--r-- 1 root root 0 2009-10-20 09:00 update-success-stamp

They are all empty.

_dan_ (dan-void) wrote :

i have the same error/warning/bug

total 0
-rw-r--r-- 1 root root 0 2009-10-11 07:55 update-stamp
-rw-r--r-- 1 root root 0 2009-10-12 06:47 update-success-stamp

Changed in update-manager (Ubuntu):
status: Incomplete → New
Michael Vogt (mvo) wrote :

@Jedasothi: thanks - this is puzzling, the timestamps on the file look correct. What version of update-manager is that? Karmic should automatically update the text.

@_dan_: it appears that in your case this is correct and the update is really a couple of days old. There was a bug in the automatic update script some days ago, could you please check what version of apt you are using?

Michael Vogt (mvo) wrote :

Hm, sorry for the question about the version. Its Package: update-manager 1:0.126.4 so that should be all right. If you close and open update-manager, does it still show the wrong time information? Or does that fix it?

Changed in update-manager (Ubuntu):
status: New → Incomplete
_dan_ (dan-void) wrote :

@Michael Vogt its not right, i set the apt to check daily plus i manually updated the package information, i tried it with cli apt and with the update-manager gui "check" button, it refreshed the information, installed updates, but i still get the warning "package information is old ..." even tho i manually updated the information 1 few seconds ago.
Closing and opening does not help, nor does rebooting.

my apt version is: 0.7.23.1ubuntu2
my update-manager version is: 1:0.126.5

Kiri (kiri) wrote :

Previously, when closing the main window and re opening it, it would still show outdated information. It may be that it was running in the 'background' and shown in the panel and not shut down. I no longer recall.

Right now, i do not have it start upon login. Starting it manually, it shows 'updated 3 days ago' which is probably the last time i used update-manager. The last update via aptitude was an hour or few ago, so i guess tracking updates by other programs is unimplemented.

Here is a conjecture: i had aptitude running and then update-manager attempted update but could not due to resources being locked. After closing Aptitude, update-manager had some invalid state information which prevented it from operating properly.

_dan_ (dan-void) wrote :

It wont show updated usage information even when i use update-manager since i use it twice a day usually.
Has nothing to do with apt or aptitude
Update-manager currently shows 14 days old package information when in fact it is seconds old.

Michael Vogt (mvo) wrote :

Thanks for the replies.

update-manager checks for the last update time via the file:

/var/lib/apt/periodic/update-success-stamp

That is written every time a apt-get update/aptitude update/update-manager check update *without* any errors was done. A error can be e.g. unreachable third party repository, no network connectivity etc. If you see incorrect information like above, please check the timestamp of that file and check if apt-get update (on a terminal) runs without errors or warnings. If both is the case, then there is a bug.

Michael Vogt (mvo) wrote :

I need to correct myself, a "aptitude update" does not update the update-success-stamp, its implementing the fetching on its own, not using the ListUpdate method that apt-get and all python-apt apps are using.

Changed in aptitude (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
summary: thinks that package information is 8 days old even after updating an
- hour ago
+ hour ago (aptitude does not write update-stamp)
_dan_ (dan-void) wrote :

I have errors from third party repos, so that explains my issue

Kiri (kiri) wrote :

So, if there were any error produced in updating one of the repositories, the results would be as described:

update-manager would correctly find and install updates, but not update the time stamp and so continuously report that updating is needed?

I no longer recall, but it could be that I had a repository at that time which produced a non-fatal error.
Around that time I had a local repository which I think produced the error that signatures or checksums could not be verified. I would expect myself to disable that repo & try the update again, but perhaps I did not. It would perfectly explain the symptoms and seems the most likely explanation to me.

I am also seeing this issue in Lucid Lynx (Alpha 3) in a Virtual Box VM.

Could it be significant that my update system is:

aptitude update
aptitude -d -y dist-upgrade

Then run update-manager via the GUI to actually install the packages that the command lines above?

Perhaps aptitude is not setting the flag because it did not actually install anything.

Rolf Leggewie (r0lf) on 2011-10-19
tags: added: lucid
Changed in aptitude:
status: Unknown → Fix Committed
Stephan Springer (geryon) wrote :

Aptitude 0.6.6-1 has been released, which should fix this bug.

Changed in aptitude:
status: Fix Committed → Fix Released
Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
Launchpad Janitor (janitor) wrote :
Download full text (4.0 KiB)

This bug was fixed in the package aptitude - 0.6.6-1ubuntu1

---------------
aptitude (0.6.6-1ubuntu1) precise; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - debian/05aptitude: Never autoremove kernels.
    - Drop aptitude-doc to Suggests.
    - 03_branding: Ubuntu branding.
    - 04_changelog: Take changelogs from changelogs.ubuntu.com.
    - 11_ubuntu_uses_sudo: Fix status line of 'Become root' menu entry to
      not refer to su.
    - 12_point_manpage_to_doc_package: Point Finnish manpage to the correct
      place for further info.
    - 14_html2text_preferred: Switch back to html2text in favor of elinks,
      since html2text is in main and elinks isn't.
    - no-google-mock: Don't use google-mock as it and libgtest-dev are in
      universe.

aptitude (0.6.6-1) unstable; urgency=low

  * New upstream release.

    - Basic multi-arch support. See NEWS for details.

      + add search terms ?architecture and ?multiarch;
      + add grouping policy 'architecture';

      (Closes: #659079, #661744)
      (LP: #454941, #845136, #884945, #904486)

    - Apply patch from Ubuntu to fix build -D_FORTIFY_SOURCE=2 errors.
      Thanks to Colin Watson and Michael Vogt (Closes: #497539)

    - Remove GTK+ menu entry for minesweeper. (Closes: #552522)

    - Hack to prevent debug messages dumping to the screen (Closes: #651748)

    - Fix '?action(upgrade)' and others (were finding kept
      packages instead). Thanks to 'Rogier' for the patch (Closes: #603862)

    - List update errors are reported. (Closes: #451137)

    - List update now runs APT::Update hooks. (Closes: #476399)

    - Actually silence progress messages with '-q2'. (Closes: #141719)

    - Fix various locking issues:

      + '[auto]clean' locks /var/cache/apt/archives;
      + 'update' locks /var/lib/apt/lists; (Closes: #653479)

    - Fix 'priority' cost level in resolver. The values should
      have been negated but were not. Thanks to Modestas Vainius
      for this one. (Closes: #608786)

    - Fix some help and prompt strings which wrongly included
      localized names for commands such as 'why'. (Closes: #486615)

    - Change ordering of top-level sections to match the order
      in aptitude::Sections::Top-Sections. The default order
      is now: main, contrib, non-free. (Closes: #181997)

    - Improve error messages when parsing grouping policies to
      use the user-visible names, rather than the internal
      names. (Closes: #231595)

    - Change default width of %D, %I, %o, and %Z. Thanks to
      Michał Kułach for this one. (Closes: #599209) (LP: #741417)

    - Change default width of %V, %v to 14. This greatly increases the
      number of versions which will display completely. (Closes: #624542)

    - 'versions' now groups it's results by 'package:arch' instead of
      'package'.

    - Cleared up grouping, sorting policy error messages.
      (Closes: #231595)

    - Minor correction to the user's manual. (Closes: #365485)

    - Translation updates:

      + Brazilian Portuguese (Closes: #483964)
      + Hungarian (Closes: #592468)
      + Polish (Closes: #659803)
      + Russian (Closes: #662624)

  * No longer suppl...

Read more...

Changed in aptitude (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.