fails to reboot during recent 9.04 -> 9.10 upgrades

Bug #451556 reported by James Troup on 2009-10-14
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
upstart (Ubuntu)
High
Scott James Remnant (Canonical)
Karmic
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: update-manager

I just upgraded 6 machines in the office to 9.10 from 9.04. Every single one failed to reboot immediately after the upgrade. I selected 'Restart' when prompted by update manager, but nothing happened. I then tried selecting 'restart' from the FUSA applet, which did start a reboot, however at that point one of two things happened. Either it got stuck on the console with nothing but a cursor on the top left of the screen, or it restarted gdm. In either instance the mouse/keyboard wasn't working at that point. I had to hard powercycle each machine to get it to boot.

Michael Vogt (mvo) on 2009-10-15
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-9.10
Michael Vogt (mvo) wrote :

Thanks for the bugreport.

I can reproduce this now. It appears that upstart does refuses the connection when reboot tries to ask for reboot.
From the strace log:

connect(3, {sa_family=AF_FILE, path=@"/com/ubuntu/upstart"}, 22) = -1 ECONNREFUSED (Connection refused)

I attach the full log.

Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

initctrl will give me a proper error message and report it fails to connect to socket /com/ubuntu/upstart. There are a bunch of (not critial) /etc/init.d/$daemon restart failed messages for the same reason in the logs as well.

So it looks like the upstart tools from 0.6 can not talk to the (still running) upstart 0.3 from jaunty (incompatible wire protocol on the socket). I tried to send SIGHUP to init as a workaround (simulating ctrl-alt-del) but other than a message on the console nothing happend.

Michael Vogt (mvo) wrote :

I think this is something new, I get now:
...
Errors were encountered while processing:
 rsyslog
 ubuntu-minimal
Setting up rsyslog (4.2.0-2ubuntu5) ...
start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: initscript rsyslog, action "start" failed.
dpkg: error processing rsyslog (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on rsyslog; however:
  Package rsyslog is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 rsyslog
 ubuntu-minimal

in my auto-upgrade testing setup (for a server install). That used to work, so its probably something that changed recently.

Michael Terry (mterry) wrote :

Yeah, rsyslog has had a couple bugs filed recently about the "Connection refused" message: bug 452078. Looking at their logs, every service package is having the same problem. I'm not yet sure if they are in a chroot or not (in which case it's a dup of bug 430224).

But you're saying that this is in a kvm, so we may be seeing a new upstart bug.

Steve Langasek (vorlon) on 2009-10-15
Changed in upstart (Ubuntu Karmic):
importance: Undecided → High
Changed in update-manager (Ubuntu Karmic):
status: Confirmed → Invalid
Changed in upstart (Ubuntu Karmic):
status: New → In Progress
assignee: nobody → Scott James Remnant (scott)
milestone: none → ubuntu-9.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.3-10

---------------
upstart (0.6.3-10) karmic; urgency=low

  * Retain the "telinit u" for the case when we're upgrading from pre-0.6
    (ie. hardy or jaunty). Whups. LP: #451556.

 -- Scott James Remnant <email address hidden> Thu, 15 Oct 2009 17:48:47 +0100

Changed in upstart (Ubuntu Karmic):
status: In Progress → Fix Released
Carfield Yim (carfield) wrote :

I am using 0.6.6-3, and I still have this problem.... look like this problem also causing my cannot boot properly ( YES, STILL! )

After it showing "scripts/init-bottom..done" Then it is stop there, how can I find out more information? Like , which module it failed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers