FFe: update-manager should have per-package changelog locations (was: uses changelogs.ubuntu.com for all packages)

Bug #45129 reported by Richard Laager on 2006-05-16
72
This bug affects 10 people
Affects Status Importance Assigned to Milestone
reprepro
New
Undecided
Unassigned
update-manager (Ubuntu)
Wishlist
Unassigned
Nominated for Lucid by Heimen Stoffels

Bug Description

Binary package hint: update-notifier

If you have packages from third-party repositories configured, update-notifier should not be looking at changelogs.ubuntu.com for their changelog information.

Gaëtan Petit (gaetanp) wrote :

yes it would be nice =)

Changed in update-notifier:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) on 2006-10-02
Changed in update-notifier:
importance: Medium → Wishlist
Michael Vogt (mvo) wrote :

The suggested spec in https://wiki.ubuntu.com/SoftwareChannelSpec dicussions this too.

Mark Florian (markrian) wrote :

I think I just encountered this bug.

I'm running edgy, but have a feisty deb-src channel enabled. With this, the update-manager would show changes from from very latest package in feisty, rather than the changes of the package within edgy. If I remove the feisty line, the correct changelog is pulled by update-manager. I'll attach a screenshot that should demonstrate what I mean.

FYI, aptitude pulls the correct changelog.

Steve Lemke (steve-lemkeville) wrote :

> FYI, aptitude pulls the correct changelog.

Not for me, it doesn't. I just tried it (hit "C" when pointing to my own package on my own private hosted repository), and got a big red dialog that says "You can only view changelogs of official Ubuntu packages."

I often get questions from people who install my (in-house) packages asking "how do I know what's changed in a new update of your package?". I HAVE changelogs, but they are not available in the Ubuntu Update Manager. It would be really nice if someone could fix the fact that not every (privately-built and/or hosted) package changelog can be found (or expected to live) at changelogs.ubuntu.com. :-(

The changelogs should ALSO be looked for in the SAME repository where the package in question was found.

Granted, I could see where some of this might need to be addressed "upstream" in the debian world, but we're not using debian, we're using Ubuntu and the Update Manager, and we'd like it to display changes from non-Ubuntu-hosted changes.

--Steve

João Pinto (joaopinto) wrote :

Hello,
I believe the requirement is to have per repository changelog source, not per packages.

For non official repositories this could be easily achieved by using the http://archive_base_url/changelogs/pool instead of the default http://changelogs.ubuntu.com/ .

Heimen Stoffels (vistaus) wrote :

Will this bug be fixed?

João Pinto (joaopinto) wrote :

With the following patch the update manager will try to fetch from "archive/changelogs/..." for non Ubuntu packages.
It needs to be improved to use the archive URI, right now is just using the origin site (archive hostname).

It can be tested by:
install filezilla

add to your sources:
deb-src http://archive.getdeb.net/ubuntu lucid-getdeb apps games

Go to update manager and check the Filezilla update change log.

Michael Vogt (mvo) on 2010-04-12
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

I commited your patch to trunk, I'm not sure its appropriate at this point for inclusion for lucid, but I will ask the release team.

It goes and looks at http://archive.getdeb.net/ubuntu as the base path to support sites (like ppas) with multiple archives on the same host.

Michael Vogt (mvo) wrote :

Here is the diff:
http://bazaar.launchpad.net/~ubuntu-core-dev/update-manager/main/revision/1778

Release team, can I get a FFe exception for this please? It will allow us to display changelogs for third party repositories like PPAs or getdeb. Because of the LTS nature this is pretty nice to have as I except we will have more third party repositories than usual.

Michael Vogt (mvo) on 2010-04-12
summary: - update-manager should have per-package changelog locations (was: uses
- changelogs.ubuntu.com for all packages)
+ FFe: update-manager should have per-package changelog locations (was:
+ uses changelogs.ubuntu.com for all packages)
Martin Pitt (pitti) wrote :

Looks fine to me, approved.

Michael Vogt (mvo) wrote :

I add a soyuz task. For soyuz to support changelogs in PPAs it just needs to create a directory called "changelogs/" under e.g. http://ppa.launchpad.net/mvo/ppa/ubuntu/
that contans a similar structure like:
http://changelogs.ubuntu.com/changelogs/
(i.e. raw debian/changelog file under pool/component/first-letter/srcpkgname/srcpkgname_fullversion/changelog)

I'm happy to include a patch to Soyuz if someone writes it; the Soyuz team doesn't really have the time to address this right now. If you need help writing it let me know.

Changed in soyuz:
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.134.1

---------------
update-manager (1:0.134.1) lucid; urgency=low

  * DistUpgrade/DistUpgradeController.py:
    - honor "DEBIAN_FRONTEND=noninteractive" on pkg failure (LP: #538206)
  * DistUpgrade/DistUpgradeQuirks.py:
    - stop apparmor before dpkg starts on hardy -> lucid upgrades to
      avoid potentially confusing error messages during the upgrade
      (LP: #559433)
  * DistUpgrade/DistUpgradeCache.py, DistUpgrade/build-tarball.sh:
    - include obselte nvidia pkgnames to properly transition old
      to new drivers (LP: #553369)
  * DistUpgrade/DistUpgradeViewText.py:
    - show packages that will be removed (because they were auto installed)
      as well (LP: #558438)
    - fix i18n bug in details output
  * UpdateManager/Core/MyCache.py:
    - support third party changelogs by using ArchiveURI() and
      append a similar structure as changelogs.ubuntu.com uses
      (LP: #45129)
  * UpdateManager/Core/MetaRelease.py:
    - do not crash if meta-release file can not be parsed, just remove
      the broken file instead (LP: #558396)
 -- Michael Vogt <email address hidden> Mon, 12 Apr 2010 18:32:59 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
William Grant (wgrant) wrote :

We discussed this on #ubuntu-devel a few hours ago, and the scheme has changed. Instead of this:

 ARCHIVE_ROOT/changelogs/pool/main/f/foo-src/foo-src_1.0/changelog

we'll use:

 ARCHIVE_ROOT/pool/main/f/foo-src/foo-src_1.0.changelog

There should also be foo-bin_1.0_i386.changelog symlinks to the source changelog, which update-manager will use. This fixes the problem with binaries that have a different version from their source.

Anton Piatek (anton-piatek) wrote :

I can confirm this works with the update-manager (gnome) gui for my custom repository on Lucid.

However it does not work for the KDE update manager gui - Should I follow that on in this bug report or create a new one?

Michael Vogt (mvo) wrote :

The relevant commit in update-manager for the new schema is:
http://bazaar.launchpad.net/~ubuntu-core-dev/update-manager/main/revision/1783

William Grant (wgrant) wrote :

Erratum to my comment #15: the binary symlinks aren't actually required. The final update-manager change looks for the source one instead, which should make our job substantially easier.

taka k. (scar) wrote :

5 years and still we are unable to view changelogs from updates coming from PPAs?

Constantine (theaspect) wrote :

There is already exists apt-changelog that reads and calculates changelog from /usr/share/doc/somepackage/changelog resides inside deb archive. Why we need at all to download changelog from ubuntu website. This is pain for custom repositories or systems.

Constantine (theaspect) wrote :

Does this patch works with ftp or ssh repositories?

And, also, does reprepro developers know, that they should extract changelog from archive and put it near the package archive?

Sitsofe Wheeler (sitsofe) wrote :

Constantine:
Re /usr/share/doc/somepackage/changelog: The changelogs being downloaded are for the updated packages that are not yet installed on the system (so the new changes will not be in /usr/share/doc/somepackage/changelog ). The only way to get at the updated changelog is to download it. Further, doesn't apt-changelog download changelogs from changelogs.ubuntu.com ( http://www.piware.de/2010/11/ubuntu-natty-where-did-my-changelogs-go/ )?

Anton Piatek (anton-piatek) wrote :

I use this for our corporate reprepro repository with several hundred packages and find it very useful to be able to show our users what has changed in a package before they install the updates.
reprepro does not extract the files itself, I do it manually as part of my repository build code

Constantine (theaspect) wrote :

I've add reprepro as affected project to notify reprepro guys

Constantine (theaspect) wrote :

Sitsofe Wheeler
Re: doesn't apt-changelog download changelogs from changelogs.ubuntu.com

I tested it on my private repository, and apt-changelog shows changes with "aptget -d install mydeb" resides in cache.

Marius B. Kotsbak (mariusko) wrote :

I read this as a duplicate of bug #253119.

Philipp Kern (pkern) wrote :

While the Soyuz task of this bug might be a duplicate, that's not true for the update-manager part and it would hurt to make the information in #45129 invisible, hence unmerged.

William Grant (wgrant) on 2013-08-12
no longer affects: launchpad
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers