Ubuntu

sudo update-manager always says 'waiting for other software managers to quit'

Reported by Rocko on 2009-10-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Martin Hauge

Bug Description

Binary package hint: update-manager

Whenever I run 'sudo update-manager' in Karmic and click 'Check' or 'Install', it now always says it is waiting for other software managers to quit.

I can't find any other software managers that are running, which is confirmed by the fact that running it without root privileges works.

ProblemType: Bug
Architecture: amd64
Date: Thu Oct 8 07:45:26 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: update-manager 1:0.125.6
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.40-generic
SourcePackage: update-manager
Uname: Linux 2.6.31-12-generic x86_64

Rocko (rockorequin) wrote :
Michael Vogt (mvo) on 2009-10-08
Changed in update-manager (Ubuntu):
status: New → Fix Committed
Brad Crittenden (bac) wrote :

As mentioned in bug 444168 a work-around is to run:

dpkg --configure -a

seamles (brianwlwu) wrote :

I have the same problem.

When i try that work-around I get
requested operation requires superuser privelege.

i don't know what to do.

thanks

kingfisher (lorenzoirl) wrote :

Hi,

that means that you need to run in terminal sudo dpkg --configure -a

Artost (weird4him) wrote :

thanks. Running the above command fixed it for me.

jan sekal (jsekal) wrote :

neither dpkg --configure -a nor sudo dpkg --configure -a worked on my machine - ubuntu 9.10, no updates - have you any idea what else to try?

Martin Hauge (marthau3) wrote :

I still get the message Waiting for other software managers to quit

Changed in update-manager (Ubuntu):
assignee: nobody → Martin Hauge (marthau3)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers