update-manager shouldn't complain that synaptic is running when there are new updates

Bug #43087 reported by neutrico on 2006-05-05
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: update-manager

Currently when new updates apear there is 'baloon' in notification area.
It says that you should click on this 'baloon' to update - unfortunately if there is some application such as synaptic running somewhere there is error report that says that user has to shut down synaptic first.

IMHO this is wrong behaviour. I agree that there could be a problem with aptitude or just command line apt-get, but I think that instead of error message update-manager should go to currently running synaptic if is up and running already.

Sebastian Heinlein (glatzor) wrote :

We could check if apt is locked before showing the notification.

The long term plan is to remove the need for root privileges if you only want to view and plan changes as already done in gnome-app-install. So it should then be possible to run synaptic and update-manager at the same time.

Changed in update-manager:
status: Unconfirmed → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Triaged and lowering to wishlist because this is not a bug but an improvement.

Furthermore, when update-manager is already running as root and the user opens a second update-manager when clicking on the update-notifier, then if you try to install some package, there is a notification saying that the database is locked. It could be better to switch to the already running update-manager.

Changed in update-manager:
importance: Low → Wishlist
status: Confirmed → Triaged
Matthew Paul Thomas (mpt) wrote :

I don't know when it was fixed, but it seems this bug no longer exists: I can launch Synaptic, and then launch Update Manager, without Update Manager complaining.

If you still experience the problem, please provide up-to-date steps to reproduce it. (We no longer show anything in the notification area for software updates.)

Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers