The update fails with an error for 9.04 to 9.10 in server upgrade mode with no universe

Bug #426367 reported by ti.teg.tnod.I on 2009-09-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubuntu-minimal

Upgrade 9.04 to 9.10 Alpha 5
I ran: update-manager -d
I upgraded all my packages and began the install.
A few minutes later it failed with this error: http://lookpic.com/i/734/R1ABYwKW.png
And here's the data it requested: http://www.filedropper.com/dist-upgradetar

My system appears to have recovered fine back to it's original state.

ti.teg.tnod.I (ti-teg-tnod-i) wrote :

I messed up when typing in the package could this be changed to the "update-manager" package?

affects: ubuntu-meta (Ubuntu) → update-manager (Ubuntu)
ti.teg.tnod.I (ti-teg-tnod-i) wrote :

Never mind I figured it out.

summary: - The update fails with an error
+ The update fails with an error for 9.04 to 9.10 Alpha 5

When trying to download the files from http://www.filedropper.com/dist-upgradetar I just go to the default page of the filedropper.com. Could you please attach the files here?

Changed in update-manager (Ubuntu):
status: New → Incomplete
Pieter (diepes) wrote :

update-manager -d

upgrading to Alpha6, after seting up channels i get a popup (attached) that states.

"After your package information was updated the essential package 'ubuntu-minimal' can not be found anymore" .......

Pieter (diepes) wrote :

update-manager -d

upgrading to Alpha6, after seting up channels i get a popup (attached) that states.

"After your package information was updated the essential package 'ubuntu-minimal' can not be found anymore" .......

summary: - The update fails with an error for 9.04 to 9.10 Alpha 5
+ The update fails with an error for 9.04 to 9.10 Alpha 5 and Alpha 6
Pieter (diepes) wrote :
Michael Vogt (mvo) wrote :

Here is the error, it seems to be a issue with the server you are using:

, W:Failed to fetch http://za.archive.ubuntu.com/ubuntu/dists/karmic/multiverse/binary-i386/Packages Could not connect to 10.65.192.115:8080 (10.65.192.115). - connect (111 Connection refused)

Could you please try again? It may be a transient issue.

Michael Vogt (mvo) wrote :

I can reproduce the failure that ubuntu-minimal gets removed. This happens for me if I do a server upgrade (ie no ububuntu-desktop or similar meta-package installed and no key dependency for that). It also only happens when universe is not enabled.

I added code to update-manager that ensures that this is handled now (still in the frozen queue).

Changed in update-manager (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-9.10
summary: - The update fails with an error for 9.04 to 9.10 Alpha 5 and Alpha 6
+ The update fails with an error for 9.04 to 9.10 in server upgrade mode
+ with no universe
Michael Vogt (mvo) wrote :

update-manager (1:0.125.6) karmic; urgency=low
...
  * DistUpgrade/DistUpgradeCache.py:
    - add new rule to ensure that base meta packages are always
      kept installed. this helps the server upgrade with the syslogd
      to rsyslog transition

Changed in update-manager (Ubuntu):
status: Triaged → Fix Committed
Michael Vogt (mvo) on 2009-10-05
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers