mysql-server has been kept back with dist-upgrading

Bug #413789 reported by Mathias Gug on 2009-08-14
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt
Karmic
High
Michael Vogt

Bug Description

While trying to upgrade mysql-server in karmic, apt-get dist-upgrade fails:

mathiaz@t-mysql-up:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
 libmysqlclient16
The following packages have been kept back:
 mysql-server
The following packages will be upgraded:
 mysql-common
1 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 2027kB of archives.
After this operation, 4502kB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.

mathiaz@t-mysql-up:~$ sudo apt-get install mysql-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
 update-motd libparted1.8-10
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
 libmysqlclient16 mysql-client-5.1 mysql-common mysql-server-5.1
 mysql-server-core-5.1
Suggested packages:
 tinyca
The following packages will be REMOVED:
 mysql-client-5.0 mysql-server-5.0 mysql-server-core-5.0
The following NEW packages will be installed:
 libmysqlclient16 mysql-client-5.1 mysql-server-5.1 mysql-server-core-5.1
The following packages will be upgraded:
 mysql-common mysql-server
2 upgraded, 4 newly installed, 3 to remove and 0 not upgraded.
Need to get 21.2MB of archives.
After this operation, 60.7MB disk space will be freed.
Do you want to continue [Y/n]?

Mathias Gug (mathiaz) on 2009-08-14
Changed in mysql-dfsg-5.1 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
milestone: none → karmic-alpha-6
milestone: karmic-alpha-6 → karmic-alpha-5
Mathias Gug (mathiaz) wrote :

To reproduce in a karmic system:

1. Install mysql-server-5.0.
2. Install the latest mysql-server package from mysql-dfsg-5.0:

https://launchpad.net/ubuntu/+source/mysql-dfsg-5.0/5.1.30really5.0.83-0ubuntu1

https://launchpad.net/ubuntu/+source/mysql-dfsg-5.0/5.1.30really5.0.83-0ubuntu1/+build/1113804/+files/mysql-server_5.1.30really5.0.83-0ubuntu1_all.deb

3. Try to apt-get dist-upgrade. mysql-server will be kept back.
4. Try to apt-get install mysql-server - it will successfully upgrade by removing mysql-*-5.0 and install mysql-*-5.1.

Changed in mysql-dfsg-5.1 (Ubuntu):
milestone: karmic-alpha-5 → karmic-alpha-6
status: Confirmed → Triaged
Mathias Gug (mathiaz) wrote :

Michael could you have a look at while dist-upgrade fails?

Mathias Gug (mathiaz) on 2009-09-15
Changed in mysql-dfsg-5.1 (Ubuntu Karmic):
milestone: karmic-alpha-6 → ubuntu-9.10-beta
Changed in mysql-dfsg-5.1 (Ubuntu Karmic):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) wrote :

I'm wondering if the proper solution to this is to remove mysql-dfsg-5.0 from the archive to clue apt into the fact that its binaries should get a lower score than the binaries from mysql-dfsg-5.1. It's no longer in unstable ...

There are *lots* of reverse dependencies, though.

Colin Watson (cjwatson) wrote :

Michael, is there anything else we can do about this that will convince apt to do the right thing?

Changed in mysql-dfsg-5.1 (Ubuntu Karmic):
assignee: Canonical Foundations Team (canonical-foundations) → Michael Vogt (mvo)
Mathias Gug (mathiaz) wrote :

mysql-dsfg-5.0 is currently in universe and the plan is to get rid of it during the next release cycle. The transition to 5.1 is ongoing in Debian and we would benefit from at the next release cycle.

There are also some unsupported features in 5.1 (like MySQL Cluster) that are available in 5.0. In that use case the upgrade will fail with an error message suggesting to remove mysql-server and keep mysql-server-5.0 around.

Colin Watson (cjwatson) wrote :

Is an action in the next release cycle good enough? We need to do something about this bug for *this* release cycle, surely.

Steve Langasek (vorlon) wrote :

Pushing back to 9.10, since nothing here is landing in time for beta at this point. Michael, can this still be worked around in update-manager?

Changed in mysql-dfsg-5.1 (Ubuntu Karmic):
milestone: ubuntu-9.10-beta → ubuntu-9.10
Michael Vogt (mvo) wrote :

I added a release upgrader hint for the handling of mysql-server now, it will be part of the next upload. Changing it so that plain apt will DTRT is more tricky, because the simple algorithm in apt generally prefers to keep installed things when two options seems to be about equal (that is the case here).

Changed in mysql-dfsg-5.1 (Ubuntu Karmic):
status: Triaged → Fix Committed
Mario Limonciello (superm1) wrote :

update-manager (1:0.126.1) karmic; urgency=low

  * DistUpgrade/DistUpgradeView.py:
    - log exceptions from pm.DoInstall() into main.log.
      this helps identifiying Dpkg::Pre-Invoke problems
  * DistUpgrade/DistUpgradeCache.py:
    - fix sandbox upgrade mode
  * DistUpgrade/DistUpgrade.cfg:
    - hint for mysql-server upgrade (LP: #413789)
  * UpdateManager/backend/__init__.py:
    - change order of backends to: synaptic, aptdaemon

 -- Michael Vogt < <email address hidden>> Mon, 12 Oct 2009 18:30:55 +0200

affects: mysql-dfsg-5.1 (Ubuntu Karmic) → update-manager (Ubuntu Karmic)
Changed in update-manager (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers