Configuration Dialogs should not steal focus during updates

Bug #373974 reported by lavinog on 2009-05-09
132
This bug affects 28 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
update-manager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

During an update, I was writing an email. A window came up just as I pressed the spacebar. The window disappeared before I could read it. The window was most likely asking about what to do about menu.lst since there was a kernel update.
This can not be proper behavior.
Either, 1) dialogs should not steal focus, or 2) dialogs should not have a default button selected so that a user pressing enter, or spacebar at the wrong time doesn't break a system.
I suspect that #2 would be a better option, since the update is incomplete until the user makes a selection. If the user fails to notice the window for an extended time, the system might crash or be rebooted before the update is completed.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: update-manager 1:0.111.9
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
Uname: Linux 2.6.28-11-generic x86_64

lavinog (lavinog) wrote :
Changed in update-manager (Ubuntu):
importance: Undecided → High
status: New → Triaged
Peter Berry (pwberry) wrote :

Personally I don't see any good reason to steal focus, ever. It is quite simply rude and annoying. Opening an unfocussed window in the foreground would be acceptable but not stealing focus.

to be removed (liw) wrote :

As far as I understand, it is the window manager that primarily decides whether to give focus to a new window. That said, apps can to things that affect how window managers do things. In particular, I think update-manager should make all of its dialogs transient for the main window. See "Transient for Window" atribute in Glade.

lavinog (lavinog) wrote :

This seems to have become worse: Both the "Downloading Updates" and "Applying Updates" windows steal focus.
This might fix itself if the update manager is going to be replaced by the software center.

iGEL (igel) wrote :

Also the check at the end steals the focus. It's very anoying.

Nicolò Chieffo (yelo3) wrote :

Summary (tell me if I'm wrong):
- when it opens automatically (after updating the package list)
- when you click "check" and there are NOT new pagkages (it steals for a second showing the progress bar at the end)
- when you click "check" and there are new packages
- when it finishes downloading packages and starts installing them
- when it needs your attention to make a decision
- when it finishes installing packages

could it be a synaptic problem? update manager uses synapric windows

Nicolò Chieffo (yelo3) wrote :

Can this be considered a paper cut to fix?

affects: update-manager → hundredpapercuts
Vish (vish) wrote :

This is actually not a Update manager bug , It seems to be a compiz bug , this is a dup of > Bug #391479

Vish (vish) wrote :

If you switch from compiz to metacity , there is no such problem with either synaptic or update manager.

lavinog (lavinog) wrote :

This bug effected me with metacity. I don't use compiz.

Vish (vish) wrote :

@lavinog : Are you sure?
Select "none" from the System>Preferences>Apperances> Visual Effects tab.
And now, try update manager or synaptic, the dialogue widow will does change appear in a different the desktop or grab focus from any other window.

I wasnt aware of this either , until pointed out by https://bugs.launchpad.net/hundredpapercuts/+bug/391479/comments/6 .

lavinog (lavinog) wrote :

@vish, no desktop effects.
The problem occurs when dpkg requires a user response such as when a config file was modified by the user and dpkg asks whether to use the packaged version or keep the original. The problem is that the dialog steals focus and a default entry is set. If I am typing in another window and I press the enter key (I think the spacebar also) at the same time the dpkg window steals focus, I commit the change without having a chance to review it, and thus possibly breaking my system.

Vish (vish) on 2010-01-16
summary: - Dialogs steal focus during update
+ Configuration Dialogs should not steal focus during updates
Changed in hundredpapercuts:
status: New → Confirmed
era (era) wrote :

The general problem of focus stealing in update-manager is in bug #35876. Perhaps this bug can be handled a bit more swiftly than the general case, though.

This bug's quite old and there's not been any activity here in about ten months now. Is this still causing problems for people?

thorstenmz (th-guenther) wrote :

This seems to be fixed. I haven't experienced problems with update manager lately.

lavinog (lavinog) wrote :

I haven't had any updates that have brought up the dpkg screen, such as when there is a custom config file, and a update might overwrite that file. I think I may have been using grub1 when I first reported this bug. Having non-default settings in menu.lst was one of the things that triggered this issue.

If this isn't affecting every (or at least most) default installations, then I'm closing the paper cut task here. Since this is marked as affecting 18 people, I'll leave the update manager task open.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Tomas Petricek (tpetricek) wrote :

This bug affects me as well on 12.04 with in 'GNOME Classic (No effects)' session. Should a new bug be created?
As was described such a behavior is very annoying and potentially harmful...

Jiang (cdjxt2006) on 2013-02-12
Changed in update-manager (Ubuntu):
status: Triaged → New
Changed in update-manager (Ubuntu):
status: New → Opinion

Please don't randomly change bug statuses.

Can this bug be reproduced in 12.10 or the development release (13.04)?

Changed in update-manager (Ubuntu):
status: Opinion → Incomplete
Dario Ruellan (druellan) wrote :

Can't reproduce on Ubuntu 12.10
I've carried on this test:

On Ternminal
> sudo apt-get update
After apt-get finished fetching, I waited until software-updater started.
An icon wiggled on the launcher, the Terminal did NOT lost focus.

well, it looks like this bug has been fixed in later versions. If someone feels that it is worth backporting, please follow the backporting procedures: https://wiki.ubuntu.com/UbuntuBackports

Changed in update-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers