Can't install 'ubuntu-desktop' on Jaunty final release

Bug #367883 reported by Dave M G on 2009-04-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntu-desktop

I tried to use the update manager to upgrade from 8.10 to Jaunty 9.04 final release version (on April 27), and it did a partial upgrade and aborted without much warning. It left my computer in an unstable state, where applications, like Gnome applets, were crashing.

I rebooted, and Compiz won't load, and it won't read data CDs, and Nautilus won't run.

I tried running the upgrade again, and got this error:

Can't install 'ubuntu-desktop'
It was impossible to install a required package. Please report this as a bug.

When I close that window, it gives me a window to install only one package, ubuntu-desktop. So I press the "Start upgrade..." button, and get this error:

The upgrade is now aborted. Your system could be in an unusable state. A recovery will run now (dpkg --configure -a).
Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.
installArchives() failed

After that, I press the "close" button on the error message, and the upgrade manager quits.

Here is the output of "dpkg --configure -a":

dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on checkbox-gtk; however:
  Package checkbox-gtk is not installed.
 ubuntu-desktop depends on gnome-applets; however:
  Package gnome-applets is not installed.
 ubuntu-desktop depends on gnome-session-canberra; however:
  Package gnome-session-canberra is not installed.
 ubuntu-desktop depends on gstreamer0.10-pulseaudio; however:
  Package gstreamer0.10-pulseaudio is not installed.
 ubuntu-desktop depends on nautilus; however:
  Package nautilus is not installed.
 ubuntu-desktop depends on notify-osd; however:
  Package notify-osd is not installed.
 ubuntu-desktop depends on pulseaudio; however:
  Package pulseaudio is not installed.
 ubuntu-desktop depends on pulseaudio-esound-compat; however:
  Package pulseaudio-esound-compat is not installed.
dpkg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ubuntu-desktop

I tried installing some dependancies with Synaptic, but they all in turn reported other dependency problems.

I've attached the contents of /var/log/dist-upgrade as instructed by the error message.

My computer is now in an unuseable state, so I hope someone can help me resolve this soon.

Dave M G (martin-autotelic) wrote :
affects: ubuntu-meta (Ubuntu) → update-manager (Ubuntu)
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please try to boot into the recovery boot option and select fix broken packages there. Or run
(in a terminal):
$ sudo apt-get install -f

Changed in update-manager (Ubuntu):
status: New → Incomplete
Michael Vogt (mvo) wrote :

The actual bug is:

(Reading database ... 145194 files and directories currently installed.)

Removing libxml-libxml-perl ...

Can't locate File/Basename.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl5/XML/SAX.pm line 15.

BEGIN failed--compilation aborted at /usr/share/perl5/XML/SAX.pm line 15.

Compilation failed in require at /usr/bin/update-perl-sax-parsers line 20.

BEGIN failed--compilation aborted at /usr/bin/update-perl-sax-parsers line 20.

dpkg: error processing libxml-libxml-perl (--remove):

 subprocess pre-removal script returned error exit status 2

affects: ubuntu-meta (Ubuntu) → libxml-libxml-perl (Ubuntu)
Dave M G (martin-autotelic) wrote :

Michael,

Thanks for the suggestions.

I tried the fix packages option at boot time, and running "sudo apt-get install -f".

Unfortunately. neither has changed the situation.

Dave M G (martin-autotelic) wrote :

I really needed to use my computer, so I reformatted the drive and installed Jaunty fresh.

So while that does not answer why the problem happened, I am now not experiencing any difficulties.

For me the bug is no longer an issue. Thanks for trying to help.

Michael Vogt (mvo) wrote :

Hey Dave,

what happend when you ran the options? The same error as above?

Evan Carroll (evancarroll) wrote :

The issue here is you simply didn't have File::Basename when you upgraded, because we can't trouble shoot this without the computer, and because this is a unique report, I'm going to close the ticket.

I'm just wondering if you deleted the file, or used cpanp to uninstall it.

Changed in libxml-libxml-perl (Ubuntu):
status: New → Incomplete
affects: libxml-libxml-perl (Ubuntu) → ubuntu
Jean-Baptiste Lallement (jibel) wrote :

I'm closing this report because the original reporter fixed it with a complete system reinstallation

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers