cannot update from ubuntu-studio 8.10 to 9.04

Bug #366715 reported by Uwe Koch on 2009-04-25
2
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

1) Description: Ubuntu 8.10
Release: 8.10
2) update-manager:
  Instalados: 1:0.93.35
  Candidato: 1:0.93.35
  Tabla de versión:
 *** 1:0.93.35 0
        500 http://archive.ubuntu.com intrepid-proposed/main Packages
        100 /var/lib/dpkg/status
     1:0.93.34 0
        500 http://it.archive.ubuntu.com intrepid-updates/main Packages
     1:0.93.32 0
        500 http://it.archive.ubuntu.com intrepid/main Packages
3) update smoothlessly from 8.10 to 9.04
4) update-manager gives up reporting no upgrade from ubuntu-studio 8.10 to 9.04

Uwe Koch (uwe-koch) wrote :
wantey (w2ntey) wrote :

why you thing what "cannot update"?
"update-manager gives up reporting no upgrade from Ubuntu-studio 8.10 to 9.04" what report?
Try
#sudo do-release-upgrade

and attach /etc/update-manager/meta-release
                 /etc/update-manager/release-upgrades

Uwe Koch (uwe-koch) wrote :

Hi wantey,

thanks for your prompt response. I have done what you suggested. Please find attached the files you requested. I meant the message report during the upgrade process.

Uwe Koch (uwe-koch) wrote :
Michael Vogt (mvo) wrote :

Hello Uwe, thanks for your bugreport.

The files look normal, are you behind a network proxy? Could you please attach ~/.update-manager-core/meta-release after you run update-manager?

Uwe Koch (uwe-koch) wrote :

O.K., thank you Michael. Please find the file attached. Some files did not download because of a weak wifi connection.

The original sources.list was modified downloading from www.sourceslist.eu . But I tried to restore the original sources.list as I used it before the download.

Uwe Koch (uwe-koch) wrote :

Ah, my fault, I am not behind a proxy.

Michael Vogt (mvo) wrote :

@uwe thanks for the update. is it working now for you? the meta-release file looks ok.

Michael Vogt (mvo) on 2009-04-29
Changed in update-manager (Ubuntu):
status: New → Incomplete
Uwe Koch (uwe-koch) wrote :

Nee, Michael. I am planning to try to update directly from an ISO image via DVD. If this does not work, well, I'll have to download my directory to a memory stick and reinstall from scratch.

Thanks anyways!

Michael Vogt (mvo) wrote :

Thanks, upgrading with the alternate CD should work in a case like this. But I wonder why its not displaying the upgrade button. What does
$ lsb_release -a
output?

What is does happen if you run "sudo do-release-upgrade" ?

Uwe Koch (uwe-koch) wrote :

Hi Michael,

lsb_release -a tells

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

But, as stated before, in a response to wantey, I never said I couldn't see the upgrade button. I can see it and I also tried the command line upgrade. Both processes where stopped at the point where it was calculating the new files download, reverting all what was done. The problem is, that I don't know why the process can't finish calculating. The problem arises almost at the end of the calculation.

I also tried to upgrade via the installed ISO file, but I must be doing something wrong.

For some reason, exactly the same upgrade problem arised on the PC I am writing now, which is more or less the same as the first one, except the fact that this one is a 64 bit distro and the other one a 32 bit. A common point was, that on both I installed the sources list from the www.sourceslist.eu page (I know, risk on my own).

This bug report is being closed. Please use the official Ubuntu mirrors for upgrading any packages as any others are not supported, and definitely not encouraged. Thank you.

Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers