Upon having selected auto-download, trying to install updates before finishing downloading returns an error

Bug #35041 reported by Dullin on 2006-03-15
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

I have selected the option to download update without my consent on my Ubuntu Dapper installation (flight 5). But a little problem as arisen.

When the manager was downloading the updates I wanted to know how dar it was and tried to go trough the update-manager menu to install the update (clicking the install-update button). Unfortunatly, this gabe me an error message :

E: Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the download directory

Wich is probably because the downloading process is being run in the background.

Wouldn't it be better that upon clickin the install-update button that you be taken to the normal pseudo-synaptic install procedure or that the download progress bar be shown?

Matt Zimmerman (mdz) on 2006-04-06
Changed in update-manager:
status: Unconfirmed → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

This behavior has been improved since then. There is now a clear message when you want to install the update and the database is locked for whatever reason. We are closing this report. Don't hesitate to submit any new bug.

Changed in update-manager:
status: Confirmed → Fix Released
Lynda Scheidt (lscheidt3593) wrote :

can somebody just heip me

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers